aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2022-07-17 10:41:45 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2022-07-17 10:41:45 +0000
commit376a027be75d1f39a05f18ce4a766b585305ba44 (patch)
tree0512acaf8c89b6e1a254a9f46329326cd53e07c7
parentf1fc9eed65fd6bfac035f48018ca5ad959420dfe (diff)
downloadports-376a027be75d1f39a05f18ce4a766b585305ba44.tar.gz
ports-376a027be75d1f39a05f18ce4a766b585305ba44.zip
emulators/dolphin-emu: Unbreak portsnap INDEX builds
Using COMPILER_VERSION as llvm dependency broke portsnap INDEX builds by bringing up a dependency to llvm6. Depending on LLVM_DEFAULT should fix this. Reported by: cperciva Discussed with: cperciva, jbeich
-rw-r--r--emulators/dolphin-emu/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index f2a6afd96032..a612042eca1e 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 5.0.16795
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -87,8 +88,9 @@ CMAKE_ARGS+= -DENABLE_GENERIC:BOOL=ON
.endif
.if ${CHOSEN_COMPILER_TYPE:Mclang}
-CMAKE_ARGS+= -DENABLE_LLVM:BOOL=ON
-LIB_DEPENDS+= libLLVM-${COMPILER_VERSION:C/.$//}.so:devel/llvm${COMPILER_VERSION:C/.$//}
+CMAKE_ARGS+= -DENABLE_LLVM:BOOL=ON \
+ -DLLVM_DIR=${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/cmake/llvm
+LIB_DEPENDS+= libLLVM-${LLVM_DEFAULT:C/^([6-9])0/\1/}.so:devel/llvm${LLVM_DEFAULT}
.else
CMAKE_ARGS+= -DENABLE_LLVM:BOOL=OFF
.endif