aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-10-18 23:39:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-10-18 23:39:51 +0000
commit37edd04c265bf13ad7d1b6ce539db1f184cb8f03 (patch)
tree551b2a37c72fa508ec4457fa24ea262747a2b52d
parentc02f916a07185e42088ac98268c4d5d46b000769 (diff)
downloadports-37edd04c265bf13ad7d1b6ce539db1f184cb8f03.tar.gz
ports-37edd04c265bf13ad7d1b6ce539db1f184cb8f03.zip
Use stage
Uncontionnally install examples in stage Modernize LIB_DEPENDS
Notes
Notes: svn path=/head/; revision=330796
-rw-r--r--www/cplanet/Makefile26
-rw-r--r--www/cplanet/pkg-plist1
2 files changed, 13 insertions, 14 deletions
diff --git a/www/cplanet/Makefile b/www/cplanet/Makefile
index 96901103180e..8311bdc1e755 100644
--- a/www/cplanet/Makefile
+++ b/www/cplanet/Makefile
@@ -10,25 +10,23 @@ MAINTAINER= bapt@FreeBSD.org
COMMENT= RSS Feed Aggregator that generate static html
BUILD_DEPENDS= ${LOCALBASE}/lib/libneo_cs.a:${PORTSDIR}/www/clearsilver
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libcurl.so:${PORTSDIR}/ftp/curl
LICENSE= BSD
-MAN1= cplanet.1
-
OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}/${MANPREFIX}/man/man1
+
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-atom.cs ${EXAMPLESDIR}
- ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-opml.cs ${EXAMPLESDIR}
- ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-rss.cs ${EXAMPLESDIR}
- ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.cs ${EXAMPLESDIR}
- ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.hdf ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/cplanet-atom.cs \
+ ${WRKSRC}/samples/cplanet-opml.cs \
+ ${WRKSRC}/samples/cplanet-rss.cs \
+ ${WRKSRC}/samples/cplanet.cs \
+ ${WRKSRC}/samples/cplanet.hdf ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/www/cplanet/pkg-plist b/www/cplanet/pkg-plist
index de70e3765405..3e44be409a06 100644
--- a/www/cplanet/pkg-plist
+++ b/www/cplanet/pkg-plist
@@ -1,4 +1,5 @@
bin/cplanet
+man/man1/cplanet.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-atom.cs
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-opml.cs
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-rss.cs