aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 09:00:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 09:00:32 +0000
commit380948e01837aa2873a7279408675039c283f58c (patch)
treeedea49d29f4a4e43bcb990e30846f8147020c5f4
parentd27944f7897f8e5697ccc963d86a64d113a5b7ae (diff)
downloadports-380948e01837aa2873a7279408675039c283f58c.tar.gz
ports-380948e01837aa2873a7279408675039c283f58c.zip
math/py-statsmodels: Update to 0.14.1
-rw-r--r--math/py-statsmodels/Makefile19
-rw-r--r--math/py-statsmodels/distinfo6
-rw-r--r--math/py-statsmodels/files/patch-pyproject.toml20
3 files changed, 34 insertions, 11 deletions
diff --git a/math/py-statsmodels/Makefile b/math/py-statsmodels/Makefile
index fc9907424951..6d9343f05aca 100644
--- a/math/py-statsmodels/Makefile
+++ b/math/py-statsmodels/Makefile
@@ -1,5 +1,5 @@
PORTNAME= statsmodels
-PORTVERSION= 0.14.0
+PORTVERSION= 0.14.1
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,17 +11,20 @@ WWW= https://github.com/statsmodels/statsmodels
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.26:lang/cython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.17,1:math/py-numpy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=1.3:science/py-scipy@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.17,1:math/py-numpy@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.33<4:lang/cython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.22.3,1<2,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.4:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=63.1.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6<9:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.22.3,1<2,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.25,1:math/py-pandas@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}patsy>=0.5.2:math/py-patsy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=1.3:science/py-scipy@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}patsy>=0.5.4:math/py-patsy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.4:science/py-scipy@${PY_FLAVOR}
USES= python shebangfix
-USE_PYTHON= autoplist concurrent cython distutils
+USE_PYTHON= autoplist concurrent cython pep517
SHEBANG_GLOB= *.py
diff --git a/math/py-statsmodels/distinfo b/math/py-statsmodels/distinfo
index b1e582a32024..9578578320cd 100644
--- a/math/py-statsmodels/distinfo
+++ b/math/py-statsmodels/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683478916
-SHA256 (statsmodels-0.14.0.tar.gz) = 6875c7d689e966d948f15eb816ab5616f4928706b180cf470fd5907ab6f647a4
-SIZE (statsmodels-0.14.0.tar.gz) = 19374614
+TIMESTAMP = 1703227906
+SHA256 (statsmodels-0.14.1.tar.gz) = 2260efdc1ef89f39c670a0bd8151b1d0843567781bcafec6cda0534eb47a94f6
+SIZE (statsmodels-0.14.1.tar.gz) = 20309647
diff --git a/math/py-statsmodels/files/patch-pyproject.toml b/math/py-statsmodels/files/patch-pyproject.toml
new file mode 100644
index 000000000000..7571e3077f7f
--- /dev/null
+++ b/math/py-statsmodels/files/patch-pyproject.toml
@@ -0,0 +1,20 @@
+--- pyproject.toml.orig 2023-12-07 13:22:55 UTC
++++ pyproject.toml
+@@ -3,14 +3,11 @@
+ # INSTALL_REQUIRES in setup.py
+ requires = [
+ "setuptools>=69.0.2; python_version>='3.12'",
+- "setuptools>=63.4.3",
++ "setuptools>=63.1.0",
+ "cython>=0.29.33,<4", # Sync with CYTHON_MIN_VER in setup
+- # Workaround for oldest supported numpy using 1.21.6, but SciPy 1.9.2+ requiring 1.22.3+
+- "oldest-supported-numpy; python_version!='3.10' or platform_system!='Windows' or platform_python_implementation=='PyPy'",
+- "numpy>=1.22.3,<2; python_version=='3.10' and platform_system=='Windows' and platform_python_implementation != 'PyPy'",
+- "numpy<2; python_version>='3.12'",
++ "numpy>=1.22.3,<2",
+ "scipy>=1.4",
+- "setuptools_scm[toml]>=8,<9"
++ "setuptools_scm[toml]>=6,<9"
+ ]
+ build-backend = "setuptools.build_meta"
+