aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-29 23:43:57 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-29 23:44:44 +0000
commit382c9a32980afe9d0e14d43d9e20b7242a54af59 (patch)
tree3c262c81eb4e947106937c881d9a487134e4c8d9
parentbacdef05a8dd44886cc915cccdd02a01be8938f1 (diff)
downloadports-382c9a32980afe9d0e14d43d9e20b7242a54af59.tar.gz
ports-382c9a32980afe9d0e14d43d9e20b7242a54af59.zip
archivers/py-patool: New port: portable command line archive file manager
Patool is an archive file manager. Various archive formats can be created, extracted, tested, listed, searched, repacked and compared with patool. The advantage of patool is its simplicity in handling archive files without having to remember a myriad of programs and options. The archive format is determined by the file(1) program and as a fallback by the archive file extension. patool supports 7z (.7z, .cb7), ACE (.ace, .cba), ADF (.adf), ALZIP (.alz), APE (.ape), AR (.a), ARC (.arc), ARJ (.arj), BZIP2 (.bz2), CAB (.cab), COMPRESS (.Z), CPIO (.cpio), DEB (.deb), DMS (.dms), FLAC (.flac), GZIP (.gz), ISO (.iso), LRZIP (.lrz), LZH (.lha, .lzh), LZIP (.lz), LZMA (.lzma), LZOP (.lzo), RPM (.rpm), RAR (.rar, .cbr), RZIP (.rz), SHN (.shn), TAR (.tar, .cbt), XZ (.xz), ZIP (.zip, .jar, .cbz) and ZOO (.zoo) archive formats. It relies on helper applications to handle those archive formats (for example bzip2 for BZIP2 archives). The archive formats TAR, ZIP, BZIP2 and GZIP are supported natively and do not require helper applications to be installed.
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-patool/Makefile22
-rw-r--r--archivers/py-patool/distinfo3
-rw-r--r--archivers/py-patool/pkg-descr21
4 files changed, 47 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 37852e243017..681b33f78d51 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -191,6 +191,7 @@
SUBDIR += py-lz4
SUBDIR += py-lzma
SUBDIR += py-lzstring
+ SUBDIR += py-patool
SUBDIR += py-pyminizip
SUBDIR += py-python-lhafile
SUBDIR += py-python-lzo
diff --git a/archivers/py-patool/Makefile b/archivers/py-patool/Makefile
new file mode 100644
index 000000000000..e010e887bf29
--- /dev/null
+++ b/archivers/py-patool/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= patool
+PORTVERSION= 1.12
+CATEGORIES= archivers python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= portable command line archive file manager
+WWW= https://github.com/wummel/patool/
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= wummel
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= 4928f3fc5083248ec83bbf6b02b5d9089c309100
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/py-patool/distinfo b/archivers/py-patool/distinfo
new file mode 100644
index 000000000000..937d71c388cd
--- /dev/null
+++ b/archivers/py-patool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680278476
+SHA256 (wummel-patool-1.12-4928f3fc5083248ec83bbf6b02b5d9089c309100_GH0.tar.gz) = 34ca0cd89cb868198e9bbbee93fb2a55b5dc68b79ca31238da3e7f0de567b7da
+SIZE (wummel-patool-1.12-4928f3fc5083248ec83bbf6b02b5d9089c309100_GH0.tar.gz) = 1990425
diff --git a/archivers/py-patool/pkg-descr b/archivers/py-patool/pkg-descr
new file mode 100644
index 000000000000..8124689aa22c
--- /dev/null
+++ b/archivers/py-patool/pkg-descr
@@ -0,0 +1,21 @@
+Patool is an archive file manager.
+
+Various archive formats can be created, extracted, tested, listed, searched,
+repacked and compared with patool. The advantage of patool is its simplicity in
+handling archive files without having to remember a myriad of programs and
+options.
+
+The archive format is determined by the file(1) program and as a fallback by
+the archive file extension.
+
+patool supports 7z (.7z, .cb7), ACE (.ace, .cba), ADF (.adf), ALZIP (.alz),
+APE (.ape), AR (.a), ARC (.arc), ARJ (.arj), BZIP2 (.bz2), CAB (.cab),
+COMPRESS (.Z), CPIO (.cpio), DEB (.deb), DMS (.dms), FLAC (.flac), GZIP (.gz),
+ISO (.iso), LRZIP (.lrz), LZH (.lha, .lzh), LZIP (.lz), LZMA (.lzma),
+LZOP (.lzo), RPM (.rpm), RAR (.rar, .cbr), RZIP (.rz), SHN (.shn),
+TAR (.tar, .cbt), XZ (.xz), ZIP (.zip, .jar, .cbz) and ZOO (.zoo) archive
+formats. It relies on helper applications to handle those archive formats (for
+example bzip2 for BZIP2 archives).
+
+The archive formats TAR, ZIP, BZIP2 and GZIP are supported natively and do not
+require helper applications to be installed.