aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-31 15:18:55 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-31 15:18:55 +0000
commit382d70fb84a22bae0af1de315bae3c199a3ed059 (patch)
tree17837888d5c23761152c721ce1f9e8b9ab345539
parentb0a447a3cf1e632738124f525faabc45783f8106 (diff)
downloadports-382d70fb84a22bae0af1de315bae3c199a3ed059.tar.gz
ports-382d70fb84a22bae0af1de315bae3c199a3ed059.zip
net/dante: update to 1.4.0
- Add LICENSE - Support stage PR: 191232 Submitted by: mp39590 gmail com Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=363619
-rw-r--r--irc/hexchat/Makefile2
-rw-r--r--net/dante/Makefile45
-rw-r--r--net/dante/distinfo4
-rw-r--r--net/dante/files/patch-configure11
-rw-r--r--net/dante/files/patch-ltmain.sh15
-rw-r--r--net/dante/pkg-message12
-rw-r--r--net/dante/pkg-plist19
7 files changed, 59 insertions, 49 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 4ec88cff6aab..ca2181af8515 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hexchat
PORTVERSION= 2.9.6.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://dl.hexchat.org/${PORTNAME}/
diff --git a/net/dante/Makefile b/net/dante/Makefile
index 2ef0e3577f2b..12bdab71b592 100644
--- a/net/dante/Makefile
+++ b/net/dante/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= dante
-PORTVERSION= 1.3.2
-CATEGORIES= net security
+PORTVERSION= 1.4.0
+CATEGORIES= net security ipv6
MASTER_SITES= ftp://ftp.inet.no/pub/socks/ \
ftp://ftp.nuug.no/pub/anders/distfiles/ \
http://atreides.freenix.no/~anders/ \
@@ -12,6 +12,8 @@ MASTER_SITES= ftp://ftp.inet.no/pub/socks/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= Circuit-level firewall/proxy
+LICENSE= BSD
+
CONFLICTS= socks5-[0-9]*
GNU_CONFIGURE= yes
@@ -20,25 +22,34 @@ CONFIGURE_ARGS= --with-socks-conf=${PREFIX}/etc/socks.conf \
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+USES= libtool
USE_LDCONFIG= yes
-
USE_RC_SUBR= sockd
-LICENSE= BSD
+OPTIONS_DEFINE= DOCS EXAMPLES
-MAN1= socksify.1
-MAN5= sockd.conf.5 socks.conf.5
-MAN8= sockd.8
+.include <bsd.port.pre.mk>
-NO_STAGE= yes
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/example/socks.conf ${PREFIX}/etc/socks.conf.example
- @${INSTALL_DATA} ${WRKSRC}/example/sockd.conf ${PREFIX}/etc/sockd.conf.example
-.if !defined(NOPORTDOCS)
- ${INSTALL} -d -m 555 ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/README* ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/rfc* ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/SOCKS4*.protocol ${DOCSDIR}
+.if ${OSVERSION} >= 1000044
+CONFIGURE_ARGS+= --with-libc=libc.so.7
.endif
-.include <bsd.port.mk>
+.include <bsd.port.options.mk>
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/example/socks.conf ${STAGEDIR}${PREFIX}/etc/socks.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/example/sockd.conf ${STAGEDIR}${PREFIX}/etc/sockd.conf.sample
+ ${INSTALL} -d -m 555 ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/sockd-basic.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/sockd-chaining.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/socks-simple-withoutnameserver.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/socks-simple.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL} -d -m 555 ${STAGEDIR}${DOCSDIR}
+ ${INSTALL} -d -m 555 ${STAGEDIR}${DOCSDIR}/contrib
+ ${INSTALL_DATA} ${WRKSRC}/doc/README* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/rfc* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/SOCKS4*.protocol ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/UPGRADE ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/sockd-stat.awk ${STAGEDIR}${DOCSDIR}/contrib/sockd-stat.awk
+
+.include <bsd.port.post.mk>
diff --git a/net/dante/distinfo b/net/dante/distinfo
index d7666074edfd..4c6e32f9de14 100644
--- a/net/dante/distinfo
+++ b/net/dante/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dante-1.3.2.tar.gz) = 6b736f32ec58b899c24cf14be02491a0631a778e385314370d5dea4baf482efb
-SIZE (dante-1.3.2.tar.gz) = 949049
+SHA256 (dante-1.4.0.tar.gz) = 55d448f2d523e69b5637ef12c05556f39201a2c397b4671a2aaaa914ba65684b
+SIZE (dante-1.4.0.tar.gz) = 1253458
diff --git a/net/dante/files/patch-configure b/net/dante/files/patch-configure
deleted file mode 100644
index 89180b1a4464..000000000000
--- a/net/dante/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2011-06-20 18:01:06.000000000 +0200
-+++ configure 2011-07-12 15:49:45.602728013 +0200
-@@ -33876,7 +33876,7 @@
-
-
-
--for ac_header in gssapi.h gssapi/gssapi.h gssapi/gssapi_ext.h
-+for ac_header in gssapi/gssapi.h gssapi/gssapi_ext.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
diff --git a/net/dante/files/patch-ltmain.sh b/net/dante/files/patch-ltmain.sh
deleted file mode 100644
index 9c3b78292e8b..000000000000
--- a/net/dante/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig 2008-08-12 19:06:26.000000000 +0200
-+++ ltmain.sh 2011-07-12 16:01:37.595732703 +0200
-@@ -6115,10 +6115,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $extra_mode $instname $destdir/$name"
- $run eval "$install_prog $extra_mode $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/dante/pkg-message b/net/dante/pkg-message
new file mode 100644
index 000000000000..8d9b74910c01
--- /dev/null
+++ b/net/dante/pkg-message
@@ -0,0 +1,12 @@
+
+******************* IMPORTANT UPGRADE NOTIFICATION *******************
+
+If you're upgrading from earlier release to 1.4.x, please read UPGRADE
+document, which is installed in docs folder, or check it online:
+
+http://www.inet.no/dante/doc/1.4.x/config/upgrade.html
+
+The 1.4.x release has syntax changes and various new functionality
+additions.
+
+******************* IMPORTANT UPGRADE NOTIFICATION *******************
diff --git a/net/dante/pkg-plist b/net/dante/pkg-plist
index c7cb15122809..634a13301eaa 100644
--- a/net/dante/pkg-plist
+++ b/net/dante/pkg-plist
@@ -1,19 +1,32 @@
@unexec %D/etc/rc.d/sockd.sh forcestop 2>/dev/null || true
bin/socksify
-etc/sockd.conf.example
-etc/socks.conf.example
+@sample etc/sockd.conf.sample
+@sample etc/socks.conf.sample
include/socks.h
lib/libdsocks.so
lib/libsocks.a
lib/libsocks.so
-lib/libsocks.so.1
+lib/libsocks.so.0
+lib/libsocks.so.0.1.1
sbin/sockd
+man/man1/socksify.1.gz
+man/man5/sockd.conf.5.gz
+man/man5/socks.conf.5.gz
+man/man8/sockd.8.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sockd-basic.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sockd-chaining.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socks-simple-withoutnameserver.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socks-simple.conf
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/README.socksify
%%PORTDOCS%%%%DOCSDIR%%/README.survey
%%PORTDOCS%%%%DOCSDIR%%/README.usage
%%PORTDOCS%%%%DOCSDIR%%/SOCKS4.protocol
%%PORTDOCS%%%%DOCSDIR%%/SOCKS4A.protocol
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
+%%PORTDOCS%%%%DOCSDIR%%/contrib/sockd-stat.awk
%%PORTDOCS%%%%DOCSDIR%%/rfc1928.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc1929.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc1961.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
%%PORTDOCS%%@dirrm %%DOCSDIR%%