aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-06 16:14:11 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-06 16:14:11 +0000
commit382f3580d4faba8a77c389912babee75843e452e (patch)
tree1e907054bb1cce653e7533f901aa3858127e09bb
parentad01b750f75b3b81609fef13c80250c658c00df8 (diff)
downloadports-382f3580d4faba8a77c389912babee75843e452e.tar.gz
ports-382f3580d4faba8a77c389912babee75843e452e.zip
Add rssowl.
RSSOwl is a free, opensource RSS / RDF / Atom Newsreader. Some special features are: - Export News to PDF, HTML, RTF, OPML - Import Favorites from OPML - Full text-search with syntax-highlight of the results - Powerful Newsfeed search-engine - View news in internal browser - Manage favorites in categories (Drag and Drop support) - Runs on Windows, Linux, Solaris and Mac For a complete list of features, see: http://www.rssowl.org/overview WWW: http://www.rssowl.org/ PR: ports/92708 Submitted by: Matthias Sund <m.sund@arcor.de>
Notes
Notes: svn path=/head/; revision=155346
-rw-r--r--www/Makefile1
-rw-r--r--www/rssowl/Makefile64
-rw-r--r--www/rssowl/distinfo3
-rw-r--r--www/rssowl/pkg-descr14
-rw-r--r--www/rssowl/pkg-message4
5 files changed, 86 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8f402401cf8c..f3e20173e54d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -806,6 +806,7 @@
SUBDIR += rnews
SUBDIR += roundup
SUBDIR += roxen
+ SUBDIR += rssowl
SUBDIR += rt2
SUBDIR += rt3
SUBDIR += rt3-elixus
diff --git a/www/rssowl/Makefile b/www/rssowl/Makefile
new file mode 100644
index 000000000000..5c32ff678009
--- /dev/null
+++ b/www/rssowl/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: rssowl
+# Date created: February, 1st 2006
+# Whom: Matthias Sund <m.sund@arcor.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rssowl
+PORTVERSION= 1.1.3
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= rssowl
+DISTNAME= rssowl_${PORTVERSION:S|.|_|g}_src
+
+MAINTAINER= m.sund@arcor.de
+COMMENT= Portable RSS, RDF, Atom Newsfeeds reader
+
+BUILD_DEPENDS= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31
+RUN_DEPENDS= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31
+
+USE_X_PREFIX= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+JAVA_RUN= yes
+
+USE_ANT= yes
+ALL_TARGET= deploy_linux
+
+PLIST_FILES= bin/rssowl %%DATADIR%%/rssowl.jar share/pixmaps/rssowl.png
+PLIST_DIRS= %%DATADIR%%
+
+DESKTOP_ENTRIES="RSSOwl" \
+ "Read newsfeeds" \
+ "rssowl.png" \
+ "rssowl" \
+ "Application;Network;News;" \
+ true
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${java\.io\.tmpdir}/source/|$${basedir}/temp/|; \
+ s|$${root}/lib/swt\.jar|${JAVALIBDIR}/swt.jar|' \
+ ${BUILD_WRKSRC}/build.xml
+
+post-build:
+ @${ECHO_CMD} '#!/bin/sh' > ${WRKSRC}/rssowl
+ @${ECHO_CMD} "exec java -jar ${DATADIR}/rssowl.jar" >> ${WRKSRC}/rssowl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rssowl ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/rssowl.jar ${DATADIR}
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/img/32x32.png ${PREFIX}/share/pixmaps/rssowl.png
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/rssowl/distinfo b/www/rssowl/distinfo
new file mode 100644
index 000000000000..5ae12d4c2655
--- /dev/null
+++ b/www/rssowl/distinfo
@@ -0,0 +1,3 @@
+MD5 (rssowl_1_1_3_src.tar.gz) = 6d7612ccc45f2ab6aba68c4f4fc9bf2f
+SHA256 (rssowl_1_1_3_src.tar.gz) = 42af68133ceee6d0c481307312740eec37cdf2c7691c5ada0f5cd45ff190d3c8
+SIZE (rssowl_1_1_3_src.tar.gz) = 4030195
diff --git a/www/rssowl/pkg-descr b/www/rssowl/pkg-descr
new file mode 100644
index 000000000000..f27fc52939f6
--- /dev/null
+++ b/www/rssowl/pkg-descr
@@ -0,0 +1,14 @@
+RSSOwl is a free, opensource RSS / RDF / Atom Newsreader.
+Some special features are:
+
+ - Export News to PDF, HTML, RTF, OPML
+ - Import Favorites from OPML
+ - Full text-search with syntax-highlight of the results
+ - Powerful Newsfeed search-engine
+ - View news in internal browser
+ - Manage favorites in categories (Drag and Drop support)
+ - Runs on Windows, Linux, Solaris and Mac
+
+For a complete list of features, see: http://www.rssowl.org/overview
+
+WWW: http://www.rssowl.org/
diff --git a/www/rssowl/pkg-message b/www/rssowl/pkg-message
new file mode 100644
index 000000000000..c462703ed9ed
--- /dev/null
+++ b/www/rssowl/pkg-message
@@ -0,0 +1,4 @@
+===============================================================================
+This port includes software with different (mainly OSI approved) licenses.
+See LICENSE.txt in the documentation for a detailed description.
+===============================================================================