aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:14:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:14:02 +0000
commit38cbe5cc9e99750df54915725121abf28135a148 (patch)
tree308ec6a88700b00819d64b8c4aeca9c20dd8bd87
parent21bc5c0345300431d6e3edc6c43d743c61fc7b5e (diff)
downloadports-38cbe5cc9e99750df54915725121abf28135a148.tar.gz
ports-38cbe5cc9e99750df54915725121abf28135a148.zip
Remove USE_FIREBIRD from bsd.databases.mk, replaced by USES=firebird.
Also: - replace USE_FIREBIRD by USES=firebird. - convert ports depending on databases/firebird25-client directly to USES=firebird. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Notes
Notes: svn path=/head/; revision=414015
-rw-r--r--Mk/bsd.database.mk29
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--Mk/bsd.sanity.mk5
-rw-r--r--databases/firebird25-server/Makefile2
-rw-r--r--databases/flamerobin/Makefile3
-rw-r--r--databases/fpc-ibase/Makefile2
-rw-r--r--databases/p5-DBD-InterBase/Makefile4
-rw-r--r--databases/py-fdb/Makefile4
-rw-r--r--databases/qt4-ibase-plugin/Makefile2
-rw-r--r--databases/qt5-sqldrivers-ibase/Makefile2
-rw-r--r--databases/soci/Makefile2
-rw-r--r--databases/sqlrelay/Makefile2
-rw-r--r--devel/matreshka/Makefile2
-rw-r--r--editors/libreoffice/Makefile5
-rw-r--r--security/hydra/Makefile2
15 files changed, 16 insertions, 52 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 2309e5bc1fea..6b258c9c28a9 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -75,15 +75,6 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# the Berkeley DB library directory.
# BDB_VER
# - Detected Berkeley DB version.
-##
-# USE_FIREBIRD - Add dependency on Firebird library. Valid values are:
-# 2 and 1. If no version is given by the maintainer (if
-# USE_FIREBIRD= yes) and the user did not define
-# WITH_FIREBIRD_VER variable, fall back to default "2".
-# WITH_FIREBIRD_VER
-# - User defined variable to set Firebird version.
-# FIREBIRD_VER
-# - Detected Firebird version.
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
@@ -375,24 +366,4 @@ IGNORE= ${_IGNORE_MSG}
.endif # USE_BDB
-.if defined(USE_FIREBIRD)
-
-.if defined(WITH_FIREBIRD_VER)
-USE_FIREBIRD= ${WITH_FIREBIRD_VER}
-.endif
-
-.if ${USE_FIREBIRD:tl} == "yes"
-FIREBIRD_VER= ${FIREBIRD_DEFAULT:S/.//}
-.else
-FIREBIRD_VER= ${USE_FIREBIRD}
-.endif
-
-.if ${FIREBIRD_VER} == "25"
-LIB_DEPENDS+= libfbclient.so:databases/firebird25-client
-.else
-IGNORE= cannot install: unknown Firebird version: ${FIREBIRD_VER}
-.endif
-
-.endif # defined(USE_FIREBIRD)
-
.endif # defined(_POSTMKINCLUDED) && !defined(Database_Post_Include)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 469427c9966e..34a356df9dd2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1864,7 +1864,7 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.endif
.if defined(USE_MYSQL) || defined(WANT_MYSQL_VER) || \
- defined(USE_BDB) || defined(USE_FIREBIRD)
+ defined(USE_BDB)
.include "${PORTSDIR}/Mk/bsd.database.mk"
.endif
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index ef122ba08355..12cd532d4fe9 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -168,9 +168,8 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
INSTALLS_SHLIB USE_PYDISTUTILS PYTHON_CONCURRENT_INSTALL \
PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO \
USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT \
- UNIQUENAME LATEST_LINK USE_SQLITE
-SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS PLIST_DIRSTRY \
- USE_FIREBIRD
+ UNIQUENAME LATEST_LINK USE_SQLITE USE_FIREBIRD
+SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS PLIST_DIRSTRY
SANITY_NOTNEEDED= WX_UNICODE
USE_AUTOTOOLS_ALT= USES=autoreconf and GNU_CONFIGURE=yes
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index e99a7734e73d..e25fd222f5c3 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -72,7 +72,7 @@ IGNORE= your system does not support sysvipc
.if !defined(CLIENT_ONLY)
# Server part stuff
-LIB_DEPENDS+= libfbembed.so:databases/firebird25-client
+USES+= firebird
CONFIGURE_ARGS+=--enable-superserver --without-editline
diff --git a/databases/flamerobin/Makefile b/databases/flamerobin/Makefile
index bdd7d9c4cf7f..595369a38654 100644
--- a/databases/flamerobin/Makefile
+++ b/databases/flamerobin/Makefile
@@ -16,8 +16,7 @@ LICENSE_NAME= FlameRobin Expat
LICENSE_FILE= ${WRKSRC}/docs/fr_license.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= compiler
-USE_FIREBIRD= yes
+USES= compiler firebird
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
diff --git a/databases/fpc-ibase/Makefile b/databases/fpc-ibase/Makefile
index 45603a4eedc3..c13f5dc5bec1 100644
--- a/databases/fpc-ibase/Makefile
+++ b/databases/fpc-ibase/Makefile
@@ -17,6 +17,6 @@ OPTIONS_DEFINE= IBASE
IBASE_DESC= Install Interbase/Firebird client
OPTIONS_DEFAULT= IBASE
-IBASE_USE= FIREBIRD=yes
+IBASE_USES= firebird
.include "${MASTERDIR}/Makefile"
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
index 8977788490dd..a8adaea93822 100644
--- a/databases/p5-DBD-InterBase/Makefile
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -14,9 +14,7 @@ COMMENT= DBI driver for InterBase/Firebird/Yaffil RDBMS server
BUILD_DEPENDS= p5-DBI>=0:databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_FIREBIRD= yes
-
-USES= perl5
+USES= perl5 firebird
USE_PERL5= patch configure
post-patch:
diff --git a/databases/py-fdb/Makefile b/databases/py-fdb/Makefile
index 906c515c79bc..2aa4dd99cc72 100644
--- a/databases/py-fdb/Makefile
+++ b/databases/py-fdb/Makefile
@@ -12,10 +12,8 @@ COMMENT= Firebird RDBMS bindings for Python
LICENSE= ISCL
-LIB_DEPENDS= libfbclient.so:databases/firebird25-client
-
NO_ARCH= yes
-USES= python
+USES= firebird python
USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
diff --git a/databases/qt4-ibase-plugin/Makefile b/databases/qt4-ibase-plugin/Makefile
index 8bd8e63b986a..f148f8bc3497 100644
--- a/databases/qt4-ibase-plugin/Makefile
+++ b/databases/qt4-ibase-plugin/Makefile
@@ -5,6 +5,6 @@ PORTREVISION= 1
COMMENT= Qt InterBase/Firebird database plugin
DB= ibase
-USE_FIREBIRD= yes
+USES+= firebird
.include "${.CURDIR:H:H}/devel/qt4/Makefile.sqldrivers"
diff --git a/databases/qt5-sqldrivers-ibase/Makefile b/databases/qt5-sqldrivers-ibase/Makefile
index 2f7aad4ddb92..416bdb2f6df6 100644
--- a/databases/qt5-sqldrivers-ibase/Makefile
+++ b/databases/qt5-sqldrivers-ibase/Makefile
@@ -3,6 +3,6 @@
DB= IBase
DB_DESC= InterBase/Firebird
-USE_FIREBIRD= yes
+USES= firebird
.include "${.CURDIR:H:H}/devel/qt5/Makefile.sqldrivers"
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index 82155ae179d8..6e55d0067ce1 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -46,7 +46,7 @@ BOOST_LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
BOOST_CMAKE_ON= -DWITH_BOOST:BOOL=ON
BOOST_CMAKE_OFF= -DWITH_BOOST:BOOL=OFF
-FIREBIRD_USE= FIREBIRD=yes
+FIREBIRD_USES= firebird
FIREBIRD_CMAKE_ARGS_ON= -DWITH_FIREBIRD:BOOL=ON
FIREBIRD_CMAKE_ARGS_OFF= -DWITH_FIREBIRD:BOOL=OFF
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index a54b23cbf0b6..4f4382968188 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -110,7 +110,7 @@ CONFIGURE_ARGS+= --disable-mysql
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= yes
+USES+= firebird
CONFIGURE_ARGS+= --with-firebird-prefix="${LOCALBASE}"
TOSTRIP+= libexec/sqlrelay/sqlrconnection_firebird.so
.else
diff --git a/devel/matreshka/Makefile b/devel/matreshka/Makefile
index 2be36ff624a1..454801ccb154 100644
--- a/devel/matreshka/Makefile
+++ b/devel/matreshka/Makefile
@@ -32,7 +32,7 @@ AMF_CONFIGURE_ENABLE= amf
MYSQL_USE= MYSQL=yes
PGSQL_USES= pgsql
SQLITE3_USES= sqlite
-FIREBIRD_USE= FIREBIRD=yes
+FIREBIRD_USES= firebird
MAKE_JOBS_UNSAFE= yes
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 6dd3b4a0da3e..1986ff845997 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -27,8 +27,7 @@ BUILD_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
${LOCALBASE}/include/glm/glm.hpp:math/glm \
bash:shells/bash \
gsed:textproc/gsed
-LIB_DEPENDS= libfbembed.so:databases/firebird25-client \
- libapr-1.so:devel/apr1 \
+LIB_DEPENDS= libapr-1.so:devel/apr1 \
libboost_date_time.so:devel/boost-libs \
libicutu.so:devel/icu \
liblangtag.so:devel/liblangtag \
@@ -96,7 +95,7 @@ USE_OPENLDAP= yes
USE_PERL5= build
USE_QT4= # empty but required
USE_XORG= xaw xrandr
-USES= bison compiler:c++11-lib cpe gmake jpeg perl5 pkgconfig \
+USES= bison compiler:c++11-lib cpe firebird gmake jpeg perl5 pkgconfig \
python shared-mime-info tar:xz
WANT_GNOME= yes
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index fecfdf0e6288..de0592bcb6fc 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -28,7 +28,7 @@ WANT_GNOME= yes
OPTIONS_DEFINE= FIREBIRD SSH SVN X11
OPTIONS_DEFAULT=SSH
OPTIONS_EXCLUDE=NLS DOCS
-FIREBIRD_LIB_DEPENDS= libfbclient.so:databases/firebird25-client
+FIREBIRD_USES= firebird
SVN_LIB_DEPENDS= libsvn_client-1.so:devel/subversion
.include <bsd.port.options.mk>