aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:41:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:42:23 +0000
commit3953bedae45d50eb391605627aebbfdfdc0181c5 (patch)
tree5026ac5a7355acc3d7238246e448c2a82e1da23e
parentde21c17f452c2ccd8b60f2a525b746490ac79814 (diff)
downloadports-3953bedae45d50eb391605627aebbfdfdc0181c5.tar.gz
ports-3953bedae45d50eb391605627aebbfdfdc0181c5.zip
graphics/py-optimize-images: Add py-optimize-images 1.5.1
Optimize Images is a command-line interface (CLI) utility written in pure Python to help you reduce the file size of images. This application is intended to be pure Python, with no special dependencies besides Pillow, therefore ensuring compatibility with a wide range of systems. Some aditional features can be added which require the presence of other third-party packages that are not written in pure Python, but those packages and the features depending on them should be treated as optional. WWW: https://github.com/victordomingos/optimize-images
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-optimize-images/Makefile25
-rw-r--r--graphics/py-optimize-images/distinfo3
-rw-r--r--graphics/py-optimize-images/pkg-descr11
4 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fe6b20ecde5f..07ff43a63a3b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -885,6 +885,7 @@
SUBDIR += py-opencolorio
SUBDIR += py-openimageio
SUBDIR += py-openshadinglanguage
+ SUBDIR += py-optimize-images
SUBDIR += py-osmnet
SUBDIR += py-pandana
SUBDIR += py-photocollage
diff --git a/graphics/py-optimize-images/Makefile b/graphics/py-optimize-images/Makefile
new file mode 100644
index 000000000000..81861cba8f9d
--- /dev/null
+++ b/graphics/py-optimize-images/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= optimize-images
+PORTVERSION= 1.5.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CLI utility to reduce the file size of images
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}piexif>=1.1.3:graphics/py-piexif@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=8.2.0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}watchdog>=2.1.2:devel/py-watchdog@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}piexif>=1.1.3:graphics/py-piexif@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=8.2.0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}watchdog>=2.1.2:devel/py-watchdog@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-optimize-images/distinfo b/graphics/py-optimize-images/distinfo
new file mode 100644
index 000000000000..367e49f0d6b3
--- /dev/null
+++ b/graphics/py-optimize-images/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662212108
+SHA256 (optimize-images-1.5.1.tar.gz) = 35f073d434575556398f60d19dfc9f9d6209482ebe3aa11d508205bfe25d4dc8
+SIZE (optimize-images-1.5.1.tar.gz) = 24368
diff --git a/graphics/py-optimize-images/pkg-descr b/graphics/py-optimize-images/pkg-descr
new file mode 100644
index 000000000000..a886b62360ed
--- /dev/null
+++ b/graphics/py-optimize-images/pkg-descr
@@ -0,0 +1,11 @@
+Optimize Images is a command-line interface (CLI) utility written in pure Python
+to help you reduce the file size of images.
+
+This application is intended to be pure Python, with no special dependencies
+besides Pillow, therefore ensuring compatibility with a wide range of systems.
+
+Some aditional features can be added which require the presence of other
+third-party packages that are not written in pure Python, but those packages and
+the features depending on them should be treated as optional.
+
+WWW: https://github.com/victordomingos/optimize-images