aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:40:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:39 +0000
commit3972be552723188588177ccaf957cc112ef59b78 (patch)
tree7d74ae85d46de035538da49e3ac5c95dbeacf94b
parent8fda83e53ea9f3da8b7727517fa96ccda68d8cab (diff)
downloadports-3972be552723188588177ccaf957cc112ef59b78.tar.gz
ports-3972be552723188588177ccaf957cc112ef59b78.zip
devel/libiqxmlrpc: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/libiqxmlrpc/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index 1bf5c482fac0..1cc29ee6458f 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -12,19 +12,19 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+USES= cmake gnome localbase:ldflags ssl tar:bzip2
+USE_CXXSTD= c++14
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+PORTDOCS= *
+
OPTIONS_DEFINE= DOXYGEN DOCS
DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CMAKE_OFF= -Dbuild_docs=off
-USE_GNOME= libxml2
-USES= cmake gnome ssl tar:bzip2
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
-
-PORTDOCS= *
-
post-patch:
${REINPLACE_CMD} -e 's,lib/pkgconfig,libdata/pkgconfig,' ${WRKSRC}/libiqxmlrpc/CMakeLists.txt
${REINPLACE_CMD} -e 's,share/doc/libiqxmlrpc-$${Libiqxmlrpc_VERSION},${DOCSDIR_REL},' ${WRKSRC}/doc/CMakeLists.txt