aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 11:38:29 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 11:38:29 +0000
commit39a7f86255001d4b80a591c9e73b6201ee277dda (patch)
tree6ca34d2b88ef8d4d5b27e8df8b52a5eac7ad64b6
parentac04188cee57a6d79cb9555e00ff68a31521173f (diff)
downloadports-39a7f86255001d4b80a591c9e73b6201ee277dda.tar.gz
ports-39a7f86255001d4b80a591c9e73b6201ee277dda.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Notes
Notes: svn path=/head/; revision=93882
-rw-r--r--audio/festdoc/Makefile4
-rw-r--r--audio/festival+OGI/Makefile2
-rw-r--r--audio/festival/Makefile2
-rw-r--r--audio/festlex-cmu/Makefile2
-rw-r--r--audio/festlex-oald/Makefile2
-rw-r--r--audio/festlex-ogi/Makefile2
-rw-r--r--audio/festlex-poslex/Makefile2
-rw-r--r--audio/festogi-spanish/Makefile4
-rw-r--r--audio/festvox-abc/Makefile4
-rw-r--r--audio/festvox-don/Makefile2
-rw-r--r--audio/festvox-el11/Makefile2
-rw-r--r--audio/festvox-hvs/Makefile4
-rw-r--r--audio/festvox-jph/Makefile4
-rw-r--r--audio/festvox-kal16/Makefile2
-rw-r--r--audio/festvox-kal8/Makefile2
-rw-r--r--audio/festvox-ked16/Makefile2
-rw-r--r--audio/festvox-ked8/Makefile2
-rw-r--r--audio/festvox-mwm/Makefile4
-rw-r--r--audio/festvox-ogirab/Makefile4
-rw-r--r--audio/festvox-rab16/Makefile2
-rw-r--r--audio/festvox-rab8/Makefile2
-rw-r--r--audio/festvox-tll/Makefile4
-rw-r--r--audio/holyshout/Makefile2
23 files changed, 31 insertions, 31 deletions
diff --git a/audio/festdoc/Makefile b/audio/festdoc/Makefile
index b9bfab5cd68b..02b67c8da677 100644
--- a/audio/festdoc/Makefile
+++ b/audio/festdoc/Makefile
@@ -24,7 +24,7 @@ FDOC= ${PREFIX}/share/doc/festival
post-extract:
${CHMOD} -R a+r ${WRKSRC}
- ${FIND} ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
${RM} ${WRKSRC}/festival/src-manual/c3750.htm~
${RM} ${WRKSRC}/speechtools/c16909.htm~
${RMDIR} ${WRKSRC}/festival/src-manual/images_gen
@@ -32,7 +32,7 @@ post-extract:
do-install:
${MKDIR} ${FDOC}
${RM} ${WRKSRC}/festival/info/festival.info.orig
- cd ${WRKSRC} && info=`find . -name '*.info*' -type f` && \
+ cd ${WRKSRC} && info=`${FIND} . -name '*.info*' -type f` && \
${CP} $$info ${PREFIX}/info && \
${CP} -r ${WRKSRC}/* ${FDOC} && \
cd ${FDOC} && \
diff --git a/audio/festival+OGI/Makefile b/audio/festival+OGI/Makefile
index c8b7977d17b6..f78f62b06d21 100644
--- a/audio/festival+OGI/Makefile
+++ b/audio/festival+OGI/Makefile
@@ -133,7 +133,7 @@ do-install:
${MKDIR} ${FHOME}/lib/voices/spanish/
${MKDIR} ${FHOME}/lib/dicts
${CHMOD} -R u+w,a+r,og-w ${FESTIVAL}/lib
- ${FIND} ${FESTIVAL}/lib -type d -print0 | xargs -0 ${CHMOD} 755
+ ${FIND} ${FESTIVAL}/lib -type d -print0 | ${XARGS} -0 ${CHMOD} 755
cd ${FESTIVAL} && ${CP} -pPR lib examples ${FHOME}
${RM} -rf ${FHOME}/lib/etc/*FreeBSD*
${INSTALL_PROGRAM} ${FESTIVAL}/lib/etc/*FreeBSD*/audsp ${PREFIX}/libexec
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index c8b7977d17b6..f78f62b06d21 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -133,7 +133,7 @@ do-install:
${MKDIR} ${FHOME}/lib/voices/spanish/
${MKDIR} ${FHOME}/lib/dicts
${CHMOD} -R u+w,a+r,og-w ${FESTIVAL}/lib
- ${FIND} ${FESTIVAL}/lib -type d -print0 | xargs -0 ${CHMOD} 755
+ ${FIND} ${FESTIVAL}/lib -type d -print0 | ${XARGS} -0 ${CHMOD} 755
cd ${FESTIVAL} && ${CP} -pPR lib examples ${FHOME}
${RM} -rf ${FHOME}/lib/etc/*FreeBSD*
${INSTALL_PROGRAM} ${FESTIVAL}/lib/etc/*FreeBSD*/audsp ${PREFIX}/libexec
diff --git a/audio/festlex-cmu/Makefile b/audio/festlex-cmu/Makefile
index b7039fcd8893..7b428d57e519 100644
--- a/audio/festlex-cmu/Makefile
+++ b/audio/festlex-cmu/Makefile
@@ -28,7 +28,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festlex-oald/Makefile b/audio/festlex-oald/Makefile
index e9080fbdc318..e6eb8908cca4 100644
--- a/audio/festlex-oald/Makefile
+++ b/audio/festlex-oald/Makefile
@@ -30,7 +30,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festlex-ogi/Makefile b/audio/festlex-ogi/Makefile
index ba43d95c9025..f9d37f7c9862 100644
--- a/audio/festlex-ogi/Makefile
+++ b/audio/festlex-ogi/Makefile
@@ -30,7 +30,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festlex-poslex/Makefile b/audio/festlex-poslex/Makefile
index a569413b619d..7f0780b92b17 100644
--- a/audio/festlex-poslex/Makefile
+++ b/audio/festlex-poslex/Makefile
@@ -28,7 +28,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
diff --git a/audio/festogi-spanish/Makefile b/audio/festogi-spanish/Makefile
index b844525321fb..437e2c43c512 100644
--- a/audio/festogi-spanish/Makefile
+++ b/audio/festogi-spanish/Makefile
@@ -29,10 +29,10 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
pre-install:
- (find ${WRKSRC} -name CVS | xargs rm -rf)
+ (${FIND} ${WRKSRC} -name CVS | ${XARGS} rm -rf)
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-abc/Makefile b/audio/festvox-abc/Makefile
index 28c012bd932d..a1b6c454fac9 100644
--- a/audio/festvox-abc/Makefile
+++ b/audio/festvox-abc/Makefile
@@ -31,9 +31,9 @@ FHOME= ${PREFIX}/share/festival
post-extract:
${CHMOD} -R a+r ${WRKSRC}
- find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
${RM} -f ${WRKSRC}/lib/voices/spanish/abc_diphone/group/hvslpcOGI16k.group
- find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-don/Makefile b/audio/festvox-don/Makefile
index 281b1e807047..75fb12c207b4 100644
--- a/audio/festvox-don/Makefile
+++ b/audio/festvox-don/Makefile
@@ -30,7 +30,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-el11/Makefile b/audio/festvox-el11/Makefile
index e40aa7586ac1..99ada1efbd3d 100644
--- a/audio/festvox-el11/Makefile
+++ b/audio/festvox-el11/Makefile
@@ -30,7 +30,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-hvs/Makefile b/audio/festvox-hvs/Makefile
index 9a6a976a8cdb..6ca3c43a9f9c 100644
--- a/audio/festvox-hvs/Makefile
+++ b/audio/festvox-hvs/Makefile
@@ -32,8 +32,8 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
- @ find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-jph/Makefile b/audio/festvox-jph/Makefile
index 7ae1cb8fed85..b0f5c528dbd4 100644
--- a/audio/festvox-jph/Makefile
+++ b/audio/festvox-jph/Makefile
@@ -31,8 +31,8 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
- @ find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-kal16/Makefile b/audio/festvox-kal16/Makefile
index 1ef9bd62a636..f37909b0ba39 100644
--- a/audio/festvox-kal16/Makefile
+++ b/audio/festvox-kal16/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-kal8/Makefile b/audio/festvox-kal8/Makefile
index fcc9e300ccab..315b08300090 100644
--- a/audio/festvox-kal8/Makefile
+++ b/audio/festvox-kal8/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-ked16/Makefile b/audio/festvox-ked16/Makefile
index 192d57eaab77..a15b4bc68fce 100644
--- a/audio/festvox-ked16/Makefile
+++ b/audio/festvox-ked16/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-ked8/Makefile b/audio/festvox-ked8/Makefile
index 24010dea685e..35e0492f32cb 100644
--- a/audio/festvox-ked8/Makefile
+++ b/audio/festvox-ked8/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-mwm/Makefile b/audio/festvox-mwm/Makefile
index 5b9202636509..4b3ae7b9dfa7 100644
--- a/audio/festvox-mwm/Makefile
+++ b/audio/festvox-mwm/Makefile
@@ -31,8 +31,8 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
- @ find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-ogirab/Makefile b/audio/festvox-ogirab/Makefile
index e1201ca9dec0..86eb2371837c 100644
--- a/audio/festvox-ogirab/Makefile
+++ b/audio/festvox-ogirab/Makefile
@@ -30,8 +30,8 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
- find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-rab16/Makefile b/audio/festvox-rab16/Makefile
index 040c4f8505b6..2ba953a9c3ca 100644
--- a/audio/festvox-rab16/Makefile
+++ b/audio/festvox-rab16/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-rab8/Makefile b/audio/festvox-rab8/Makefile
index a21fc0fc3bc6..81694d8748d0 100644
--- a/audio/festvox-rab8/Makefile
+++ b/audio/festvox-rab8/Makefile
@@ -32,7 +32,7 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/festvox-tll/Makefile b/audio/festvox-tll/Makefile
index 9c6d38384532..68365c53cfbf 100644
--- a/audio/festvox-tll/Makefile
+++ b/audio/festvox-tll/Makefile
@@ -30,8 +30,8 @@ FHOME= ${PREFIX}/share/festival
post-extract:
@ ${CHMOD} -R a+r ${WRKSRC}
- find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
- find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
do-install:
${MKDIR} ${FHOME}
diff --git a/audio/holyshout/Makefile b/audio/holyshout/Makefile
index 1f6b883d9302..c7bf5997851f 100644
--- a/audio/holyshout/Makefile
+++ b/audio/holyshout/Makefile
@@ -17,7 +17,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
- (find ${WRKSRC} -name Makefile | xargs ${REINPLACE_CMD} -e \
+ (${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
"s@-O20@${CFLAGS}@g ; s@-O2@${CFLAGS}@g")
${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' \
${WRKSRC}/Makefile