aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-09-19 18:14:46 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-09-19 18:17:51 +0000
commit39e16722d6898a59b14014e9a92877388d3945f0 (patch)
tree66bea12e5fd975a4b6f8cd2cfdc41af66813199a
parentf089d2af6775567d633c46aa5cd6cc338d8bcabd (diff)
downloadports-39e16722d6898a59b14014e9a92877388d3945f0.tar.gz
ports-39e16722d6898a59b14014e9a92877388d3945f0.zip
deskutils/caja-extensions: Drop (G)UPnP support
All available versions of caja-extensions depends on legacy version of GUPnP which is unsupported upstream and doesn't build with newer versions of libxml2. Drop plugin for new until it's fixed upstream. gtk-doc is now a build dependency due to https://savannah.gnu.org/support/?110503 Reference: https://github.com/mate-desktop/caja-extensions/issues/110 PR: 273430 Approved by: portmgr (maintainer timeout, 2+ weeks) Sponsored by: Blinkinblox
-rw-r--r--deskutils/caja-extensions/Makefile13
-rw-r--r--deskutils/caja-extensions/files/patch-configure.ac20
-rw-r--r--deskutils/caja-extensions/pkg-plist1
3 files changed, 25 insertions, 9 deletions
diff --git a/deskutils/caja-extensions/Makefile b/deskutils/caja-extensions/Makefile
index 69dc75f1c1d1..49adfdffa5ce 100644
--- a/deskutils/caja-extensions/Makefile
+++ b/deskutils/caja-extensions/Makefile
@@ -1,6 +1,6 @@
PORTNAME= caja-extensions
PORTVERSION= 1.26.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -12,15 +12,15 @@ WWW= https://mate-desktop.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libgupnp-1.2.so:net/gupnp14 \
- libstartup-notification-1.so:x11/startup-notification \
+BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib
PORTSCOUT= limitw:1,even
-USES= compiler:c11 gettext gmake gnome libtool localbase mate \
- pathfix pkgconfig tar:xz
+USES= autoreconf compiler:c11 gettext gmake gnome libtool \
+ localbase mate pathfix pkgconfig tar:xz
USE_MATE= caja desktop
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
USE_LDCONFIG= yes
@@ -31,7 +31,4 @@ INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.Caja.Sendto.gschema.xml \
org.mate.caja-open-terminal.gschema.xml
-post-patch:
- @${REINPLACE_CMD} -e 's|gupnp-1.0|gupnp-1.2|' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/deskutils/caja-extensions/files/patch-configure.ac b/deskutils/caja-extensions/files/patch-configure.ac
new file mode 100644
index 000000000000..22d5c5dbbae2
--- /dev/null
+++ b/deskutils/caja-extensions/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac.orig 2021-08-06 19:34:59 UTC
++++ configure.ac
+@@ -100,7 +100,7 @@ if test "x$enable_sendto" = "xyes"; then
+ GTHREAD_REQUIRED=2.6.0
+ DBUS_REQUIRED=1.0
+ DBUS_GLIB_REQUIRED=0.60
+- GUPNP_REQUIRED=0.13
++# GUPNP_REQUIRED=0.13
+ PKG_CHECK_MODULES(SENDTO,
+ glib-2.0 >= $GLIB_REQUIRED
+ gthread-2.0 >= $GTHREAD_REQUIRED
+@@ -111,7 +111,7 @@ if test "x$enable_sendto" = "xyes"; then
+ AC_SUBST(SENDTO_LIBS)
+
+ # The full list of plugins
+- allowed_sendto_plugins="emailclient gajim caja-burn pidgin removable-devices upnp"
++ allowed_sendto_plugins="emailclient gajim caja-burn pidgin removable-devices"
+
+ sendto_plugin_error_or_ignore()
+ {
diff --git a/deskutils/caja-extensions/pkg-plist b/deskutils/caja-extensions/pkg-plist
index 0d34ad19f421..b9df83af761a 100644
--- a/deskutils/caja-extensions/pkg-plist
+++ b/deskutils/caja-extensions/pkg-plist
@@ -5,7 +5,6 @@ lib/caja-sendto/plugins/libnstemailclient.so
lib/caja-sendto/plugins/libnstgajim.so
lib/caja-sendto/plugins/libnstpidgin.so
lib/caja-sendto/plugins/libnstremovable_devices.so
-lib/caja-sendto/plugins/libnstupnp.so
lib/caja/extensions-2.0/libcaja-image-converter.so
lib/caja/extensions-2.0/libcaja-open-terminal.so
lib/caja/extensions-2.0/libcaja-sendto.so