aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-10 16:27:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-10 16:33:07 +0000
commit39f2c705c61fb27085aeaa49bdef553222b9d425 (patch)
tree61335874057a49b44a99ec9d34f116c187e8410c
parent590c58de6d73cb0ffc2f3db30cb9a0ccbf4ae7db (diff)
downloadports-39f2c705c61fb27085aeaa49bdef553222b9d425.tar.gz
ports-39f2c705c61fb27085aeaa49bdef553222b9d425.zip
math/py-gmpy2-devel: fix build with PYTHON_DEFAULT <3.7 >3.9
- Explicitly specify correct sphinx-build binary to use. Use versioned binary, as unversioned one may not be available (such as when building with default python=3.10; in this case PY_FLAVOR is py38 as this port does not yet support python 3.10, so it pulls sphinx-build@py38 which does not install sphinx-build as 3.8 is not default python version). - Fix LICENSE and add LICENSE_FILE - Do not try to install docs in build phase Approved by: portmgr blanket
-rw-r--r--math/py-gmpy2-devel/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/py-gmpy2-devel/Makefile b/math/py-gmpy2-devel/Makefile
index b08e25f0fc44..131894b3c7aa 100644
--- a/math/py-gmpy2-devel/Makefile
+++ b/math/py-gmpy2-devel/Makefile
@@ -11,7 +11,8 @@ PKGNAMESUFFIX= -devel
MAINTAINER= thierry@FreeBSD.org
COMMENT= GMP, MPFR, and MPC interface to Python - devel version
-LICENSE= GPLv3
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
LIB_DEPENDS= libgmp.so:math/gmp \
libmpc.so:math/mpc \
@@ -34,10 +35,10 @@ PORTDOCS= *
PLIST_SUB= VER=${DISTVERSION}
do-build-DOCS-on:
- (cd ${WRKSRC}/docs && ${GMAKE} html)
+ (cd ${WRKSRC}/docs && ${GMAKE} SPHINXBUILD=sphinx-build-${PYTHON_VER} html)
-post-build-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -R ${WRKSRC}/docs/_build/html/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>