aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2024-01-19 17:04:38 +0000
committerKyle Evans <kevans@FreeBSD.org>2024-01-19 17:07:56 +0000
commit3a26999f32da393ccb6e26d3f13dc475857d727c (patch)
tree68a38721c43d27fdb5baf2145e72552fb936bbc4
parent982de4a7bf3bd61aa69ee829f6a30bf8e22b9e53 (diff)
downloadports-3a26999f32da393ccb6e26d3f13dc475857d727c.tar.gz
ports-3a26999f32da393ccb6e26d3f13dc475857d727c.zip
sysutils/orch: pull in some patches following portability testing
These were deemed critcial enough to be worth backporting: the first issue affects spawn() of paths that look relative; these are now just using $PATH, and the script's directory is prepended to $PATH. The other is that the tests weren't easily runnable, so it's gained some bits to improve that and we hook up TEST_TARGET in the ports tree here.
-rw-r--r--sysutils/orch/Makefile15
-rw-r--r--sysutils/orch/distinfo6
2 files changed, 20 insertions, 1 deletions
diff --git a/sysutils/orch/Makefile b/sysutils/orch/Makefile
index 34e68d19500b..c599ec9e4dd2 100644
--- a/sysutils/orch/Makefile
+++ b/sysutils/orch/Makefile
@@ -1,5 +1,6 @@
PORTNAME= orch
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://git.kevans.dev/kevans/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
@@ -12,6 +13,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= lua:52-54 uidfix
+PATCH_DIST_STRIP= -p1
+PATCH_SITES= https://git.kevans.dev/kevans/orch/commit/
+# Add script dir to $PATH rather than some custom searching
+PATCHFILES+= b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch
+# Add a `make check` target for easier testing
+PATCHFILES+= 4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch
+
WRKSRC= ${WRKDIR}/${PORTNAME}
ORCHLUA_PATH= ${PREFIX}/share/${PORTNAME}
@@ -22,6 +30,7 @@ MAKE_ENV+= BINDIR="${PREFIX}/bin" \
LUA_INCDIR="${LUA_INCDIR}" \
LUA_LIB="-L${LUA_LIBDIR} -llua-${LUA_VER}" \
ORCHLUA_PATH="${ORCHLUA_PATH}"
+TEST_TARGET= check
.include <bsd.port.pre.mk>
@@ -31,6 +40,12 @@ MAKE_ENV+= FILESDIR_OWN=${UID} FILESDIR_GRP=${GID}
MAKE_ENV+= EXAMPLESDIR_OWN=${UID} EXAMPLESDIR_GRP=${GID}
.endif
+post-patch:
+ # XXX This can go away in the next version; patch(1) won't take the hint of
+ # the file mode from the patch, so we just fix it here in case one wants to
+ # run the tests
+ @${CHMOD} +x ${WRKSRC}/tests/my_cat
+
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/share/man/man1
diff --git a/sysutils/orch/distinfo b/sysutils/orch/distinfo
index 52af1438de94..b7e9e5a50cfc 100644
--- a/sysutils/orch/distinfo
+++ b/sysutils/orch/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1705544817
+TIMESTAMP = 1705682998
SHA256 (orch-0.1.tar.gz) = c4c058f73324f883c9b823639664a97380bd041dbc4dfd646be325a99305aa64
SIZE (orch-0.1.tar.gz) = 20134
+SHA256 (b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch) = 15ee1c5192b1336edfef0974ac8c3e5943a08e8049dba32b4547890595186e01
+SIZE (b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch) = 6865
+SHA256 (4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch) = c6577dae7b4c9e0dd2bf1e35a1a2c424cd7a1a5123dc09de3ccbafa7f5eec9f4
+SIZE (4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch) = 3320