aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-05-06 00:39:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-05-06 00:39:40 +0000
commit3a472458301efae6090c769816116c26cd9db4db (patch)
tree0a3837698486bfa560388db7e427d31374561e97
parent60b5891eeefc811865e400a49b482de29605dfd3 (diff)
downloadports-3a472458301efae6090c769816116c26cd9db4db.tar.gz
ports-3a472458301efae6090c769816116c26cd9db4db.zip
math/asl: fix build on powerpc*
Don't use fpsetprec / fpsetmask on powerpc*: fpinit.c:246:2: warning: implicit declaration of function 'fpsetprec' is invalid in C99 [-Wimplicit-function-declaration] fpsetprec(FP_PD); ^ fpinit.c:246:12: error: use of undeclared identifier 'FP_PD' fpsetprec(FP_PD);
-rw-r--r--math/asl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/asl/Makefile b/math/asl/Makefile
index 21fc5597d253..4e1a8f69af9d 100644
--- a/math/asl/Makefile
+++ b/math/asl/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= yes
BINARY_ALIAS= make=${GMAKE}
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*}
+CFLAGS+= -DASL_NO_FP_INIT
+.endif
+
post-extract:
@cd ${WRKSRC} && ${LN} -s ../solvers .