aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 20:00:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 20:02:30 +0000
commit3a4966afef9c678c7652f351164c816ed398ac08 (patch)
tree620478e99de5e9d618bbfcb7c7b5964e1dbe7852
parenta493958303d4c9aa1a24e41bc1ffb632369e764b (diff)
downloadports-3a4966afef9c678c7652f351164c816ed398ac08.tar.gz
ports-3a4966afef9c678c7652f351164c816ed398ac08.zip
devel/gorm: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/gorm/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index fabb83501cda..3564b591a5be 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -20,4 +20,10 @@ USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
DEFAULT_LIBVERSION= 1.1.0
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
.include <bsd.port.mk>