aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-10 01:00:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-10 01:18:08 +0000
commit3ae6553cbd34c94c116757c0166876f63cfcde75 (patch)
tree5402c31091330a35ff95448fc8f458a4740fc433
parent52768539d46f7549a8333c403c02e838182293bf (diff)
downloadports-3ae6553cbd34c94c116757c0166876f63cfcde75.tar.gz
ports-3ae6553cbd34c94c116757c0166876f63cfcde75.zip
x11-wm/kwinft: unbreak X-KDE-Wayland-Interfaces detection
$ pkg install kwinft vulkan-tools $ export QT_LOGGING_RULES="kwin_*.debug=true" $ kwin_wayland --exit-with-session vkcube-wayland [...] kwin_wl: Could not identify process with pid 12345
-rw-r--r--x11-wm/kwinft/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11-wm/kwinft/Makefile b/x11-wm/kwinft/Makefile
index 6a9704511dcc..a2175235d230 100644
--- a/x11-wm/kwinft/Makefile
+++ b/x11-wm/kwinft/Makefile
@@ -1,7 +1,7 @@
PORTNAME= kwinft
DISTVERSIONPREFIX= ${PORTNAME}@
DISTVERSION= 5.26.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -59,6 +59,16 @@ QA11Y_DESC= Accessibility (focus tracking) for Zoom effect
QA11Y_LIB_DEPENDS= libqaccessibilityclient-qt5.so:accessibility/libqaccessibilityclient
QA11Y_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_QAccessibilityClient
+post-patch:
+# Convert nodes from linprocfs(5) to procfs(5)
+# XXX kwinft lacks https://invent.kde.org/plasma/kwin/-/commit/1bc7afe8aaa9
+ @${REINPLACE_CMD} -e '/proc/,+1s,/exe,/file,' \
+ ${WRKSRC}/base/wayland/filtered_display.cpp \
+ ${WRKSRC}/desktop/kde/service_utils.h
+# Generic nodes are not supported by procfs(5)
+ @${REINPLACE_CMD} -e '/mounts/s,/proc,/compat/linux&,' \
+ ${WRKSRC}/debug/perf/ftrace_impl.cpp
+
# XXX Drop after FreeBSD 12.3 EOL around 2023-03-01 (don't forget distinfo)
.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
.if !exists(/usr/include/c++/v1/concepts) || make(makesum) || make(fetch)