aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2023-05-21 08:59:15 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-05-28 17:03:48 +0000
commit3b5185777050a60a420765a1610700ac03244f83 (patch)
tree4022a1f0e20ea0b87ae1286988bb028776cc819f
parente51591ee47bb609ff7ce4b7248ca61f662c2a570 (diff)
downloadports-3b5185777050a60a420765a1610700ac03244f83.tar.gz
ports-3b5185777050a60a420765a1610700ac03244f83.zip
devel/gitaly: update to 16.0.0
-rw-r--r--devel/gitaly/Makefile34
-rw-r--r--devel/gitaly/distinfo10
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile41
3 files changed, 11 insertions, 74 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index ad3eb2998a68..fcc2213bb47b 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,7 +1,6 @@
PORTNAME= gitaly
-DISTVERSION= 15.11.3
+DISTVERSION= 16.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= mfechner@FreeBSD.org
@@ -16,29 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# it fixes segfaults reported here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259848
# define dependencies that are required for build and run under MY_DEPENDS
-MY_DEPENDS= git>=2.40.1:devel/git \
- rubygem-bundler>=2.1.4:sysutils/rubygem-bundler \
- rubygem-rugged>=1.5.1<1.6:devel/rubygem-rugged \
- rubygem-gitlab-markup>=1.9.0<1.10.0:textproc/rubygem-gitlab-markup \
- rubygem-activesupport61>=6.1.7.2<6.1.8:devel/rubygem-activesupport61 \
- rubygem-grpc>=1.42.0<2:net/rubygem-grpc \
- rubygem-sentry-raven>=3.1<4:devel/rubygem-sentry-raven \
- rubygem-rbtrace>=0.4.14:devel/rubygem-rbtrace \
- rubygem-gitaly>=15.5.0<15.10:net/rubygem-gitaly \
- rubygem-gitlab-labkit>=0.31<1:devel/rubygem-gitlab-labkit \
- rubygem-licensee>=9.15<10:devel/rubygem-licensee \
- rubygem-google-protobuf322>=3.22.3<3.23:devel/rubygem-google-protobuf322 \
- rubygem-nokogiri>=1.14.1<1.15:textproc/rubygem-nokogiri \
- rubygem-license_finder>=7.0<8:devel/rubygem-license_finder \
- rubygem-redis4>=4.8.0<5:databases/rubygem-redis4
-BUILD_DEPENDS= gem:devel/ruby-gems \
- bash>0:shells/bash \
+MY_DEPENDS= git>=2.40.1:devel/git
+BUILD_DEPENDS= bash>0:shells/bash \
${MY_DEPENDS}
RUN_DEPENDS= ${MY_DEPENDS} \
gitlab-shell>=14.17.0:devel/gitlab-shell
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= cpe gmake go:modules,no_targets pkgconfig ruby
+USES= cpe gmake go:modules,no_targets pkgconfig
CPE_VENDOR= gitlab
@@ -49,7 +33,7 @@ MAKE_ENV+= ${GO_ENV}
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/-/tags
-GL_COMMIT= 62b051c35c2bcccd5ad7c707ff4f1fd67f641717
+GL_COMMIT= a404f278abbfc4c7bfa2935ac5f992261e39c52c
# for go dependencies
# Gitlab hosts there dependencies on their own platform and not on go-proxy
@@ -74,24 +58,18 @@ post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config.toml.example
${MV} ${WRKSRC}/config.toml.example ${WRKSRC}/config.toml.sample
-pre-build:
- (cd ${WRKSRC}/ruby && ${RM} Gemfile.lock && bundle install --local)
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${DATADIR}/bin
${FIND} ${WRKSRC} -name '*.orig' -delete
- ${FIND} ${WRKSRC} -name "Gemfile.lock" -delete
(cd ${WRKSRC}/_build/bin/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/bin && \
- cd ${WRKSRC} && ${COPYTREE_SHARE} config.toml.sample ${STAGEDIR}${DATADIR}) && \
- cd ${WRKSRC}/ruby && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/ruby
+ cd ${WRKSRC} && ${COPYTREE_SHARE} config.toml.sample ${STAGEDIR}${DATADIR})
post-install:
${FIND} -s ${STAGEDIR}${DATADIR} -not -type d | ${SORT} | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' | \
${SED} -E -e '/sample$$/ s#^#@sample #; \
/gitlab-shell-hook$$/ s#^#@(,,755) #; \
- s#${DATADIR_REL}/ruby/bin#@(,,555) ${DATADIR_REL}/ruby/bin#; \
s#${DATADIR_REL}/bin#@(,,555) ${DATADIR_REL}/bin#; ' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index e4c60e166e4a..604f11cf05f9 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1683982203
-SHA256 (go/devel_gitaly/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0/go.mod) = 4937565cfcb003930a583d7adb41f6dce0acb6b5cc496c2c03242dbd4eb36a18
-SIZE (go/devel_gitaly/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0/go.mod) = 10423
-SHA256 (go/devel_gitaly/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0.tar.gz) = 9730eb06bfe1add7e4a84e16c28a04ff79084bc118693835e5f41a0996e7c7d4
-SIZE (go/devel_gitaly/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0/gitlab-org-gitaly-62b051c35c2bcccd5ad7c707ff4f1fd67f641717_GL0.tar.gz) = 3458575
+TIMESTAMP = 1684518785
+SHA256 (go/devel_gitaly/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0/go.mod) = a9d6d090f061cab00b5bcdbbddd08e0b02de1772b256ed3bec2f3c0d07b3c923
+SIZE (go/devel_gitaly/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0/go.mod) = 10483
+SHA256 (go/devel_gitaly/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0.tar.gz) = 64e40d53de346f98f9b12f02b5d0a1aaa793196664242906ce946db78017beb2
+SIZE (go/devel_gitaly/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0/gitlab-org-gitaly-a404f278abbfc4c7bfa2935ac5f992261e39c52c_GL0.tar.gz) = 3460075
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
deleted file mode 100644
index 2cbf4f928b8d..000000000000
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ /dev/null
@@ -1,41 +0,0 @@
---- ruby/Gemfile.orig 2023-04-05 16:07:34 UTC
-+++ ruby/Gemfile
-@@ -1,15 +1,15 @@
- source 'https://rubygems.org'
-
- gem 'rugged', '~> 1.5.1'
--gem 'gitlab-markup', '~> 1.8.0'
-+gem 'gitlab-markup', '~> 1.9.0'
- gem 'activesupport', '~> 6.1.7.2'
--gem 'grpc', '~> 1.42.0' # keep in lock-step with grpc-tools in ../tools/protogem
-+gem 'grpc', '~> 1.42' # keep in lock-step with grpc-tools in ../tools/protogem
- gem 'sentry-raven', '~> 3.1', require: false
- gem 'rbtrace', require: false
-
- # The Gitaly Gem contains the Protobuf and gRPC definitions required by the
- # Ruby sidecar.
--gem 'gitaly', '~> 15.5.0'
-+gem 'gitaly', '~> 15.5'
-
- # Labkit provides observability functionality
- gem 'gitlab-labkit', '~> 0.31', '>= 0.31.1'
-@@ -26,18 +26,10 @@ gem 'nokogiri', '~> 1.14'
- # dependency and can thus be removed when the version constraint is gone.
- gem 'redis', '~> 4.8.0'
-
--group :development, :test do
-- gem 'rubocop', '~> 1.38', require: false
-- gem 'rspec', '~> 3.12.0', require: false
-- gem 'rspec-parameterized', require: false
-- gem 'factory_bot', require: false
-- gem 'pry', '~> 0.13.1', require: false
--end
--
- # Gems required in omnibus-gitlab pipeline
- group :development, :test, :omnibus do
- # Using a fork until https://github.com/pivotal/LicenseFinder/pull/816 is
- # resolved. For details, check discussion in
- # https://gitlab.com/gitlab-org/gitlab/-/merge_requests/74881
-- gem 'gitlab-license_finder', require: false
-+ gem 'license_finder', require: false
- end