aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-01-19 12:06:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-01-19 12:06:14 +0000
commit3b6641a158eff00a2c84962bae7a9dc47e73dc09 (patch)
tree3aada758a08f0da555e66c79ad3699ac4ba476b2
parent39146f3dade2b06172cd752ed23ab8d5447ec927 (diff)
downloadports-3b6641a158eff00a2c84962bae7a9dc47e73dc09.tar.gz
ports-3b6641a158eff00a2c84962bae7a9dc47e73dc09.zip
- new option GNUSTEP_PREFIX
allow user defined location of all files
Notes
Notes: svn path=/head/; revision=153867
-rw-r--r--deskutils/gworkspace/Makefile3
-rw-r--r--deskutils/preferences.app/Makefile3
-rw-r--r--devel/gnustep-make/Makefile3
-rw-r--r--devel/gnustep/Makefile3
-rw-r--r--devel/gorm/Makefile3
-rw-r--r--devel/projectcenter.app/Makefile3
-rw-r--r--games/gomoku.app/Makefile3
-rw-r--r--games/gshisen/Makefile3
-rw-r--r--graphics/gnustep-slideshow/Makefile3
-rw-r--r--graphics/gnustep-slideshowkit/Makefile3
-rw-r--r--graphics/imageviewer/Makefile3
-rw-r--r--graphics/preview/Makefile3
-rw-r--r--lang/gnustep-base/Makefile3
-rw-r--r--lang/gnustep-guile/Makefile3
-rw-r--r--lang/gnustep-objc/Makefile3
-rw-r--r--mail/addresses/Makefile3
-rw-r--r--mail/addresses/distinfo1
-rw-r--r--mail/gnumail/Makefile3
-rw-r--r--mail/pantomime-ssl/Makefile3
-rw-r--r--mail/pantomime/Makefile3
-rw-r--r--misc/gnustep-examples/Makefile3
-rw-r--r--shells/gscommander/Makefile3
-rw-r--r--textproc/easydiff/Makefile3
-rw-r--r--x11-toolkits/gnustep-back/Makefile3
-rw-r--r--x11-toolkits/gnustep-gui/Makefile3
-rw-r--r--x11-toolkits/gtoolkit/Makefile5
26 files changed, 52 insertions, 26 deletions
diff --git a/deskutils/gworkspace/Makefile b/deskutils/gworkspace/Makefile
index 370624f4f9c9..c8e85c18fb55 100644
--- a/deskutils/gworkspace/Makefile
+++ b/deskutils/gworkspace/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://www.gnustep.it/enrico/gworkspace/ \
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep workspace manager
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/GWorkspace-${PORTVERSION}
GUN_CONFIGURE= yes
diff --git a/deskutils/preferences.app/Makefile b/deskutils/preferences.app/Makefile
index 87a0341b2708..b6c424f79475 100644
--- a/deskutils/preferences.app/Makefile
+++ b/deskutils/preferences.app/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep workspace manager
USE_BZIP2= yes
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 303b92e3ddf3..7b4d9aa3ba71 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -15,7 +15,8 @@ MASTER_SITE_SUBDIR= core
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep makefile package
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c" \
diff --git a/devel/gnustep/Makefile b/devel/gnustep/Makefile
index bd9fa5e3abff..445e4cb87003 100644
--- a/devel/gnustep/Makefile
+++ b/devel/gnustep/Makefile
@@ -15,7 +15,8 @@ EXTRACT_ONLY= # empty
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Objective-C libraries based on the OpenStep standard
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
NO_BUILD= yes
USE_GNUSTEP= yes
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index 26144331ad10..b030186a7338 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -15,7 +15,8 @@ DISTNAME= Gorm-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Graphical Object Relationship Modeller
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
index b45caad515b3..67673478a5a2 100644
--- a/devel/projectcenter.app/Makefile
+++ b/devel/projectcenter.app/Makefile
@@ -15,7 +15,8 @@ DISTNAME= ProjectCenter-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A development environment for GNUstep
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/games/gomoku.app/Makefile b/games/gomoku.app/Makefile
index 98b2e4fd5601..8af78caa1a12 100644
--- a/games/gomoku.app/Makefile
+++ b/games/gomoku.app/Makefile
@@ -14,7 +14,8 @@ DISTNAME= Gomoku-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Gomoku game
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index 3aa4b6fa131d..d0a2a8fe1da0 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -15,7 +15,8 @@ MASTER_SITE_SUBDIR= dinoex
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Mahjongg-kind of game that uses the GNUstep toolkit
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/graphics/gnustep-slideshow/Makefile b/graphics/gnustep-slideshow/Makefile
index 0714c69149b2..78484cafd589 100644
--- a/graphics/gnustep-slideshow/Makefile
+++ b/graphics/gnustep-slideshow/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS+= ${LOCALLIBDIR}/libSlideShow.so:${PORTSDIR}/${SLIDESHOWKIT_PORT}
RUN_DEPENDS+= ${LOCALLIBDIR}/libSlideShow.so:${PORTSDIR}/${SLIDESHOWKIT_PORT}
USE_BZIP2= yes
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/graphics/gnustep-slideshowkit/Makefile b/graphics/gnustep-slideshowkit/Makefile
index e53dec283838..9f6f3bcf7a76 100644
--- a/graphics/gnustep-slideshowkit/Makefile
+++ b/graphics/gnustep-slideshowkit/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= SlideShow Framework
USE_BZIP2= yes
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/SlideShowKit
USE_GMAKE= yes
diff --git a/graphics/imageviewer/Makefile b/graphics/imageviewer/Makefile
index 851ce9eb550f..a9ed320f2864 100644
--- a/graphics/imageviewer/Makefile
+++ b/graphics/imageviewer/Makefile
@@ -14,7 +14,8 @@ DISTNAME= ImageViewer-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Image Viewer
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GUN_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/preview/Makefile b/graphics/preview/Makefile
index f2ad9814cc24..5cd9bcdb520a 100644
--- a/graphics/preview/Makefile
+++ b/graphics/preview/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Simple image viewer
USE_BZIP2= yes
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNUSTEP= yes
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 71d7feec431a..5d7b7b442bc6 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
ETCDIR= ${LOCALBASE}/etc
USE_AUTOTOOLS= autoconf:259
diff --git a/lang/gnustep-guile/Makefile b/lang/gnustep-guile/Makefile
index d9b87d1fbb7a..77bd63db3ba4 100644
--- a/lang/gnustep-guile/Makefile
+++ b/lang/gnustep-guile/Makefile
@@ -17,7 +17,8 @@ COMMENT= GNUstep interface to the GUILE scheme interpreter
LIB_DEPENDS+= guile.15:${PORTSDIR}/lang/guile
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index 39a2bfe0001a..99819fadade3 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -15,7 +15,8 @@ MASTER_SITE_SUBDIR= libs
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A snapshot of libobjc, meant to be used with GNUstep
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_BUILD= yes
diff --git a/mail/addresses/Makefile b/mail/addresses/Makefile
index 3616a57e819d..4be95503c1ff 100644
--- a/mail/addresses/Makefile
+++ b/mail/addresses/Makefile
@@ -15,7 +15,8 @@ DISTNAME= Addresses-${PORTVERSION}
MAINTAINER= flynn@energyhq.es.eu.org
COMMENT= A versatile addressbook for GNUstep
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/Addresses-${PORTVERSION}
USE_GMAKE= yes
diff --git a/mail/addresses/distinfo b/mail/addresses/distinfo
index acb517b25de1..fac15831a5e9 100644
--- a/mail/addresses/distinfo
+++ b/mail/addresses/distinfo
@@ -1,2 +1,3 @@
MD5 (Addresses-0.4.6.tar.gz) = 2d6b6bf9a1578a5b3a13cb0bd2c60fad
+SHA256 (Addresses-0.4.6.tar.gz) = a901d13676b745c3523f581824434387e592cb721df7b3d3719496946c610155
SIZE (Addresses-0.4.6.tar.gz) = 444463
diff --git a/mail/gnumail/Makefile b/mail/gnumail/Makefile
index 6cc1aa39ae7b..82c7ab27285b 100644
--- a/mail/gnumail/Makefile
+++ b/mail/gnumail/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS+= ${LOCALLIBDIR}/libAddresses.so:${PORTSDIR}/${ADDRESSES_PORT}
RUN_DEPENDS+= ${LOCALLIBDIR}/libPantomime.so:${PORTSDIR}/${PANTOMIME_PORT}
RUN_DEPENDS+= ${LOCALLIBDIR}/libAddresses.so:${PORTSDIR}/${ADDRESSES_PORT}
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/GNUMail
USE_GMAKE= yes
diff --git a/mail/pantomime-ssl/Makefile b/mail/pantomime-ssl/Makefile
index 0c62573ebd0e..31f3725e7a22 100644
--- a/mail/pantomime-ssl/Makefile
+++ b/mail/pantomime-ssl/Makefile
@@ -19,7 +19,8 @@ COMMENT= SSL Connections for pantomime
BUILD_DEPENDS+= ${LOCALLIBDIR}/libPantomime.so:${PORTSDIR}/${PANTOMIME_PORT}
RUN_DEPENDS+= ${LOCALLIBDIR}/libPantomime.so:${PORTSDIR}/${PANTOMIME_PORT}
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/Pantomime/Bundles/SSL
USE_OPENSSL= yes
diff --git a/mail/pantomime/Makefile b/mail/pantomime/Makefile
index 77ce9bf287bd..781e00051f3a 100644
--- a/mail/pantomime/Makefile
+++ b/mail/pantomime/Makefile
@@ -15,7 +15,8 @@ DISTNAME= Pantomime-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Mail/MIME handling library for GNUstep
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/Pantomime
USE_GMAKE= yes
diff --git a/misc/gnustep-examples/Makefile b/misc/gnustep-examples/Makefile
index eeeb0a1298dd..9733ac9e69cc 100644
--- a/misc/gnustep-examples/Makefile
+++ b/misc/gnustep-examples/Makefile
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= core
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep example applications
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
GUN_CONFIGURE= yes
diff --git a/shells/gscommander/Makefile b/shells/gscommander/Makefile
index 76e8a0668b0c..535e75f117fa 100644
--- a/shells/gscommander/Makefile
+++ b/shells/gscommander/Makefile
@@ -15,7 +15,8 @@ DISTNAME= GSCommander-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep simple unix command monitor
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/GSCommander
GUN_CONFIGURE= yes
diff --git a/textproc/easydiff/Makefile b/textproc/easydiff/Makefile
index 4fd82f279b51..ca45e91cdaba 100644
--- a/textproc/easydiff/Makefile
+++ b/textproc/easydiff/Makefile
@@ -15,7 +15,8 @@ MASTER_SITES= http://www.linuks.mine.nu/easydiff/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep graphical diff
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GUN_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/gnustep-back/Makefile b/x11-toolkits/gnustep-back/Makefile
index eefe9becbdb6..48f4a2873a8c 100644
--- a/x11-toolkits/gnustep-back/Makefile
+++ b/x11-toolkits/gnustep-back/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
USE_XLIB= yes
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index d7fd650347cd..ca8081b8488c 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
NOT_FOR_ARCHS= ia64
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index aa3d2ff78e19..347531444cc2 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.inf.uos.de/pub/elmar/gtk/objc-gtoolkit/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Obj-C wrapper for gtk, a x11 graphics library
-PREFIX= ${LOCALBASE}/GNUstep
+GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
+PREFIX= ${GNUSTEP_PREFIX}
NO_MTREE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
@@ -28,7 +29,7 @@ LDCONFIG_DIRS= ${LOCALLIBDIR}
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-MAKE_ARGS+= GNUSTEP_SYSTEM_ROOT=${PREFIX}/System
+MAKE_ARGS+= GNUSTEP_PREFIX=${PREFIX}/System
CONFIGURE_ARGS+= --with-gnustep
WRKSRC= ${WRKDIR}/${DISTNAME}/GToolKit
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}