aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-11-18 16:45:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-11-18 16:46:59 +0000
commit3b7f6d468072ef91a66d1ea7d940d5fd37c21bc4 (patch)
tree87cd0f090c42d3be22fc11be595884e03ddcf758
parent38974808e77e5b6f67f51a0f2df6693c6ed5c569 (diff)
downloadports-3b7f6d468072ef91a66d1ea7d940d5fd37c21bc4.tar.gz
ports-3b7f6d468072ef91a66d1ea7d940d5fd37c21bc4.zip
emulators/vice: fix build on arm64
PR: 273785
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c15
2 files changed, 14 insertions, 3 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 13f589cfa7b0..0a2762397a1d 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vice
PORTVERSION= 3.7.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= emulators
MASTER_SITES= SF/vice-emu/releases
diff --git a/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c b/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
index 1fad3f0bf319..c77d704d0ec5 100644
--- a/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
+++ b/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
@@ -16,7 +16,7 @@
#ifdef UNIX_COMPILE
#include <fcntl.h>
-@@ -121,7 +130,11 @@ static uint8_t device_io_inb(uint16_t addr)
+@@ -121,8 +130,12 @@ static uint8_t device_io_inb(uint16_t addr)
#ifdef HAVE_INBV
return inbv(addr);
#else
@@ -24,7 +24,18 @@
return inb(addr);
+#else
+ return 0;
-+#endif
#endif
++#endif
}
+ static void device_io_outb(uint16_t addr, uint8_t val)
+@@ -130,7 +143,9 @@ static void device_io_outb(uint16_t addr, uint8_t val)
+ #ifdef HAVE_OUTBV
+ outbv(addr, val);
+ #else
++#ifdef HAVE_OUTB
+ outb(addr, val);
++#endif
+ #endif
+ }
+ #endif