aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 01:53:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 02:08:56 +0000
commit3b93925ed37dfd23eb893aea57b1d0a1f9bef7f8 (patch)
treeecaee71f469b5149d075781b8e5bb626b5adb94b
parent765f62e970712952be481fd7a92839efd4c36517 (diff)
downloadports-3b93925ed37dfd23eb893aea57b1d0a1f9bef7f8.tar.gz
ports-3b93925ed37dfd23eb893aea57b1d0a1f9bef7f8.zip
net/rubygem-grpc: Update to 1.59.0
-rw-r--r--net/rubygem-grpc/Makefile4
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb4
3 files changed, 7 insertions, 7 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 21ec01a30042..9996a9d9449f 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.58.0
+PORTVERSION= 1.59.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -12,7 +12,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares \
libgrpc.so:devel/grpc
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
- rubygem-google-protobuf>=3.23<4:devel/rubygem-google-protobuf \
+ rubygem-google-protobuf>=3.24<4:devel/rubygem-google-protobuf \
rubygem-googleapis-common-protos-types>=1.0<2:devel/rubygem-googleapis-common-protos-types
USES= cpe gem gmake pkgconfig
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index 036ea60ba0e6..891b1e9d97c9 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1694348362
-SHA256 (rubygem/grpc-1.58.0.gem) = 0cfbccbe955d318909c58d3e207969a8145fc837e7edd2f3992a9d40b13e9d02
-SIZE (rubygem/grpc-1.58.0.gem) = 6357504
+TIMESTAMP = 1698341277
+SHA256 (rubygem/grpc-1.59.0.gem) = 942db7814cb0eee0b72c4c4ac5eac5ce76275b314a327b952e580e8b5d1dd76a
+SIZE (rubygem/grpc-1.59.0.gem) = 6394368
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index c061d0c14e0b..db889ea228a7 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,4 +1,4 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2023-08-19 01:12:29 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2023-10-29 03:53:23 UTC
+++ src/ruby/ext/grpc/extconf.rb
@@ -68,11 +68,11 @@ if apple_toolchain && !cross_compiling
end
@@ -58,7 +58,7 @@
ext_export_file = File.join(grpc_root, 'src', 'ruby', 'ext', 'grpc', ext_export_filename())
-$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if linux
if apple_toolchain
- $LDFLAGS << ' -weak_framework CoreFoundation' if RUBY_PLATFORM =~ /arm64/
+ $LDFLAGS << ' -weak_framework CoreFoundation'
$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"'
end