aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-10-04 20:22:08 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-10-04 20:24:08 +0000
commit3be035569652b94df37bc87306c0d9ab970069bc (patch)
tree1b297f0902f1c4f4559373f04d8726b754e22eb9
parent833b131bfdc2f4eab34db75f5de7c7d10a5c452e (diff)
downloadports-3be035569652b94df37bc87306c0d9ab970069bc.tar.gz
ports-3be035569652b94df37bc87306c0d9ab970069bc.zip
archivers/py-borgbackup: clean environment for self-tests
This avoids build failures when, for instance, BORG_NEW_PASSWORD is set to another password than the one used by the self-tests. Reported by: SimpleRezo <simplerezo@gmail.com> PR: 266821 Not bumping PORTREVISION because this only affects the execution of self-tests, which is pass (then the change is irrelevant) or fail (then there is no package or installed port and PORTREVISION would serve no purpose).
-rw-r--r--archivers/py-borgbackup/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 8801af4b893f..593d625906a7 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -35,7 +35,7 @@ FUSE_DESC= Support to mount locally borg backup files
FUSE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}llfuse>0:devel/py-llfuse@${PY_FLAVOR}
_BORGHOME=${WRKDIR}/testhome
-_BORGENV=BORG_PASSPHRASE=secret123 PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} HOME=${_BORGHOME}
+_BORGENV=-i BORG_PASSPHRASE=secret123 PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} HOME=${_BORGHOME}
post-install:
${MKDIR} ${STAGEDIR}${MAN1PREFIX}/share/man/man1/
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}${MAN1PREFIX}/share/man/man1/
@@ -64,6 +64,6 @@ post-install:
${SETENV} ${_BORGENV} ${STAGEDIR}${PREFIX}/bin/borg info ${WRKDIR}/borgrepo
do-test:
- cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${_BORGENV} tox-${PYTHON_VER} -e ${PY_FLAVOR} -vv
+ cd ${WRKSRC} && ${SETENV} ${_BORGENV} ${TEST_ENV} tox-${PYTHON_VER} -e ${PY_FLAVOR} -vv
.include <bsd.port.mk>