aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-10 19:49:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-10 20:02:29 +0000
commit3c3154cae7ca96ae72ec0043c0aae5783044508b (patch)
tree2ab66979d865dcb0a832f701296f68a670896f3f
parent1b6ac9cb3176ffd713b33e0c9e796c47e9b45c1e (diff)
downloadports-3c3154cae7ca96ae72ec0043c0aae5783044508b.tar.gz
ports-3c3154cae7ca96ae72ec0043c0aae5783044508b.zip
audio/madronalib: drop GCC on powerpc64
-rw-r--r--audio/madronalib/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/audio/madronalib/Makefile b/audio/madronalib/Makefile
index 4248d0e62fed..693348251596 100644
--- a/audio/madronalib/Makefile
+++ b/audio/madronalib/Makefile
@@ -2,7 +2,7 @@ PORTNAME= madronalib
DISTVERSIONPREFIX= v
DISTVERSION= 1.6-1016
DISTVERSIONSUFFIX= -g103895f
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -19,21 +19,19 @@ BROKEN_riscv64= error: use of undeclared identifier '__builtin_ia32_emms'; did y
LIB_DEPENDS= libjack.so:audio/jack
-USES= cmake localbase:ldflags perl5
+USES= cmake compiler:c++11-lib localbase:ldflags perl5
USE_GITHUB= yes
GH_ACCOUNT= madronalabs
CMAKE_ON= LINUX_JACK
CXXFLAGS_powerpc64le= -DNO_WARN_X86_INTRINSICS
+CXXFLAGS_powerpc64= -DNO_WARN_X86_INTRINSICS
.include <bsd.port.options.mk>
-.if ${ARCH} == powerpc64
-CXXFLAGS+= -DNO_WARN_X86_INTRINSICS -maltivec -mvsx
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++11-lib
+.if ${ARCH} == powerpc64 && !defined(CPUTYPE)
+CXXFLAGS+= -mcpu=power7
.endif
.include <bsd.port.mk>