aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-27 16:58:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-27 18:42:43 +0000
commit3c428609d34e60904bf6e97b2feb8d0082534206 (patch)
tree76a1a0c99b11b65649de50fade311c30a5630e36
parentb4ab0d6abac1bfd7a359bcb96e9c778c1bcab2ec (diff)
downloadports-3c428609d34e60904bf6e97b2feb8d0082534206.tar.gz
ports-3c428609d34e60904bf6e97b2feb8d0082534206.zip
security/zxid: Mark DEPRECATED
- Do not build with OpenSSL 1.1.1e and later - Fails to build with all version of ssl from base - Fails to build with any version of ssl from ports - Set EXPIRATION_DATE 2023-05-27
-rw-r--r--security/zxid/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 612eb09d1913..7e69d656c273 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -13,18 +13,22 @@ LICENSE_NAME= End2End Trust Architecture (e2eta) Software Copying
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= # none
+DEPRECATED= Do not build with OpenSSL 1.1.1e and later
+EXPIRATION_DATE= 2023-05-27
+
LIB_DEPENDS= libcurl.so:ftp/curl
USES= gmake localbase tar:tgz ssl
USE_CSTD= gnu89
+USE_LDCONFIG= yes
+
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
LD="${CC}" LDFLAGS="${LDFLAGS}" \
PREFIX="${PREFIX}" OPENSSL_ROOT="${OPENSSLBASE}" \
POSTLIBS="${LDFLAGS}" TARGET="${OPSYS:tl}" \
V=1
-ALL_TARGET= default smime libzxid.so.0.0
-USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= default smime libzxid.so.0.0
CFLAGS+= -D_LSEEK_DECLARED -fPIC