aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2023-01-06 12:09:13 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2023-01-06 12:47:12 +0000
commit3d4de6dad59e66354b345f0abad56caec12c50ba (patch)
treef73ee26825e4d2501070e86255ba6370531ba7f8
parent769e272527a7086304ca50ba49a4c819136e4828 (diff)
downloadports-3d4de6dad59e66354b345f0abad56caec12c50ba.tar.gz
ports-3d4de6dad59e66354b345f0abad56caec12c50ba.zip
security/opie: New port: One-time Passwords In Everything
Differential Revision: https://reviews.freebsd.org/D37963
-rw-r--r--security/Makefile1
-rw-r--r--security/opie/Makefile28
-rw-r--r--security/opie/distinfo3
-rw-r--r--security/opie/pkg-descr1
-rw-r--r--security/opie/pkg-plist25
5 files changed, 58 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1ec35dd00eee..746fbf81f2ce 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -417,6 +417,7 @@
SUBDIR += openvpn-auth-radius
SUBDIR += openvpn-auth-script
SUBDIR += openvpn-devel
+ SUBDIR += opie
SUBDIR += ophcrack
SUBDIR += ossec-hids
SUBDIR += ossec-hids-agent
diff --git a/security/opie/Makefile b/security/opie/Makefile
new file mode 100644
index 000000000000..12ddcd226b3f
--- /dev/null
+++ b/security/opie/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= opie
+PORTVERSION= 1.20230106
+CATEGORIES= security
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= One-time Passwords In Everything
+
+LICENSE= TINV2 BSD3CLAUSE
+LICENSE_COMB= multi
+LICENSE_NAME_TINV2= The Inner Net License, Version 2
+LICENSE_FILE_TINV2= ${WRKSRC}/opie/License.TIN
+LICENSE_PERMS_TINV2= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= uidfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+GH_PROJECT= opie
+
+MAKE_ARGS= BINDIR=${PREFIX}/bin \
+ INCLUDEDIR=${PREFIX}/include \
+ LIBDIR=${PREFIX}/lib \
+ MANDIR=${MANPREFIX}/man/man
+
+IGNORE_FreeBSD_12= FreeBSD 12 has OPIE in base
+IGNORE_FreeBSD_13= FreeBSD 13 has OPIE in base
+
+.include <bsd.port.mk>
diff --git a/security/opie/distinfo b/security/opie/distinfo
new file mode 100644
index 000000000000..2a9840923e29
--- /dev/null
+++ b/security/opie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673008144
+SHA256 (freebsd-opie-1.20230106_GH0.tar.gz) = 614a7b61d6e301e87512e43b0f447c20c241d0da1791673f70b520f3d99cf7f7
+SIZE (freebsd-opie-1.20230106_GH0.tar.gz) = 164408
diff --git a/security/opie/pkg-descr b/security/opie/pkg-descr
new file mode 100644
index 000000000000..cc6ef280cf44
--- /dev/null
+++ b/security/opie/pkg-descr
@@ -0,0 +1 @@
+Provides utilities and PAM modules for OPIE one-time passwords.
diff --git a/security/opie/pkg-plist b/security/opie/pkg-plist
new file mode 100644
index 000000000000..1cf7cddb6b46
--- /dev/null
+++ b/security/opie/pkg-plist
@@ -0,0 +1,25 @@
+bin/opieinfo
+bin/opiekey
+bin/opiepasswd
+bin/otp-md4
+bin/otp-md5
+bin/otp-sha1
+include/opie.h
+lib/libopie.a
+lib/libopie.so
+lib/libopie.so.8
+lib/pam_opie.so
+lib/pam_opie.so.6
+lib/pam_opieaccess.so
+lib/pam_opieaccess.so.6
+man/man1/opieinfo.1.gz
+man/man1/opiekey.1.gz
+man/man1/opiepasswd.1.gz
+man/man1/otp-md4.1.gz
+man/man1/otp-md5.1.gz
+man/man1/otp-sha1.1.gz
+man/man4/opie.4.gz
+man/man5/opieaccess.5.gz
+man/man5/opiekeys.5.gz
+man/man8/pam_opie.8.gz
+man/man8/pam_opieaccess.8.gz