aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-12-31 11:26:25 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-12-31 11:26:25 +0000
commit3d6a5f7cb0c444e93af61a57e2b2f3379f10e938 (patch)
tree7bf59571ca0d2206c6bd7355dd8a66258fc21b67
parenta37f8af7c16d323b109b26c5c77d7a36a8525e5d (diff)
downloadports-3d6a5f7cb0c444e93af61a57e2b2f3379f10e938.tar.gz
ports-3d6a5f7cb0c444e93af61a57e2b2f3379f10e938.zip
security/stoken: unbreak build with LLVM >= 17 (+)
FreeBSD already have strcasestr() and mkstemps() functions and compat stubs are always skipped so declare local functions in map file is false positive. LLVM >= 17 is more restrictive with declared but missed functions which lead to linker error. Drop local stubs stoken__strcasestr() and stoken__mkstemps() from library map file to unbreak. Reported by: poudriere failure Approved by: portmgr blanket (trivial build fix)
-rw-r--r--security/stoken/Makefile2
-rw-r--r--security/stoken/files/patch-libstoken.map11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/stoken/Makefile b/security/stoken/Makefile
index d23f5739f4c9..960b878441fa 100644
--- a/security/stoken/Makefile
+++ b/security/stoken/Makefile
@@ -1,6 +1,6 @@
PORTNAME= stoken
DISTVERSION= 0.93
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MAINTAINER= samm@FreeBSD.org
diff --git a/security/stoken/files/patch-libstoken.map b/security/stoken/files/patch-libstoken.map
new file mode 100644
index 000000000000..f8026b48156b
--- /dev/null
+++ b/security/stoken/files/patch-libstoken.map
@@ -0,0 +1,11 @@
+--- libstoken.map.orig 2023-03-09 18:40:27 UTC
++++ libstoken.map
+@@ -58,8 +58,6 @@ global:
+ __stoken_read_rcfile;
+ __stoken_write_rcfile;
+ __stoken_zap_rcfile_data;
+- stoken__strcasestr;
+- stoken__mkstemps;
+ /* NOTE: this can break non-GNU toolchains */
+ Java_*;
+ local: