aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-11-07 12:33:51 +0000
committerRene Ladan <rene@FreeBSD.org>2022-11-07 12:34:31 +0000
commit3dade901ebc20c3d3fc043faf65ef2cacc0e742a (patch)
treefd9b9720cf2e48a9317269af48ba3c744bbb24fa
parenta0fc9a33fccb42e0a2be715f039302523e5988c7 (diff)
downloadports-3dade901ebc20c3d3fc043faf65ef2cacc0e742a.tar.gz
ports-3dade901ebc20c3d3fc043faf65ef2cacc0e742a.zip
x11-toolkits/libgdiplus: use USES=autoreconf instead of hand-rolling code.
Reported by: danfe
-rw-r--r--x11-toolkits/libgdiplus/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 1f873b6a8dd1..6c17599e0eda 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -10,7 +10,6 @@ WWW= https://www.mono-project.com/docs/gui/libgdiplus/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= autoconf>0:devel/autoconf
LIB_DEPENDS= libtiff.so:graphics/tiff \
libgif.so:graphics/giflib \
libpng.so:graphics/png \
@@ -19,8 +18,8 @@ LIB_DEPENDS= libtiff.so:graphics/tiff \
libfontconfig.so:x11-fonts/fontconfig
GNU_CONFIGURE= yes
-USES= cpe gettext-runtime gmake gnome jpeg libtool:keepla pathfix \
- pkgconfig
+USES= autoreconf cpe gettext-runtime gmake gnome jpeg libtool:keepla \
+ pathfix pkgconfig
USE_GNOME= cairo glib20 pango
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -42,7 +41,4 @@ PLIST_FILES= lib/libgdiplus.a \
lib/libgdiplus.so.0.0.0 \
libdata/pkgconfig/libgdiplus.pc
-pre-configure:
- cd ${WRKSRC} && autoconf
-
.include <bsd.port.mk>