aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-03 16:03:14 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-04 12:19:23 +0000
commit3dcaa7ac69b5916473360eb9864719af5a5178b2 (patch)
tree7089b91dbd2d977bea7bcb2e8bd0147dbd6e2b9c
parent8d759aa5353413f955fbc5fbc143593da35041d4 (diff)
downloadports-3dcaa7ac69b5916473360eb9864719af5a5178b2.tar.gz
ports-3dcaa7ac69b5916473360eb9864719af5a5178b2.zip
devel/dparser: update to 1.32
From ChangeLog: https://github.com/jplevyak/dparser/releases/tag/v1.32 * Update .gitignore: make_parser -> make_dparser * Convert FAQ into Markdown * Convert manual into Markdown * Consolidate README.md and index.html * Change from COPYRIGHT to LICENSE.txt * Remove old HTML documents * Convert TODO into docs/todo.md * Make includes more explicit Reported by: portscout
-rw-r--r--devel/dparser/Makefile9
-rw-r--r--devel/dparser/distinfo6
-rw-r--r--devel/dparser/files/patch-Makefile58
-rw-r--r--devel/dparser/pkg-plist7
4 files changed, 13 insertions, 67 deletions
diff --git a/devel/dparser/Makefile b/devel/dparser/Makefile
index b613da9876b2..68db656d38a0 100644
--- a/devel/dparser/Makefile
+++ b/devel/dparser/Makefile
@@ -1,7 +1,7 @@
# Created by: ijliao
PORTNAME= dparser
-PORTVERSION= 1.31
+PORTVERSION= 1.32
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -9,7 +9,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple but powerful tool for parsing
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= gmake
@@ -20,9 +20,6 @@ EXTRACT_AFTER_ARGS= --exclude "*my*"
MAKE_ARGS= CC="${CC}" D_OPTIMIZE= PREFIX=${PREFIX}
PORTDOCS= *
-PLIST_FILES= bin/make_dparser include/dparse.h include/dparse_tables.h \
- include/dparse_tree.h include/dsymtab.h lib/${LIBDPARSE} \
- man/man1/make_dparser.1.gz
OPTIONS_DEFINE= BOEHM DOCS
BOEHM_DESC= Boehm garbage collector support
@@ -48,6 +45,6 @@ do-install:
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.html ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.md ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/dparser/distinfo b/devel/dparser/distinfo
index 2d75d577c58f..727d73042939 100644
--- a/devel/dparser/distinfo
+++ b/devel/dparser/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549984176
-SHA256 (jplevyak-dparser-v1.31_GH0.tar.gz) = 8fed643095893396ef5f88eaa70497a42585fe8ded0349085fd0abafafe4aee2
-SIZE (jplevyak-dparser-v1.31_GH0.tar.gz) = 190612
+TIMESTAMP = 1646323327
+SHA256 (jplevyak-dparser-v1.32_GH0.tar.gz) = bbc71aed5dc74b36b88b3f3d29f899e339a6814112518451afeee28af4854896
+SIZE (jplevyak-dparser-v1.32_GH0.tar.gz) = 191103
diff --git a/devel/dparser/files/patch-Makefile b/devel/dparser/files/patch-Makefile
deleted file mode 100644
index fc93bad9d19a..000000000000
--- a/devel/dparser/files/patch-Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
---- Makefile.orig 2019-01-10 00:20:05 UTC
-+++ Makefile
-@@ -11,7 +11,7 @@ MAJOR=1
- MINOR=31
- RELEASE=$(MAJOR).$(MINOR)
-
--CC = gcc
-+CC ?= gcc
-
- ifndef PREFIX
- PREFIX=/usr/local
-@@ -38,18 +38,21 @@ ifeq ($(ARCH),i686)
- ARCH = x86
- endif
-
--ifeq ($(ARCH),x86_64)
-+ifeq ($(ARCH),amd64)
- CFLAGS += -fPIC
- endif
-
- ifeq ($(OS_TYPE),CYGWIN)
- GC_CFLAGS += -L/usr/local/lib
- else
--GC_CFLAGS += -I/usr/local/include -L/usr/local/lib
-+GC_CFLAGS += -I/usr/local/include
- endif
-
- ifdef D_USE_GC
- CFLAGS += -DUSE_GC ${GC_CFLAGS}
-+ifeq ($(OS_TYPE),FreeBSD)
-+ LIBS += -L${LOCALBASE}/lib
-+endif
- LIBS += -lgc
- ifeq ($(OS_TYPE),Linux)
- LIBS += -ldl
-@@ -64,10 +67,10 @@ ifdef D_USE_FREELISTS
- CFLAGS += -DUSE_FREELISTS
- endif
-
--D_BUILD_VERSION = $(shell git show-ref 2> /dev/null | head -1 | cut -d ' ' -f 1)
--ifeq ($(D_BUILD_VERSION),)
-+#D_BUILD_VERSION = $(shell git show-ref 2> /dev/null | head -1 | cut -d ' ' -f 1)
-+#ifeq ($(D_BUILD_VERSION),)
- D_BUILD_VERSION = $(shell cat D_BUILD_VERSION)
--endif
-+#endif
- CFLAGS += -DD_MAJOR_VERSION=$(MAJOR) -DD_MINOR_VERSION=$(MINOR) -DD_BUILD_VERSION=\"$(D_BUILD_VERSION)\"
-
- CFLAGS += -Wall
-@@ -143,7 +146,7 @@ endif
-
- ALL_SRCS = $(MAKE_PARSER_SRCS) $(BASE_SAMPLE_PARSER_SRCS) $(LIB_SRCS) $(MK_LIB_SRCS)
-
--all: $(EXECS) $(LIBRARIES) D_BUILD_VERSION make_dparser.cat
-+all: $(EXECS) $(LIBRARIES) make_dparser.cat
-
- version:
- echo $(OS_TYPE) $(OS_VERSION)
diff --git a/devel/dparser/pkg-plist b/devel/dparser/pkg-plist
new file mode 100644
index 000000000000..2e4f2f059294
--- /dev/null
+++ b/devel/dparser/pkg-plist
@@ -0,0 +1,7 @@
+bin/make_dparser
+include/dparse.h
+include/dparse_tables.h
+include/dparse_tree.h
+include/dsymtab.h
+lib/libdparse.a
+man/man1/make_dparser.1.gz