aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-12-19 21:54:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-12-19 21:54:26 +0000
commit3dea606a45e8c38d0d271b8124d33b346df8a136 (patch)
tree904667e511d101ede3054513dfb19fc84e572028
parent976abf2c480b13860e641a0331beff48104ccac8 (diff)
downloadports-3dea606a45e8c38d0d271b8124d33b346df8a136.tar.gz
ports-3dea606a45e8c38d0d271b8124d33b346df8a136.zip
games/openbor: update to 3.0.r4415
- Pacify -fsanitize=address a bit since previous update - Drop pointless USES=dos2unix Changes: svn log -r4415:r4391 https://svn.code.sf.net/p/openbor/engine/engine/
Notes
Notes: svn path=/head/; revision=428961
-rw-r--r--games/openbor/Makefile5
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-openbor.c29
3 files changed, 34 insertions, 6 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index d5f635883849..7310f30ccaf7 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= openbor
-PORTVERSION= 3.0.r4390
+PORTVERSION= 3.0.r4415
CATEGORIES= games devel
MASTER_SITES= LOCAL/jbeich \
https://svn.code.sf.net/p/${PORTNAME}/engine/engine/:svn
@@ -14,9 +14,8 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libpng.so:graphics/png \
libvpx.so:multimedia/libvpx
-USES= dos2unix gmake pkgconfig tar:xz
+USES= gmake pkgconfig tar:xz
USE_SDL= gfx2
-DOS2UNIX_FILES= Makefile
MAKE_ENV= BUILD_LINUX=1 SDKPATH="${LOCALBASE}" \
GCC_TARGET="${CONFIGURE_TARGET:S/amd64/x86_64/}"
MAKE_ARGS= CC="${CC}" LIBRARIES="${LOCALBASE}/lib" \
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index c0e536ec29cd..87b2db4eedfd 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480986407
-SHA256 (openbor-3.0.r4390.tar.xz) = d4d42a93db1ccde0c57a5459d42aac7e239ae4e3c4a13fe0eb0aa0174d1ed26d
-SIZE (openbor-3.0.r4390.tar.xz) = 3946520
+TIMESTAMP = 1482161397
+SHA256 (openbor-3.0.r4415.tar.xz) = eba62d10dd78649200dc6411bf5a2f06a348b1e0f3902a29f82144d63a9f81a2
+SIZE (openbor-3.0.r4415.tar.xz) = 3942168
diff --git a/games/openbor/files/patch-openbor.c b/games/openbor/files/patch-openbor.c
new file mode 100644
index 000000000000..d3af726c1212
--- /dev/null
+++ b/games/openbor/files/patch-openbor.c
@@ -0,0 +1,29 @@
+--- openbor.c.orig 2016-12-19 15:29:57 UTC
++++ openbor.c
+@@ -5810,7 +5810,7 @@ s_collision_attack **collision_alloc_att
+ size_t alloc_size;
+
+ // Get amount of memory we'll need.
+- alloc_size = sizeof(*result);
++ alloc_size = max_collisons * sizeof(*result);
+
+ // Allocate memory and get pointer.
+ result = malloc(alloc_size);
+@@ -5859,7 +5859,7 @@ s_collision_body **collision_alloc_body_
+ size_t alloc_size;
+
+ // Get amount of memory we'll need.
+- alloc_size = sizeof(*result);
++ alloc_size = max_collisons * sizeof(*result);
+
+ // Allocate memory and get pointer.
+ result = malloc(alloc_size);
+@@ -34617,7 +34617,7 @@ void keyboard_setup(int player)
+ strncpy(buttonnames[SDID_SPECIAL], "Special", 16);
+ strncpy(buttonnames[SDID_START], "Start", 16);
+ strncpy(buttonnames[SDID_SCREENSHOT], "Screenshot", 16);
+- strncpy(buttonnames[SDID_ESC], "Exit", 16);
++// strncpy(buttonnames[SDID_ESC], "Exit", 16);
+
+ savesettings();
+ bothnewkeys = 0;