aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 09:43:33 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:42 +0000
commit3e0515560556dc48ce03e315b2de73143a95ca22 (patch)
treef797c66f9f49bd056e5aa09897589e3f5af7658b
parent8ae71fbb335508c140898af9da2d50e8a19cfce0 (diff)
downloadports-3e0515560556dc48ce03e315b2de73143a95ca22.tar.gz
ports-3e0515560556dc48ce03e315b2de73143a95ca22.zip
games/openmw: Move to FFmpeg 4
Move to FFmpeg 4 due to dependency of graphics/osg Approved by: portmgr (blanket, build fix) Sponsored by: Blinkinblox
-rw-r--r--games/openmw/Makefile5
-rw-r--r--games/openmw/files/patch-cmake_FindFFmpeg.cmake11
2 files changed, 15 insertions, 1 deletions
diff --git a/games/openmw/Makefile b/games/openmw/Makefile
index dd012ba94cf2..973a4a0ce0dc 100644
--- a/games/openmw/Makefile
+++ b/games/openmw/Makefile
@@ -11,7 +11,7 @@ WWW= https://openmw.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+LIB_DEPENDS= libavcodec.so.58:multimedia/ffmpeg4 \
libboost_thread.so:devel/boost-libs \
libMyGUIEngine.so:x11-toolkits/mygui \
libBulletCollision.so:devel/bullet@double \
@@ -44,6 +44,9 @@ DOCS_USES= python:build
PORTDOCS= *
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${PATCH_WRKSRC}/cmake/FindFFmpeg.cmake
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
diff --git a/games/openmw/files/patch-cmake_FindFFmpeg.cmake b/games/openmw/files/patch-cmake_FindFFmpeg.cmake
new file mode 100644
index 000000000000..cbedcb816345
--- /dev/null
+++ b/games/openmw/files/patch-cmake_FindFFmpeg.cmake
@@ -0,0 +1,11 @@
+--- cmake/FindFFmpeg.cmake.orig 2023-04-24 10:57:53 UTC
++++ cmake/FindFFmpeg.cmake
+@@ -33,6 +33,8 @@
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
++set(CMAKE_PREFIX_PATH "%%LOCALBASE%%/ffmpeg4;%%LOCALBASE%%/ffmpeg4/libexec")
++
+ include(LibFindMacros)
+ include(FindPackageHandleStandardArgs)
+