aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2023-04-12 13:31:36 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-04-12 14:31:54 +0000
commit3e1d8d19939fde72de940c299466438ec7b80911 (patch)
tree8e5a59da33cf5b8887f52ead174f569ad6ae1c5c
parentb5a874168ae078116b48f335b35967b31ff29be6 (diff)
downloadports-3e1d8d19939fde72de940c299466438ec7b80911.tar.gz
ports-3e1d8d19939fde72de940c299466438ec7b80911.zip
www/gitlab-ce: switch to newer grpc version
Problems are maybe fixed with the rubygem-google-protobuf that is hiding the internal symbols. Tested together with the 15.10.2 update.
-rw-r--r--devel/gitaly/Makefile2
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile9
-rw-r--r--devel/rubygem-gitlab-labkit/Makefile3
-rw-r--r--net/rubygem-gitaly/Makefile3
-rw-r--r--net/rubygem-kas-grpc/Makefile4
-rw-r--r--net/rubygem-kas-grpc/files/patch-kas-grpc.gemspec10
-rw-r--r--net/rubygem-spamcheck/Makefile4
-rw-r--r--net/rubygem-spamcheck/files/patch-spamcheck.gemspec10
-rw-r--r--www/gitlab-ce/Makefile2
-rw-r--r--www/gitlab-ce/files/patch-Gemfile15
10 files changed, 27 insertions, 35 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index ccbaac3695d4..afa04da339b2 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -21,7 +21,7 @@ MY_DEPENDS= git>=2.39.2:devel/git \
rubygem-rugged>=1.5.1<1.6:devel/rubygem-rugged \
rubygem-gitlab-markup>=1.9.0<1.10.0:textproc/rubygem-gitlab-markup \
rubygem-activesupport61>=6.1.7.2<6.1.8:devel/rubygem-activesupport61 \
- rubygem-grpc142>=1.42.0<2:net/rubygem-grpc142 \
+ rubygem-grpc>=1.42.0<2:net/rubygem-grpc \
rubygem-sentry-raven>=3.1<4:devel/rubygem-sentry-raven \
rubygem-rbtrace>=0.4.14:devel/rubygem-rbtrace \
rubygem-gitaly>=15.5.0<15.10:net/rubygem-gitaly \
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
index f363f6758027..2cbf4f928b8d 100644
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ b/devel/gitaly/files/patch-ruby_Gemfile
@@ -1,15 +1,16 @@
---- ruby/Gemfile.orig 2023-03-30 13:24:44 UTC
+--- ruby/Gemfile.orig 2023-04-05 16:07:34 UTC
+++ ruby/Gemfile
-@@ -1,7 +1,7 @@
+@@ -1,15 +1,15 @@
source 'https://rubygems.org'
gem 'rugged', '~> 1.5.1'
-gem 'gitlab-markup', '~> 1.8.0'
+gem 'gitlab-markup', '~> 1.9.0'
gem 'activesupport', '~> 6.1.7.2'
- gem 'grpc', '~> 1.42.0' # keep in lock-step with grpc-tools in ../tools/protogem
+-gem 'grpc', '~> 1.42.0' # keep in lock-step with grpc-tools in ../tools/protogem
++gem 'grpc', '~> 1.42' # keep in lock-step with grpc-tools in ../tools/protogem
gem 'sentry-raven', '~> 3.1', require: false
-@@ -9,7 +9,7 @@ gem 'rbtrace', require: false
+ gem 'rbtrace', require: false
# The Gitaly Gem contains the Protobuf and gRPC definitions required by the
# Ruby sidecar.
diff --git a/devel/rubygem-gitlab-labkit/Makefile b/devel/rubygem-gitlab-labkit/Makefile
index 7943fd8bb7f4..c725f66e351e 100644
--- a/devel/rubygem-gitlab-labkit/Makefile
+++ b/devel/rubygem-gitlab-labkit/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gitlab-labkit
PORTVERSION= 0.31.1
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -12,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-actionpack61>=5<8:www/rubygem-actionpack61 \
rubygem-activesupport61>=5<8:devel/rubygem-activesupport61 \
- rubygem-grpc142>=1.37:net/rubygem-grpc142 \
+ rubygem-grpc>=1.37:net/rubygem-grpc \
rubygem-jaeger-client>=1.1.0<1.2:devel/rubygem-jaeger-client \
rubygem-opentracing>=0.4<1.0:devel/rubygem-opentracing \
rubygem-pg_query>=2.1<3:databases/rubygem-pg_query \
diff --git a/net/rubygem-gitaly/Makefile b/net/rubygem-gitaly/Makefile
index 6ac9ac5ce92a..6b2bbb73bfbc 100644
--- a/net/rubygem-gitaly/Makefile
+++ b/net/rubygem-gitaly/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gitaly
PORTVERSION= 15.9.0.pre.rc3
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -9,7 +10,7 @@ WWW= https://gitlab.com/gitlab-org/gitaly
LICENSE= MIT
-RUN_DEPENDS= rubygem-grpc142>=1.0<2.0:net/rubygem-grpc142
+RUN_DEPENDS= rubygem-grpc>=1.0<2.0:net/rubygem-grpc
USES= cpe gem
diff --git a/net/rubygem-kas-grpc/Makefile b/net/rubygem-kas-grpc/Makefile
index eeb74cefc1d3..98d56c37220b 100644
--- a/net/rubygem-kas-grpc/Makefile
+++ b/net/rubygem-kas-grpc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kas-grpc
PORTVERSION= 0.0.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -11,7 +11,7 @@ WWW= https://gitlab.com/gitlab-org/cluster-integration/gitlab-agent
LICENSE= MIT
-RUN_DEPENDS= rubygem-grpc142>=1.0<2.0:net/rubygem-grpc142
+RUN_DEPENDS= rubygem-grpc>=1.0<2.0:net/rubygem-grpc
USES= gem
diff --git a/net/rubygem-kas-grpc/files/patch-kas-grpc.gemspec b/net/rubygem-kas-grpc/files/patch-kas-grpc.gemspec
deleted file mode 100644
index d25e9f2543a9..000000000000
--- a/net/rubygem-kas-grpc/files/patch-kas-grpc.gemspec
+++ /dev/null
@@ -1,10 +0,0 @@
---- kas-grpc.gemspec.orig 2023-01-05 23:45:07 UTC
-+++ kas-grpc.gemspec
-@@ -18,6 +18,6 @@ Gem::Specification.new do |s|
-
- s.specification_version = 4
-
-- s.add_runtime_dependency(%q<grpc>.freeze, ["~> 1.0"])
-+ s.add_runtime_dependency(%q<grpc>.freeze, ["~> 1.42.0.pre1"])
- end
-
diff --git a/net/rubygem-spamcheck/Makefile b/net/rubygem-spamcheck/Makefile
index 428ec4ad7fe8..6ecb1e8e5174 100644
--- a/net/rubygem-spamcheck/Makefile
+++ b/net/rubygem-spamcheck/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spamcheck
PORTVERSION= 1.0.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -10,7 +10,7 @@ WWW= https://rubygems.org/gems/spamcheck
LICENSE= MIT
-RUN_DEPENDS= rubygem-grpc142>=1.0<2.0:net/rubygem-grpc142
+RUN_DEPENDS= rubygem-grpc>=1.0<2.0:net/rubygem-grpc
USES= gem
diff --git a/net/rubygem-spamcheck/files/patch-spamcheck.gemspec b/net/rubygem-spamcheck/files/patch-spamcheck.gemspec
deleted file mode 100644
index fafd7df63065..000000000000
--- a/net/rubygem-spamcheck/files/patch-spamcheck.gemspec
+++ /dev/null
@@ -1,10 +0,0 @@
---- spamcheck.gemspec.orig 2023-01-05 23:55:10 UTC
-+++ spamcheck.gemspec
-@@ -19,6 +19,6 @@ Gem::Specification.new do |s|
-
- s.specification_version = 4
-
-- s.add_runtime_dependency(%q<grpc>.freeze, ["~> 1.0"])
-+ s.add_runtime_dependency(%q<grpc>.freeze, ["~> 1.42.0.pre1"])
- end
-
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index bc41cbc42753..ce2707e7b3ea 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -234,7 +234,7 @@ MY_DEPENDS= git>=2.39.2:devel/git \
rubygem-spamcheck>=1.0.0<1.1:net/rubygem-spamcheck \
rubygem-gitaly>=15.9.0.pre.rc3<15.10.0:net/rubygem-gitaly \
rubygem-kas-grpc>=0.0.2,1<0.0.3,1:net/rubygem-kas-grpc \
- rubygem-grpc142>=1.42.0<1.43:net/rubygem-grpc142 \
+ rubygem-grpc>=1.42.0<2:net/rubygem-grpc \
rubygem-google-protobuf>=3.22.2<4:devel/rubygem-google-protobuf \
rubygem-toml-rb>=2.2.0<3:www/rubygem-toml-rb \
rubygem-flipper025>=0.25.0<0.26:devel/rubygem-flipper025 \
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 6a8d283bc92f..c22edcd4519f 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -175,6 +175,7 @@
- gem 'test-prof', '~> 1.0.7'
- gem 'rspec_junit_formatter'
- gem 'guard-rspec'
+- gem 'axe-core-rspec'
-
- # Moved in `test` because https://gitlab.com/gitlab-org/gitlab/-/issues/217527
- gem 'derailed_benchmarks', require: false
@@ -183,7 +184,15 @@
gem 'octokit', '~> 4.15'
# Updating this gem version here is deprecated. See:
-@@ -523,7 +427,7 @@ gem 'google-protobuf', '~> 3.21', '>= 3.21.12'
+@@ -515,14 +418,14 @@ gem 'gitaly', '~> 15.9.0-rc3'
+ # KAS GRPC protocol definitions
+ gem 'kas-grpc', '~> 0.0.2'
+
+-gem 'grpc', '~> 1.42.0'
++gem 'grpc', '~> 1.42'
+
+ gem 'google-protobuf', '~> 3.22', '>= 3.22.2'
+
gem 'toml-rb', '~> 2.2.0'
# Feature toggles
@@ -192,7 +201,7 @@
gem 'flipper-active_record', '~> 0.25.0'
gem 'flipper-active_support_cache_store', '~> 0.25.0'
gem 'unleash', '~> 3.2.2'
-@@ -537,7 +441,7 @@ gem 'grape_logging', '~> 1.8'
+@@ -536,7 +439,7 @@ gem 'grape_logging', '~> 1.8'
gem 'gitlab-net-dns', '~> 0.9.1'
# Countries list
@@ -201,7 +210,7 @@
gem 'retriable', '~> 3.1.2'
-@@ -580,6 +484,11 @@ gem 'ed25519', '~> 1.3.0'
+@@ -579,6 +482,11 @@ gem 'ed25519', '~> 1.3.0'
# Error Tracking OpenAPI client
# See https://gitlab.com/gitlab-org/gitlab/-/blob/master/doc/development/rake_tasks.md#update-openapi-client-for-error-tracking-feature
gem 'error_tracking_open_api', path: 'vendor/gems/error_tracking_open_api'