aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Strobl <marius@FreeBSD.org>2023-04-15 16:00:40 +0000
committerMarius Strobl <marius@FreeBSD.org>2023-04-15 19:01:48 +0000
commit3e1f667a34df9027a783fcca905c7cd8915fdcc3 (patch)
treed748fdfc2105c28134bc354faec94053c45f6f69
parentddc0ad6b45d697222d335985d7a44ecfc04532ca (diff)
downloadports-3e1f667a34df9027a783fcca905c7cd8915fdcc3.tar.gz
ports-3e1f667a34df9027a783fcca905c7cd8915fdcc3.zip
benchmarks/netperf: Update to 20210121 version
For the most part, this complicates the build, moves the debug log from /tmp to /var/log and changes debugging to default to off. Also: - Don't let netserver chmod(2) /dev/null to 644 when debug log is off. - Take back port. Approved by: netchild
-rw-r--r--benchmarks/netperf/Makefile16
-rw-r--r--benchmarks/netperf/distinfo6
-rw-r--r--benchmarks/netperf/files/patch-configure20
-rw-r--r--benchmarks/netperf/files/patch-configure.ac20
-rw-r--r--benchmarks/netperf/files/patch-doc_examples_runemomni.sh2
-rw-r--r--benchmarks/netperf/files/patch-doc_examples_runemomniagg2.sh4
-rw-r--r--benchmarks/netperf/files/patch-doc_examples_runemomniaggdemo.sh2
-rw-r--r--benchmarks/netperf/files/patch-src_netserver.c11
-rw-r--r--benchmarks/netperf/pkg-descr2
9 files changed, 49 insertions, 34 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 971b35e9820f..51f35e113f64 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -1,16 +1,18 @@
PORTNAME= netperf
-PORTVERSION= 2.7.1.p20170921
+PORTVERSION= 2.7.1.p20210121
PORTREVISION= 1
CATEGORIES= benchmarks
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= marius@FreeBSD.org
COMMENT= Network performance benchmarking package
WWW= https://hewlettpackard.github.io/netperf/
+USES= autoreconf:build,2.69
+
USE_GITHUB= yes
GH_ACCOUNT= HewlettPackard
#GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
-GH_TAGNAME= d566775bf
+GH_TAGNAME= 3bc455b23
OPTIONS_DEFINE= EXAMPLES EXS HISTOGRAM INFO OMNI SCTP SOCKETS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
@@ -23,9 +25,7 @@ SOCKETS_DESC= Enable Unix Domain socket support
USE_CSTD= gnu89
GNU_CONFIGURE= yes
-CONFIGURE_ENV= "transform="
-CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
- --enable-demo --enable-burst --enable-intervals
+CONFIGURE_ARGS= --enable-burst --enable-demo --enable-dirty --enable-intervals
CFLAGS+= -fcommon
INFO_INFO= netperf
@@ -46,6 +46,10 @@ post-patch:
.for i in ${SCRIPTS}
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/doc/examples/$i
.endfor
+ @${REINPLACE_CMD} -E -e 's,(conf|header),\12.69,g' ${WRKSRC}/autogen.sh
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/benchmarks/netperf/distinfo b/benchmarks/netperf/distinfo
index 1ce89f85daa7..a466b562d6b2 100644
--- a/benchmarks/netperf/distinfo
+++ b/benchmarks/netperf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1519739687
-SHA256 (HewlettPackard-netperf-2.7.1.p20170921-d566775bf_GH0.tar.gz) = 66fc216436bdd9dbdb726cc43d6d09a7c5356b4569546fb3dce833ed45ea5b70
-SIZE (HewlettPackard-netperf-2.7.1.p20170921-d566775bf_GH0.tar.gz) = 2010861
+TIMESTAMP = 1681506504
+SHA256 (HewlettPackard-netperf-2.7.1.p20210121-3bc455b23_GH0.tar.gz) = 9b6cc198f1727866ff337e444f35a12ecc708f92e74e12812e4e02f969b88a61
+SIZE (HewlettPackard-netperf-2.7.1.p20210121-3bc455b23_GH0.tar.gz) = 1913413
diff --git a/benchmarks/netperf/files/patch-configure b/benchmarks/netperf/files/patch-configure
deleted file mode 100644
index a45924e8e560..000000000000
--- a/benchmarks/netperf/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2017-09-21 17:32:54 UTC
-+++ configure
-@@ -6817,7 +6817,7 @@ fi
- done
-
- case "$host" in
-- *-*-freebsd[7-9].* | *-*-freebsd1[0-1].* )
-+ *-*-freebsd[7-9].* | *-*-freebsd[1-9][0-9].*)
- # FreeBSD 7.x and later SCTP support doesn't need -lsctp.
- ;;
- *)
-@@ -7392,7 +7392,7 @@ ac_cv_lib_kstat=ac_cv_lib_kstat_main
- enable_cpuutil="kstat - auto"
- NETCPU_SOURCE="kstat"
- ;;
-- *-*-freebsd[4-9].* | *-*-freebsd1[0-1].* | *-*-netbsd[1-9].* )
-+ *-*-freebsd[4-9].* | *-*-freebsd[1-9][0-9].* | *-*-netbsd[1-9].* )
- use_cpuutil=true
-
- $as_echo "#define USE_SYSCTL /**/" >>confdefs.h
diff --git a/benchmarks/netperf/files/patch-configure.ac b/benchmarks/netperf/files/patch-configure.ac
new file mode 100644
index 000000000000..dc965e15761d
--- /dev/null
+++ b/benchmarks/netperf/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac.orig 2021-01-21 16:02:24 UTC
++++ configure.ac
+@@ -472,7 +472,7 @@ case "$enable_sctp" in
+ #include <sys/socket.h>
+ ]])
+ case "$host" in
+- *-*-freebsd[[7-9]].* | *-*-freebsd1[[0-2]].* )
++ *-*-freebsd[[7-9]].* | *-*-freebsd[[1-9]][[0-9]].*)
+ # FreeBSD 7.x and later SCTP support doesn't need -lsctp.
+ ;;
+ *)
+@@ -704,7 +704,7 @@ case "$enable_cpuutil" in
+ enable_cpuutil="kstat - auto"
+ NETCPU_SOURCE="kstat"
+ ;;
+- *-*-freebsd[[4-9]].* | *-*-freebsd1[[0-2]].* | *-*-netbsd[[1-9]].* )
++ *-*-freebsd[[4-9]].* | *-*-freebsd[[1-9]][[0-9]].* | *-*-netbsd[[1-9]].* )
+ use_cpuutil=true
+ AC_DEFINE([USE_SYSCTL],,[Use MumbleBSD's sysctl interface to measure CPU util.])
+ enable_cpuutil="sysctl - auto"
diff --git a/benchmarks/netperf/files/patch-doc_examples_runemomni.sh b/benchmarks/netperf/files/patch-doc_examples_runemomni.sh
index caaa54ffb138..5718feef41fb 100644
--- a/benchmarks/netperf/files/patch-doc_examples_runemomni.sh
+++ b/benchmarks/netperf/files/patch-doc_examples_runemomni.sh
@@ -12,7 +12,7 @@
@@ -81,7 +83,7 @@ do
fi
for j in $set
- do
+ do
- netperf $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -m 64K;HDR="-P 0";
+ $NETPERF $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -m 64K;HDR="-P 0";
done
diff --git a/benchmarks/netperf/files/patch-doc_examples_runemomniagg2.sh b/benchmarks/netperf/files/patch-doc_examples_runemomniagg2.sh
index 9a64a32bf259..844fd6550979 100644
--- a/benchmarks/netperf/files/patch-doc_examples_runemomniagg2.sh
+++ b/benchmarks/netperf/files/patch-doc_examples_runemomniagg2.sh
@@ -11,11 +11,11 @@
@@ -84,11 +87,11 @@ echo four dl585 G5 clients rh5.2, each w
echo TCP_STREAM
for i in $concurrent_sessions; do
- j=0;
+ j=0;
- NETUUID=`netperf -t uuid`;
+ NETUUID=`$NETPERF -t uuid`;
echo $i concurrent streams id $NETUUID;
- while [ $j -lt $i ]; do
+ while [ $j -lt $i ]; do
client=`expr $j % $num_cli` ;
- netperf $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -m 64K -u $NETUUID & HDR="-P 0";
+ $NETPERF $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -m 64K -u $NETUUID & HDR="-P 0";
diff --git a/benchmarks/netperf/files/patch-doc_examples_runemomniaggdemo.sh b/benchmarks/netperf/files/patch-doc_examples_runemomniaggdemo.sh
index e2ba57a8a08f..bb68cc7c3766 100644
--- a/benchmarks/netperf/files/patch-doc_examples_runemomniaggdemo.sh
+++ b/benchmarks/netperf/files/patch-doc_examples_runemomniaggdemo.sh
@@ -3,7 +3,7 @@
@@ -138,7 +138,7 @@ then
fi
- # allow the netperf binary to be used to be overridden
+ # allow the netperf binary to be used to be overridden
-NETPERF=${NETPERF:="netperf"}
+NETPERF="%%PREFIX%%/bin/netperf"
diff --git a/benchmarks/netperf/files/patch-src_netserver.c b/benchmarks/netperf/files/patch-src_netserver.c
new file mode 100644
index 000000000000..b6b2781c6d8b
--- /dev/null
+++ b/benchmarks/netperf/files/patch-src_netserver.c
@@ -0,0 +1,11 @@
+--- src/netserver.c.orig 2021-01-21 16:02:24 UTC
++++ src/netserver.c
+@@ -260,8 +260,6 @@ open_debug_file()
+
+ #if !defined(WIN32)
+
+- chmod(FileName,0644);
+-
+ /* redirect stdin to "/dev/null" */
+ rd_null_fp = fopen(NETPERF_NULL,"r");
+ if (NULL == rd_null_fp) {
diff --git a/benchmarks/netperf/pkg-descr b/benchmarks/netperf/pkg-descr
index 369a70d44648..5e6d33dae960 100644
--- a/benchmarks/netperf/pkg-descr
+++ b/benchmarks/netperf/pkg-descr
@@ -1,5 +1,5 @@
Netperf is a serious networking performance evaluation tool being
-distributed under GPL by HP's Information Networks Division.
+distributed under BSD-1-clause by HP's Information Networks Division.
Testing is done using a pair of programs: `netserver' (the server) and
`netperf' (the measurement tool).