aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2023-02-04 16:27:45 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2023-02-10 21:15:12 +0000
commit3e73333f4bc31346815f13624775416af2c1d721 (patch)
tree5e332497b579b5b1449c1f4ad576da80a84833e3
parent67d92e052a364083dc46c6d9a071bd22ee64a814 (diff)
downloadports-3e73333f4bc31346815f13624775416af2c1d721.tar.gz
ports-3e73333f4bc31346815f13624775416af2c1d721.zip
graphics/libetonyek01: USES=localbase and Boost only as build dep
-rw-r--r--graphics/libetonyek01/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/libetonyek01/Makefile b/graphics/libetonyek01/Makefile
index 405fb0b9ae79..a3cda3e0b3fa 100644
--- a/graphics/libetonyek01/Makefile
+++ b/graphics/libetonyek01/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libetonyek
PORTVERSION= 0.1.10
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= LODEV/${PORTNAME}
@@ -14,19 +14,17 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/mdds-${MDDS_VERSION}/mdds/global.hpp:devel/mdds \
+ ${LOCALBASE}/include/boost/any.hpp:devel/boost-libs \
${LOCALBASE}/include/glm/glm.hpp:math/glm
-LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
- librevenge-0.0.so:textproc/librevenge \
+LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge \
liblangtag.so:devel/liblangtag \
libxml2.so:textproc/libxml2
-USES= compiler:c++11-lib gmake libtool pathfix \
- pkgconfig tar:xz
+USES= compiler:c++11-lib gmake libtool localbase pkgconfig tar:xz
MDDS_VERSION= 2.0
CONFIGURE_ARGS= --disable-tests --disable-werror --without-docs --with-mdds=${MDDS_VERSION}
-CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
USE_LDCONFIG= yes