aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof <ports@bsdserwis.com>2023-09-19 17:08:25 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-22 04:54:46 +0000
commit3e774cb07c9bb3a4fc28ad8d69c009c123fe3714 (patch)
tree4136e25d4ecaf2cc01c1a42998b33e54b3660ec0
parent2a076903c199b65e87d478b2d6d093c8fa77ef2e (diff)
downloadports-3e774cb07c9bb3a4fc28ad8d69c009c123fe3714.tar.gz
ports-3e774cb07c9bb3a4fc28ad8d69c009c123fe3714.zip
mail/postsrsd: add missing files and variables
This fixes an issue where postsrsd would fail to start. Reported by: Javier Sturman <sturmanj@gmail.com> PR: 273787
-rw-r--r--mail/postsrsd/Makefile7
-rw-r--r--mail/postsrsd/files/postsrsd.in2
2 files changed, 8 insertions, 1 deletions
diff --git a/mail/postsrsd/Makefile b/mail/postsrsd/Makefile
index cf906a7d0d4a..bf7cd417785b 100644
--- a/mail/postsrsd/Makefile
+++ b/mail/postsrsd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= postsrsd
-PORTVERSION= 2.0.8
+DISTVERSION= 2.0.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail
@@ -32,6 +33,7 @@ SUB_FILES= pkg-message
PLIST_FILES= \
sbin/postsrsd \
+ "@sample ${ETCDIR}.conf.sample" \
"@dir /var/db/${PORTNAME}"
PORTDOCS= CHANGELOG.rst README.rst postsrsd.conf
@@ -48,4 +50,7 @@ SQLITE_DESC= Use sqlite3 backebd for storing envelope senders
SQLITE_USES= sqlite
SQLITE_CMAKE_BOOL= WITH_SQLITE
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/postsrsd.conf ${STAGEDIR}${PREFIX}/etc/postsrsd.conf.sample
+
.include <bsd.port.mk>
diff --git a/mail/postsrsd/files/postsrsd.in b/mail/postsrsd/files/postsrsd.in
index a4625245439c..1e0617568447 100644
--- a/mail/postsrsd/files/postsrsd.in
+++ b/mail/postsrsd/files/postsrsd.in
@@ -13,6 +13,7 @@
# postsrsd_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable postsrsd.
# postsrsd_uid (str): Set username to run postsrsd.
+# postsrsd_secret (str): Secret file file. See postsrsd(8)
# postsrsd_flags (str): Flags passed to start command.
. /etc/rc.subr
@@ -33,6 +34,7 @@ load_rc_config $name
#
: ${postsrsd_enable="NO"}
: ${postsrsd_uid="mailnull"}
+: ${postsrsd_secret="%%PREFIX%%/etc/postsrsd.secret"}
# Options other than above can be set with $postsrsd_flags.
# see postsrsd documentation for detail.