aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-10 16:36:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-10 16:36:39 +0000
commit3ed2a61a8767ea35173d05639a035563f7bba71c (patch)
tree85bfdb16914bbfeee68cfe71c93899c417554344
parent73caa72efb8d05a399f298ac5b2f8f482a673d71 (diff)
downloadports-3ed2a61a8767ea35173d05639a035563f7bba71c.tar.gz
ports-3ed2a61a8767ea35173d05639a035563f7bba71c.zip
Unbundle libltdl
Differential Revision: https://reviews.freebsd.org/D1816 Reviewed by: tijl Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=378782
-rw-r--r--emulators/xsystem35/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 4020875d5073..c512a12dc26d 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xsystem35
PORTVERSION= 1.7.2
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= emulators games
MASTER_SITES= http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/down/
@@ -13,6 +13,7 @@ COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg
@@ -25,9 +26,9 @@ ESOUND_CONFIGURE_ON=--enable-audio=oss,esd --with-default-output=esd
MMX_BUILD_DEPENDS=nasm:${PORTSDIR}/devel/nasm
MMX_CONFIGURE_ENABLE=mmx
+EXTRACT_AFTER_ARGS=--exclude libltdl
USES= gettext gmake libtool shebangfix
SHEBANG_FILES= contrib/instgame
-USE_AUTOTOOLS= autoconf:env
USE_GNOME= gtk12
USE_XORG= x11 xext xxf86vm
GNU_CONFIGURE= yes
@@ -49,12 +50,13 @@ DOCSDIR= ${PREFIX}/share/doc/ja/${PORTNAME}
post-patch:
@${CP} ${WRKSRC}/INSTALL ${WRKSRC}/doc/INSTALL
- @${REINPLACE_CMD} '/-lxpg4/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/-lxpg4/d' \
+ -e '/INCLTDL=/d; /LTDLINCL=/d' \
+ -e '/LIBLTDL=/s/=.*/="-lltdl"/' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^SUBDIRS/s/ libltdl//' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} 's|__COUNTER__|__COUNTER_H__|' ${WRKSRC}/src/counter.h
-pre-configure:
- (cd ${WRKSRC}/libltdl; ${AUTOCONF})
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/instgame ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}