aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-02-08 16:12:30 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-02-08 20:24:23 +0000
commit3efc1cf3079d811c3620d3dce1ba95658abe38cf (patch)
treed9038df327c1576a53ec0ea2097ca616fab31419
parentdf05ae7c03b46705b888a47b5bdcb830f3ca0ae6 (diff)
downloadports-3efc1cf3079d811c3620d3dce1ba95658abe38cf.tar.gz
ports-3efc1cf3079d811c3620d3dce1ba95658abe38cf.zip
math/py-fastcluster: fix build on powerpc* with LLVM 14 by forcing 15
Assertion failed: ((CGF.CurFuncDecl == nullptr || CGF.Builder.getIsFPConstrained() || isa<CXXConstructorDecl>(CGF.CurFuncDecl) || isa<CXXDestructorDecl>(CGF.CurFuncDecl) || (NewExceptionBehavior == llvm::fp::ebIgnore && NewRoundingBehavior == llvm::RoundingMode::NearestTiesToEven)) && "FPConstrained should be enabled on entire function"), function ConstructorHelper, file /usr/local/poudriere/jails/main-powerpc64/usr/src/contrib/llvm-project/clang/lib/CodeGen/CodeGenFunction.cpp, line 163. (cherry picked from commit 278ced6f36e6b428c4f718bd8536a0b4884816e9)
-rw-r--r--math/py-fastcluster/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/math/py-fastcluster/Makefile b/math/py-fastcluster/Makefile
index 96ed61f5a1e7..b9db6e67c12f 100644
--- a/math/py-fastcluster/Makefile
+++ b/math/py-fastcluster/Makefile
@@ -14,10 +14,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9,1:math/py-numpy@${PY_FLAVOR}
-USES= python:3.7+
+USES= compiler python:3.7+
USE_PYTHON= autoplist concurrent distutils
+.include <bsd.port.pre.mk>
+
+.if ${ARCH:Mpowerpc*} && ${COMPILER_VERSION} == 140
+BUILD_DEPENDS+= clang15:devel/llvm15
+CPP= clang-cpp15
+CC= clang15
+CXX= clang++15
+.endif
+
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>