aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-09-28 06:40:56 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-09-28 06:42:30 +0000
commit3f4627fc27ad26876fdc440d51500c960f282751 (patch)
tree1a8275831dc90f9c727296333f636d7ea2b23680
parent2fb798e986f053cbc26c94bc6a27cba67a1bbcd0 (diff)
downloadports-3f4627fc27ad26876fdc440d51500c960f282751.tar.gz
ports-3f4627fc27ad26876fdc440d51500c960f282751.zip
emulators/wine-devel: Unconditionally use SDL
SDL2 is indirectly pulled in via our (unconditional) FAudio dependency anyway, so always use it, remove the SDL option, and simplify the port accordingly. PR: 258375
-rw-r--r--emulators/wine-devel/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 42f52c5f2b59..d6eb6e8d42b1 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -23,8 +23,10 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
LIB_DEPENDS= libFAudio.so:audio/faudio \
libxml2.so:textproc/libxml2
-USES= bison cpe desktop-file-utils gmake localbase pkgconfig shebangfix tar:xz
+USES= bison cpe desktop-file-utils gmake localbase \
+ pkgconfig sdl shebangfix tar:xz
USE_GCC= yes
+USE_SDL= sdl2
CPE_VENDOR= winehq
@@ -50,6 +52,7 @@ CONFIGURE_ARGS+=--verbose \
--with-oss \
--without-pulse \
--without-sane \
+ --with-sdl \
--without-tiff \
--without-udev \
--without-unwind \
@@ -66,13 +69,12 @@ SUB_FILES= pkg-message
PORTDATA= wine.inf
-OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS LDAP LIBXSLT MPG123 OPENAL SDL STAGING V4L WINEMAKER X11 GECKO MONO
+OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS LDAP LIBXSLT MPG123 OPENAL STAGING V4L WINEMAKER X11 GECKO MONO
OPTIONS_DEFAULT=GNUTLS OPENAL X11
OPTIONS_SUB= yes
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
-SDL_DESC= Use SDL for gamepad support (XInput only)
STAGING_DESC= Include Wine Staging patchset (experimental&unsupported)
WINEMAKER_DESC= Fully support winemaker (requires Perl)
GECKO_DESC= Bundle Gecko MSI package for Wine
@@ -102,10 +104,6 @@ MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
OPENAL_CONFIGURE_WITH= openal
OPENAL_USES= openal
-SDL_CONFIGURE_WITH= sdl
-SDL_USES= sdl
-SDL_USE= SDL=sdl2
-
STAGING_MASTER_SITES= https://github.com/wine-staging/wine-staging/archive/:staging
STAGING_DIST= v${DISTVERSION}.tar.gz
STAGING_DISTFILES= ${STAGING_DIST}:staging