aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-01-12 15:51:33 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-01-13 10:15:05 +0000
commit3f5bebfe0095594f351f7ac90ba3dda1dd6e12c8 (patch)
tree49373165baeb4191d8f1516a8d75e4a650c3ed08
parent3717100872b29a65ccfd15e8df61c09cd346e313 (diff)
downloadports-3f5bebfe0095594f351f7ac90ba3dda1dd6e12c8.tar.gz
ports-3f5bebfe0095594f351f7ac90ba3dda1dd6e12c8.zip
math/suitesparse-paru: new port, parallel unsymmetric multifrontal method
-rw-r--r--math/Makefile1
-rw-r--r--math/suitesparse-paru/Makefile27
-rw-r--r--math/suitesparse-paru/pkg-descr4
-rw-r--r--math/suitesparse-paru/pkg-plist14
-rw-r--r--math/suitesparse/Makefile1
-rw-r--r--math/suitesparse/bsd.suitesparse.mk1
6 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c105d38c9b65..345406ce012f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1178,6 +1178,7 @@
SUBDIR += suitesparse-lagraph
SUBDIR += suitesparse-ldl
SUBDIR += suitesparse-mongoose
+ SUBDIR += suitesparse-paru
SUBDIR += suitesparse-rbio
SUBDIR += suitesparse-spex
SUBDIR += suitesparse-spqr
diff --git a/math/suitesparse-paru/Makefile b/math/suitesparse-paru/Makefile
new file mode 100644
index 000000000000..ffb06f26ff5f
--- /dev/null
+++ b/math/suitesparse-paru/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= ${MPORTNAME:tl}
+PORTVERSION= 0.1.1
+CATEGORIES= math parallel
+
+COMMENT= Parallel unsymmetric multifrontal method
+WWW= https://faculty.cse.tamu.edu/davis/suitesparse.html
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libumfpack.so:math/suitesparse-umfpack
+
+USES= localbase
+CMAKE_ARGS+= -DUMFPACK_DIR:PATH="${LOCALBASE}/lib/cmake/UMFPACK"
+
+MPORTNAME= ParU
+USE_LDCONFIG= yes
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+
+post-stage-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/README.md \
+ ${STAGEDIR}${DOCSDIR}/${MPORTNAME}_README.md
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/Doc/paru_user_guide.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/math/suitesparse-paru/pkg-descr b/math/suitesparse-paru/pkg-descr
new file mode 100644
index 000000000000..e784407aeb29
--- /dev/null
+++ b/math/suitesparse-paru/pkg-descr
@@ -0,0 +1,4 @@
+This port installs the module ParU of SuiteSparse.
+
+ParU is a set of routines for solving sparse linear system via parallel
+multifrontal LU factorization algorithms.
diff --git a/math/suitesparse-paru/pkg-plist b/math/suitesparse-paru/pkg-plist
new file mode 100644
index 000000000000..cb2209f264ef
--- /dev/null
+++ b/math/suitesparse-paru/pkg-plist
@@ -0,0 +1,14 @@
+include/suitesparse/ParU.hpp
+include/suitesparse/ParU_C.h
+include/suitesparse/ParU_definitions.h
+lib/cmake/ParU/ParUConfig.cmake
+lib/cmake/ParU/ParUConfigVersion.cmake
+lib/cmake/ParU/ParUTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ParU/ParUTargets.cmake
+lib/libparu.a
+lib/libparu.so
+lib/libparu.so.0
+lib/libparu.so.%%VER%%
+libdata/pkgconfig/ParU.pc
+%%PORTDOCS%%%%DOCSDIR%%/ParU_README.md
+%%PORTDOCS%%%%DOCSDIR%%/paru_user_guide.pdf
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 854528772898..782fc8b97d2f 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= suitesparse-config>0:math/suitesparse-config \
suitesparse-lagraph>0:math/suitesparse-lagraph \
suitesparse-ldl>0:math/suitesparse-ldl \
suitesparse-mongoose>0:math/suitesparse-mongoose \
+ suitesparse-paru>0:math/suitesparse-paru \
suitesparse-rbio>0:math/suitesparse-rbio \
suitesparse-spex>0:math/suitesparse-spex \
suitesparse-spqr>0:math/suitesparse-spqr \
diff --git a/math/suitesparse/bsd.suitesparse.mk b/math/suitesparse/bsd.suitesparse.mk
index 8a1a9190878b..b924bdbc43d7 100644
--- a/math/suitesparse/bsd.suitesparse.mk
+++ b/math/suitesparse/bsd.suitesparse.mk
@@ -60,6 +60,7 @@ OPTIONS_DEFAULT+= OPTIMIZED_CFLAGS
.if ${MPORTNAME} == config || \
${MPORTNAME} == CHOLMOD || \
+ ${MPORTNAME} == ParU || \
${MPORTNAME} == SPQR || \
${MPORTNAME} == UMFPACK
OPTIONS_RADIO+= BLAS