aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2023-12-01 21:22:20 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2023-12-01 21:25:41 +0000
commit3f92c66f41ea624538d2b21d983ac9e89a8f6992 (patch)
treed850bb9d8ad079d7161f99eda0fcf8342a1088b1
parentf7e264a920ca64b9828f19493df7c7b7658c8e92 (diff)
downloadports-3f92c66f41ea624538d2b21d983ac9e89a8f6992.tar.gz
ports-3f92c66f41ea624538d2b21d983ac9e89a8f6992.zip
archivers/rpm4: Unbreak build for FreeBSD 14
-rw-r--r--archivers/rpm4/Makefile2
-rw-r--r--archivers/rpm4/files/patch-python_header-py.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index a3e8898b6bb6..d10ea97f6f2a 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rpm
PORTVERSION= 4.18.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://ftp.rpm.org/releases/rpm-${PORTVERSION:R}.x/
PKGNAMESUFFIX= 4
diff --git a/archivers/rpm4/files/patch-python_header-py.c b/archivers/rpm4/files/patch-python_header-py.c
new file mode 100644
index 000000000000..828f441dddd8
--- /dev/null
+++ b/archivers/rpm4/files/patch-python_header-py.c
@@ -0,0 +1,11 @@
+--- python/header-py.c.orig 2023-11-30 19:45:23 UTC
++++ python/header-py.c
+@@ -741,7 +741,7 @@
+ 0, /* tp_as_number */
+ &hdr_as_sequence, /* tp_as_sequence */
+ &hdr_as_mapping, /* tp_as_mapping */
+- hdr_hash, /* tp_hash */
++ (hashfunc)hdr_hash, /* tp_hash */
+ 0, /* tp_call */
+ 0, /* tp_str */
+ (getattrofunc) hdr_getattro, /* tp_getattro */