aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-10 22:25:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-10 22:37:53 +0000
commit4054c13798a5c74e89f5258fd2eb23d1eb72a67d (patch)
treefb0d0a6928ffd44d4c2bb2ea36c0587c0e7540c6
parent60e94873d15b407c1b399b980ae6a8ac69a30949 (diff)
downloadports-4054c13798a5c74e89f5258fd2eb23d1eb72a67d.tar.gz
ports-4054c13798a5c74e89f5258fd2eb23d1eb72a67d.zip
cad/xyce: Change to GNU tools build; Add missing test dependencies
GNU tools build is stable, and cmake build isn't yet considered to be stable.
-rw-r--r--cad/xyce/Makefile40
-rw-r--r--cad/xyce/pkg-plist12
2 files changed, 40 insertions, 12 deletions
diff --git a/cad/xyce/Makefile b/cad/xyce/Makefile
index 558dca5707a6..b9e2a23955d0 100644
--- a/cad/xyce/Makefile
+++ b/cad/xyce/Makefile
@@ -1,9 +1,10 @@
PORTNAME= xyce
DISTVERSION= 7.5.0
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= https://github.com/Xyce/Xyce/archive/refs/tags/
DISTNAME= Release-${DISTVERSION}
-DIST_SUBDIR= xyce-${DISTVERSION}
+DIST_SUBDIR= ${PORTNAME}-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Xyce electronic simulator
@@ -11,24 +12,39 @@ COMMENT= Xyce electronic simulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libamd.so:math/suitesparse-amd \
- libblas.so:math/blas \
+LIB_DEPENDS= libblas.so:math/blas \
libfftw3.so:math/fftw3 \
liblapack.so:math/lapack \
libtpetra.so:science/trilinos \
+ \
+ libamd.so:math/suitesparse-amd \
+ libcholmod.so:math/suitesparse-cholmod \
+ libcolamd.so:math/suitesparse-colamd \
+ libsuitesparseconfig.so:math/suitesparse-config \
libumfpack.so:math/suitesparse-umfpack
-TEST_DEPENDS= git:devel/git
+TEST_DEPENDS= git:devel/git \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ # also needs pycompadre
-USES= bison cmake localbase
-
-CMAKE_ON= BUILD_SHARED_LIBS
+USES= autoreconf bison gmake fortran libtool localbase perl5 python:test # GNU tools should be used for 7.5 and on until the cmake cbuild is declared stable
+USE_CXXSTD= c++14 # otherwise configure fails because of c++14 features like std::conditional_t
+USE_LDCONFIG= yes
+USE_PERL5= test
WRKSRC= ${WRKDIR}/Xyce-Release-${DISTVERSION}
-post-install:
- @cd ${STAGEDIR}${PREFIX} && \
- ${RM} ${STAGEDIR}${PREFIX}/doc/README.TXT && \
- ${RMDIR} ${STAGEDIR}${PREFIX}/doc
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= LEX=/usr/bin/flex \
+ --enable-stokhos \
+ --enable-amesos \
+ --enable-shared \
+ --disable-static
+
+INSTALL_TARGET= install-strip
+
+BINARY_ALIAS= python=${PYTHON_CMD} # only for tests
do-test:
# checkout tests
@@ -43,7 +59,7 @@ do-test:
@cd ${TEST_WRKSRC} && ( \
${ECHO} "running tests ..."; \
eval `${WRKDIR}/Xyce_Regression/TestScripts/suggestXyceTagList.sh ${STAGEDIR}${PREFIX}/bin/Xyce` ; \
- ${WRKDIR}/Xyce_Regression/TestScripts/run_xyce_regression \
+ ${SETENV} ${TEST_ENV} ${WRKDIR}/Xyce_Regression/TestScripts/run_xyce_regression \
--output=${WRKDIR}/Xyce_Test \
--xyce_test="${WRKDIR}/Xyce_Regression" \
--resultfile=${WRKDIR}/serial_results \
diff --git a/cad/xyce/pkg-plist b/cad/xyce/pkg-plist
index 390f7b41e0f2..2f8ee5043571 100644
--- a/cad/xyce/pkg-plist
+++ b/cad/xyce/pkg-plist
@@ -83,3 +83,15 @@ include/N_UTL_Xyce.h
include/N_UTL_fwd.h
include/Xyce_config.h
lib/libxyce.so
+lib/libxyce.so.0
+lib/libxyce.so.0.0.0
+share/xml/adms.implicit.xml
+share/xml/html_params.xml
+share/xml/xyceAnalogFunction_nosac.xml
+share/xml/xyceBasicTemplates_nosac.xml
+share/xml/xyceBootstrapFile.xml
+share/xml/xyceHeaderFile_nosac.xml
+share/xml/xyceImplementationFile_nosac.xml
+share/xml/xyceMakefile.am.xml
+share/xml/xyceOutVarsDoc.xml
+share/xml/xyceVersion_nosac.xml