aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-13 10:16:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-13 10:16:36 +0000
commit4073556f569f624ef79af6b0b3a48b3620ee67d4 (patch)
tree2f73be7fc81fd1800a51856058ec1b53c47b67a5
parent7f3266505f1f35aad36d856754b8e2c413edfd1c (diff)
devel/py-junitparser: New port: Manipulating JUnit/xUnit Result XML files
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-junitparser/Makefile22
-rw-r--r--devel/py-junitparser/distinfo3
-rw-r--r--devel/py-junitparser/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fd8f7e11dfb9..43b1174a9e53 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4870,6 +4870,7 @@
SUBDIR += py-jsonschema3
SUBDIR += py-jsonschema417
SUBDIR += py-jsonsir
+ SUBDIR += py-junitparser
SUBDIR += py-jupyter-client
SUBDIR += py-jupyter-collaboration
SUBDIR += py-jupyter-core
diff --git a/devel/py-junitparser/Makefile b/devel/py-junitparser/Makefile
new file mode 100644
index 000000000000..8258529d3750
--- /dev/null
+++ b/devel/py-junitparser/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= junitparser
+DISTVERSION= 3.1.0
+CATEGORIES= devel net
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Manipulating JUnit/xUnit Result XML files
+WWW= https://junitparser.readthedocs.io/en/latest/
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-junitparser/distinfo b/devel/py-junitparser/distinfo
new file mode 100644
index 000000000000..fb689be19079
--- /dev/null
+++ b/devel/py-junitparser/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1699868381
+SHA256 (junitparser-3.1.0.tar.gz) = e69d14c61404f6193407bdb36adcae720e9a99ba3c1712ef78cccf0a21bb521d
+SIZE (junitparser-3.1.0.tar.gz) = 14252
diff --git a/devel/py-junitparser/pkg-descr b/devel/py-junitparser/pkg-descr
new file mode 100644
index 000000000000..11d37ec8045c
--- /dev/null
+++ b/devel/py-junitparser/pkg-descr
@@ -0,0 +1,3 @@
+junitparser handles JUnit/xUnit Result XML files.
+Use it to parse and manipulate existing Result XML files,
+or create new JUnit/xUnit result XMLs from scratch.