aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-09-26 21:31:46 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-09-26 21:31:46 +0000
commit4092f22bdc700d8c34c18c6c0fd5cb05d27016ec (patch)
tree97f4c0f8bde25549d8b1554fc30109f98f683b88
parent5d2cf658ff3994575b89a05ea2cc9c0c1bedbfd7 (diff)
downloadports-4092f22bdc700d8c34c18c6c0fd5cb05d27016ec.tar.gz
ports-4092f22bdc700d8c34c18c6c0fd5cb05d27016ec.zip
- Update yaml-cpp to 0.6.3
- Removed TEST option since it fails to build. Disable tests unconditionally. - Bump PORTREVISION on dependent ports. I've observed linker errors on startup due to library changes
Notes
Notes: svn path=/head/; revision=512990
-rw-r--r--chinese/librime/Makefile1
-rw-r--r--devel/yaml-cpp/Makefile13
-rw-r--r--devel/yaml-cpp/distinfo6
-rw-r--r--devel/yaml-cpp/files/patch-CMakeLists.txt20
-rw-r--r--devel/yaml-cpp/pkg-plist58
-rw-r--r--games/openxcom/Makefile2
-rw-r--r--net-mgmt/openbmp/Makefile2
-rw-r--r--sysutils/cloudabi-utils/Makefile1
-rw-r--r--sysutils/crate/Makefile1
-rw-r--r--sysutils/daggy/Makefile2
-rw-r--r--sysutils/facter/Makefile1
-rw-r--r--www/envoy/Makefile2
12 files changed, 26 insertions, 83 deletions
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 0f686f3fecb5..559b52554119 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -3,6 +3,7 @@
PORTNAME= librime
PORTVERSION= 1.2.9
+PORTREVISION= 1
DISTVERSIONPREFIX= rime-
PORTREVISION= 18
CATEGORIES= chinese textproc
diff --git a/devel/yaml-cpp/Makefile b/devel/yaml-cpp/Makefile
index ecf0c46f6c4c..1cb5681d8587 100644
--- a/devel/yaml-cpp/Makefile
+++ b/devel/yaml-cpp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= yaml-cpp
-PORTVERSION= 0.6.2
-PORTREVISION= 2
+PORTVERSION= 0.6.3
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= devel
@@ -15,13 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0
-
-OPTIONS_DEFINE= TEST
-OPTIONS_SUB= yes
-
-TEST_CMAKE_BOOL= YAML_CPP_BUILD_TESTS
-TEST_CONFLICTS_INSTALL= googletest
+CMAKE_ARGS+= -DYAML_BUILD_SHARED_LIBS:BOOL=ON \
+ -DYAML_CPP_BUILD_TOOLS=OFF \
+ -DYAML_CPP_BUILD_TESTS=OFF
USE_GITHUB= yes
GH_ACCOUNT= jbeder
diff --git a/devel/yaml-cpp/distinfo b/devel/yaml-cpp/distinfo
index 927050666246..cf48f76baa56 100644
--- a/devel/yaml-cpp/distinfo
+++ b/devel/yaml-cpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520322187
-SHA256 (jbeder-yaml-cpp-yaml-cpp-0.6.2_GH0.tar.gz) = e4d8560e163c3d875fd5d9e5542b5fd5bec810febdcba61481fe5fc4e6b1fd05
-SIZE (jbeder-yaml-cpp-yaml-cpp-0.6.2_GH0.tar.gz) = 1396250
+TIMESTAMP = 1569483448
+SHA256 (jbeder-yaml-cpp-yaml-cpp-0.6.3_GH0.tar.gz) = 77ea1b90b3718aa0c324207cb29418f5bced2354c2e483a9523d98c3460af1ed
+SIZE (jbeder-yaml-cpp-yaml-cpp-0.6.3_GH0.tar.gz) = 1398768
diff --git a/devel/yaml-cpp/files/patch-CMakeLists.txt b/devel/yaml-cpp/files/patch-CMakeLists.txt
index 1cacfe5cd5a7..0471011527bc 100644
--- a/devel/yaml-cpp/files/patch-CMakeLists.txt
+++ b/devel/yaml-cpp/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2016-01-10 18:11:40 UTC
+--- CMakeLists.txt.orig 2019-09-25 16:56:00 UTC
+++ CMakeLists.txt
-@@ -276,7 +276,7 @@ set_target_properties(yaml-cpp PROPERTIE
+@@ -276,7 +276,7 @@ set_target_properties(yaml-cpp PROPERTIES
set_target_properties(yaml-cpp PROPERTIES
VERSION "${YAML_CPP_VERSION}"
@@ -9,12 +9,12 @@
PROJECT_LABEL "yaml-cpp ${LABEL_SUFFIX}"
)
-@@ -320,7 +320,7 @@ configure_file(${CMAKE_CURRENT_SOURCE_DI
- if(UNIX)
- set(PC_FILE ${CMAKE_BINARY_DIR}/yaml-cpp.pc)
- configure_file("yaml-cpp.pc.cmake" ${PC_FILE} @ONLY)
-- install(FILES ${PC_FILE} DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-+ install(FILES ${PC_FILE} DESTINATION libdata/pkgconfig)
- endif()
-
+@@ -342,7 +342,7 @@ if (YAML_CPP_INSTALL)
+ if(UNIX)
+ set(PC_FILE ${CMAKE_BINARY_DIR}/yaml-cpp.pc)
+ configure_file("yaml-cpp.pc.cmake" ${PC_FILE} @ONLY)
+- install(FILES ${PC_FILE} DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
++ install(FILES ${PC_FILE} DESTINATION libdata/pkgconfig)
+ endif()
+ endif()
diff --git a/devel/yaml-cpp/pkg-plist b/devel/yaml-cpp/pkg-plist
index 6a02bd7cdcd5..a3bc8c217690 100644
--- a/devel/yaml-cpp/pkg-plist
+++ b/devel/yaml-cpp/pkg-plist
@@ -1,54 +1,3 @@
-%%TEST%%include/gmock/gmock-actions.h
-%%TEST%%include/gmock/gmock-cardinalities.h
-%%TEST%%include/gmock/gmock-generated-actions.h
-%%TEST%%include/gmock/gmock-generated-actions.h.pump
-%%TEST%%include/gmock/gmock-generated-function-mockers.h
-%%TEST%%include/gmock/gmock-generated-function-mockers.h.pump
-%%TEST%%include/gmock/gmock-generated-matchers.h
-%%TEST%%include/gmock/gmock-generated-matchers.h.pump
-%%TEST%%include/gmock/gmock-generated-nice-strict.h
-%%TEST%%include/gmock/gmock-generated-nice-strict.h.pump
-%%TEST%%include/gmock/gmock-matchers.h
-%%TEST%%include/gmock/gmock-more-actions.h
-%%TEST%%include/gmock/gmock-more-matchers.h
-%%TEST%%include/gmock/gmock-spec-builders.h
-%%TEST%%include/gmock/gmock.h
-%%TEST%%include/gmock/internal/custom/gmock-generated-actions.h
-%%TEST%%include/gmock/internal/custom/gmock-generated-actions.h.pump
-%%TEST%%include/gmock/internal/custom/gmock-matchers.h
-%%TEST%%include/gmock/internal/custom/gmock-port.h
-%%TEST%%include/gmock/internal/gmock-generated-internal-utils.h
-%%TEST%%include/gmock/internal/gmock-generated-internal-utils.h.pump
-%%TEST%%include/gmock/internal/gmock-internal-utils.h
-%%TEST%%include/gmock/internal/gmock-port.h
-%%TEST%%include/gtest/gtest-death-test.h
-%%TEST%%include/gtest/gtest-message.h
-%%TEST%%include/gtest/gtest-param-test.h
-%%TEST%%include/gtest/gtest-param-test.h.pump
-%%TEST%%include/gtest/gtest-printers.h
-%%TEST%%include/gtest/gtest-spi.h
-%%TEST%%include/gtest/gtest-test-part.h
-%%TEST%%include/gtest/gtest-typed-test.h
-%%TEST%%include/gtest/gtest.h
-%%TEST%%include/gtest/gtest_pred_impl.h
-%%TEST%%include/gtest/gtest_prod.h
-%%TEST%%include/gtest/internal/custom/gtest-port.h
-%%TEST%%include/gtest/internal/custom/gtest-printers.h
-%%TEST%%include/gtest/internal/custom/gtest.h
-%%TEST%%include/gtest/internal/gtest-death-test-internal.h
-%%TEST%%include/gtest/internal/gtest-filepath.h
-%%TEST%%include/gtest/internal/gtest-internal.h
-%%TEST%%include/gtest/internal/gtest-linked_ptr.h
-%%TEST%%include/gtest/internal/gtest-param-util-generated.h
-%%TEST%%include/gtest/internal/gtest-param-util-generated.h.pump
-%%TEST%%include/gtest/internal/gtest-param-util.h
-%%TEST%%include/gtest/internal/gtest-port-arch.h
-%%TEST%%include/gtest/internal/gtest-port.h
-%%TEST%%include/gtest/internal/gtest-string.h
-%%TEST%%include/gtest/internal/gtest-tuple.h
-%%TEST%%include/gtest/internal/gtest-tuple.h.pump
-%%TEST%%include/gtest/internal/gtest-type-util.h
-%%TEST%%include/gtest/internal/gtest-type-util.h.pump
include/yaml-cpp/anchor.h
include/yaml-cpp/binary.h
include/yaml-cpp/contrib/anchordict.h
@@ -79,7 +28,6 @@ include/yaml-cpp/node/node.h
include/yaml-cpp/node/parse.h
include/yaml-cpp/node/ptr.h
include/yaml-cpp/node/type.h
-include/yaml-cpp/noncopyable.h
include/yaml-cpp/null.h
include/yaml-cpp/ostream_wrapper.h
include/yaml-cpp/parser.h
@@ -90,11 +38,7 @@ lib/cmake/yaml-cpp/yaml-cpp-config-version.cmake
lib/cmake/yaml-cpp/yaml-cpp-config.cmake
lib/cmake/yaml-cpp/yaml-cpp-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/yaml-cpp/yaml-cpp-targets.cmake
-%%TEST%%lib/libgmock.so
-%%TEST%%lib/libgmock_main.so
-%%TEST%%lib/libgtest.so
-%%TEST%%lib/libgtest_main.so
lib/libyaml-cpp.so
lib/libyaml-cpp.so.0
-lib/libyaml-cpp.so.0.6.2
+lib/libyaml-cpp.so.0.6.3
libdata/pkgconfig/yaml-cpp.pc
diff --git a/games/openxcom/Makefile b/games/openxcom/Makefile
index 84e594c6d518..da0a0697b4c1 100644
--- a/games/openxcom/Makefile
+++ b/games/openxcom/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openxcom
PORTVERSION= 1.0
DISTVERSIONPREFIX= v
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/net-mgmt/openbmp/Makefile b/net-mgmt/openbmp/Makefile
index 1903c93b9bd0..054fb23e5bb8 100644
--- a/net-mgmt/openbmp/Makefile
+++ b/net-mgmt/openbmp/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openbmp
DISTVERSIONPREFIX= v
DISTVERSION= 0.14.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-mgmt
MAINTAINER= pizzamig@FreeBSD.org
diff --git a/sysutils/cloudabi-utils/Makefile b/sysutils/cloudabi-utils/Makefile
index 57e21786cfb2..f7f385ca6ebd 100644
--- a/sysutils/cloudabi-utils/Makefile
+++ b/sysutils/cloudabi-utils/Makefile
@@ -4,6 +4,7 @@
PORTNAME= cloudabi-utils
DISTVERSIONPREFIX= v
DISTVERSION= 0.38
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= ed@FreeBSD.org
diff --git a/sysutils/crate/Makefile b/sysutils/crate/Makefile
index d4b92c9a573f..a770c18ce7f7 100644
--- a/sysutils/crate/Makefile
+++ b/sysutils/crate/Makefile
@@ -2,6 +2,7 @@
PORTNAME= crate
DISTVERSION= 0.1.3
+PORTREVISION= 1
CATEGORIES= sysutils emulators
MAINTAINER= yuri@FreeBSD.org
diff --git a/sysutils/daggy/Makefile b/sysutils/daggy/Makefile
index ac14ca78b803..47c39e1db9e7 100644
--- a/sysutils/daggy/Makefile
+++ b/sysutils/daggy/Makefile
@@ -2,7 +2,7 @@
PORTNAME= daggy
DISTVERSION= 1.1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= yuri@FreeBSD.org
diff --git a/sysutils/facter/Makefile b/sysutils/facter/Makefile
index 4d01f16f3e5e..5171c86ff412 100644
--- a/sysutils/facter/Makefile
+++ b/sysutils/facter/Makefile
@@ -2,6 +2,7 @@
PORTNAME= facter
PORTVERSION= 3.14.4
+PORTREVISION= 1
CATEGORIES?= sysutils
MASTER_SITES= https://downloads.puppetlabs.com/facter/
diff --git a/www/envoy/Makefile b/www/envoy/Makefile
index 9366e21740fa..3b7d63442b27 100644
--- a/www/envoy/Makefile
+++ b/www/envoy/Makefile
@@ -4,7 +4,7 @@
PORTNAME= envoy
PORTVERSION= 1.10.0
DISTVERSIONPREFIX= v
-PORTREVISION= 4
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= danfe@FreeBSD.org