aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 19:54:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 19:54:43 +0000
commit40cccee32402d3f22c63040869c37ac5a962c9b9 (patch)
tree1e82c00f89efa18a750307c2e9b671534ea1dc66
parentca77dc193eb1d9bee82da08024fb7dfce07fc802 (diff)
downloadports-40cccee32402d3f22c63040869c37ac5a962c9b9.tar.gz
ports-40cccee32402d3f22c63040869c37ac5a962c9b9.zip
math/fann: fix plist without libomp
pkg-static: Unable to access file /wrkdirs/usr/ports/math/fann/work/stage/usr/local/include/parallel_fann.h:No such file or directory pkg-static: Unable to access file /wrkdirs/usr/ports/math/fann/work/stage/usr/local/include/parallel_fann.hpp:No such file or directory
-rw-r--r--math/fann/Makefile6
-rw-r--r--math/fann/pkg-plist4
2 files changed, 8 insertions, 2 deletions
diff --git a/math/fann/Makefile b/math/fann/Makefile
index 85e71ff6a3f8..63d8bd6c79c3 100644
--- a/math/fann/Makefile
+++ b/math/fann/Makefile
@@ -16,4 +16,10 @@ USE_GITHUB= yes
GH_ACCOUNT= libfann
GH_TAGNAME= 8409b42
+.if !exists(/usr/include/omp.h)
+PLIST_SUB= OPENMP="@comment "
+.else
+PLIST_SUB= OPENMP=""
+.endif
+
.include <bsd.port.mk>
diff --git a/math/fann/pkg-plist b/math/fann/pkg-plist
index 0e982deeb0d5..b490ccd1056d 100644
--- a/math/fann/pkg-plist
+++ b/math/fann/pkg-plist
@@ -12,8 +12,8 @@ include/fann_train.h
include/fann_training_data_cpp.h
include/fixedfann.h
include/floatfann.h
-include/parallel_fann.h
-include/parallel_fann.hpp
+%%OPENMP%%include/parallel_fann.h
+%%OPENMP%%include/parallel_fann.hpp
lib/cmake/fann/fann-config.cmake
lib/cmake/fann/fann-use.cmake
lib/libdoublefann.a