aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-10-11 07:16:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-10-11 07:16:55 +0000
commit40f1c0d283d42c1c89222da3e84428db730c31cf (patch)
tree8df556df6803a8f4744427c11c576cf89dd45bfb
parentac9de29196101c4c4abc2e9a5bbf2727372b2536 (diff)
downloadports-40f1c0d283d42c1c89222da3e84428db730c31cf.tar.gz
ports-40f1c0d283d42c1c89222da3e84428db730c31cf.zip
editors/libreoffice: drop handling of icon cache
Let the icon cache be handle by the trigger brought in by the toolkits on the system.
-rw-r--r--editors/libreoffice/Makefile13
-rw-r--r--editors/libreoffice6/Makefile10
2 files changed, 3 insertions, 20 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 1749975bc153..4d95da5e1a91 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -149,12 +149,10 @@ GNOME_LIB_DEPENDS= libdbus-1.so:devel/dbus \
GNOME_USE= GNOME=dconf
GTK3_CONFIGURE_ENABLE= gtk3
-GTK3_USE= GNOME=gtk30,gtk-update-icon-cache
-GTK3_VARS= POST_PLIST=add-plist-gnome
+GTK3_USE= GNOME=gtk30
GTK4_CONFIGURE_ENABLE= gtk4
-GTK4_USE= GNOME=gtk40,gtk-update-icon-cache
-GTK4_VARS= POST_PLIST=add-plist-gnome
+GTK4_USE= GNOME=gtk40
JAVA_BUILD_DEPENDS= ant:devel/apache-ant \
${JAVAJARDIR}/commons-codec.jar:java/apache-commons-codec \
@@ -346,11 +344,4 @@ post-install-SDK-on:
${FIND} -s ${subdir}/libreoffice -not -type d >> ${TMPPLIST}
.endfor
-add-plist-gnome:
-.for subdir in gnome hicolor locolor
- @${ECHO_CMD} "@rmtry share/icons/${subdir}/icon-theme.cache" >> ${TMPPLIST}
- @${ECHO_CMD} "@postexec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/share/icons/${subdir} 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
- @${ECHO_CMD} "@postunexec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/share/icons/${subdir} 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
-.endfor
-
.include <bsd.port.post.mk>
diff --git a/editors/libreoffice6/Makefile b/editors/libreoffice6/Makefile
index dfa18147dd27..ceb69f8fd542 100644
--- a/editors/libreoffice6/Makefile
+++ b/editors/libreoffice6/Makefile
@@ -146,8 +146,7 @@ GNOME_LIB_DEPENDS= libdbus-1.so:devel/dbus \
GNOME_USE= GNOME=dconf
GTK3_CONFIGURE_ENABLE= gtk3
-GTK3_USE= GNOME=gtk30,gtk-update-icon-cache
-GTK3_VARS= POST_PLIST=add-plist-gnome
+GTK3_USE= GNOME=gtk30
I18N_CONFIGURE_WITH= lang=ALL
I18N_DISTFILES= ${PORTNAME}-dictionaries-${LOVERSION}${EXTRACT_SUFX} \
@@ -322,11 +321,4 @@ post-install-SDK-on:
${FIND} -s ${subdir}/libreoffice -not -type d >> ${TMPPLIST}
.endfor
-add-plist-gnome:
-.for subdir in gnome hicolor locolor
- @${ECHO_CMD} "@rmtry share/icons/${subdir}/icon-theme.cache" >> ${TMPPLIST}
- @${ECHO_CMD} "@postexec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/share/icons/${subdir} 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
- @${ECHO_CMD} "@postunexec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/share/icons/${subdir} 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
-.endfor
-
.include <bsd.port.post.mk>