aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-18 20:02:30 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-18 20:02:30 +0000
commit414efbaa699ceb86eb1fd839daf08e51974887f7 (patch)
tree5755f6adeab14b77a7d87f5f9bc5099a2117e2e3
parenta808abe8148d987e8db91039e7955b1cfbef3a56 (diff)
downloadports-414efbaa699ceb86eb1fd839daf08e51974887f7.tar.gz
ports-414efbaa699ceb86eb1fd839daf08e51974887f7.zip
sysutils/qpxtool: qt4-linguist -> qt4-linguisttools, add LICENSE
- Add LICENSE/LICENSE_FILE. - Use qt4-linguisttools for localization. - Add DB option group for reports database (taken from misc/krecipes-kde4). - Strip binaries. - Regenerate patch-configure with 'make makepatch'. - Bump PORTREVISION. PR: 202044 Submitted by: s3erios@gmail.com Approved by: horia@racoviceanu.com
Notes
Notes: svn path=/head/; revision=394649
-rw-r--r--sysutils/qpxtool/Makefile20
-rw-r--r--sysutils/qpxtool/files/patch-configure12
2 files changed, 24 insertions, 8 deletions
diff --git a/sysutils/qpxtool/Makefile b/sysutils/qpxtool/Makefile
index e1f64c01bbc6..635e690b0885 100644
--- a/sysutils/qpxtool/Makefile
+++ b/sysutils/qpxtool/Makefile
@@ -3,26 +3,42 @@
PORTNAME= qpxtool
PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION:C/\.[^.]*$/.x/}/${DISTVERSION}
MAINTAINER= horia@racoviceanu.com
COMMENT= GUI for testing CD/DVD quality and transfer rate
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USES= gmake tar:bzip2
-USE_QT4= qmake_build moc_build rcc_build linguist_build corelib gui network sql
+USE_QT4= qmake_build moc_build rcc_build linguisttools_build \
+ corelib gui network sql
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
USE_LDCONFIG= yes
+OPTIONS_GROUP= DB
+OPTIONS_GROUP_DB= SQLITE MYSQL PGSQL
+OPTIONS_DEFAULT= SQLITE
+
+SQLITE_USE= QT4=sql-sqlite3_run
+MYSQL_USE= QT4=sql-mysql_run
+PGSQL_USE= QT4=sql-pgsql_run
+
post-configure:
@${REINPLACE_CMD} -e 's|$$(QMAKE4)|& ${QMAKE_AGRS}|' \
${WRKSRC}/gui/Makefile
@${REINPLACE_CMD} -e 's|S_ISBLK|S_ISCHR|' \
${WRKSRC}/lib/qpxtransport/qpx_mmc.cpp
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* \
+ ${STAGEDIR}${PREFIX}/sbin/pxfw
+
.include <bsd.port.mk>
diff --git a/sysutils/qpxtool/files/patch-configure b/sysutils/qpxtool/files/patch-configure
index d2cb2cd66fe5..c37715f9823e 100644
--- a/sysutils/qpxtool/files/patch-configure
+++ b/sysutils/qpxtool/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-03-27 19:25:38.000000000 +0300
-+++ configure 2010-04-25 07:56:54.000000000 +0400
-@@ -13,10 +13,10 @@
+--- configure.orig 2012-12-04 12:06:33 UTC
++++ configure
+@@ -13,10 +13,10 @@ OSLIBS_INET=""
OSLIBS_DL=""
OSLIBS_THREAD=""
@@ -15,7 +15,7 @@
__enable_debug=no
__enable_png=yes
__enable_gui=yes
-@@ -261,8 +261,8 @@
+@@ -344,8 +344,8 @@ LPNG_LIB = $lpng_ldflags
" >> Makefile
@@ -26,7 +26,7 @@
if test "$__enable_debug" = "yes" ; then
echo "# additional debug options" >> Makefile
-@@ -407,7 +407,7 @@
+@@ -491,7 +491,7 @@ else
fi
fi
fi
@@ -35,7 +35,7 @@
echo "
clean: Makefile.qmake
-@@ -765,7 +765,7 @@
+@@ -846,7 +846,7 @@ case "$OSL" in
__libdir=$__prefix/lib
__plugindir=$__libdir/qpxtool
__incdir=$__prefix/include