aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-02-19 10:20:44 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-02-19 10:20:44 +0000
commit419892c3f71e4cf7613817c46d851fca4a25b792 (patch)
tree82ba390632efe019b95160a4ad0da38d2c50d743
parent17fb61759c9ce626a0c0c12c4f5e245333ecb066 (diff)
downloadports-419892c3f71e4cf7613817c46d851fca4a25b792.tar.gz
ports-419892c3f71e4cf7613817c46d851fca4a25b792.zip
mark BORKED until finished
Notes
Notes: svn path=/head/; revision=75877
-rw-r--r--devel/autoconf257/Makefile20
-rw-r--r--devel/autoconf257/pkg-comment1
-rw-r--r--devel/autoconf257/pkg-plist56
-rw-r--r--devel/autoconf259/Makefile20
-rw-r--r--devel/autoconf259/pkg-comment1
-rw-r--r--devel/autoconf259/pkg-plist56
-rw-r--r--devel/autoconf26/Makefile20
-rw-r--r--devel/autoconf26/pkg-comment1
-rw-r--r--devel/autoconf26/pkg-plist56
-rw-r--r--devel/autoconf261/Makefile20
-rw-r--r--devel/autoconf261/pkg-comment1
-rw-r--r--devel/autoconf261/pkg-plist56
-rw-r--r--devel/autoconf262/Makefile20
-rw-r--r--devel/autoconf262/pkg-comment1
-rw-r--r--devel/autoconf262/pkg-plist56
-rw-r--r--devel/autoconf267/Makefile20
-rw-r--r--devel/autoconf267/pkg-comment1
-rw-r--r--devel/autoconf267/pkg-plist56
-rw-r--r--devel/autoconf268/Makefile20
-rw-r--r--devel/autoconf268/pkg-comment1
-rw-r--r--devel/autoconf268/pkg-plist56
-rw-r--r--devel/gnu-autoconf/Makefile20
-rw-r--r--devel/gnu-autoconf/pkg-comment1
-rw-r--r--devel/gnu-autoconf/pkg-plist56
24 files changed, 504 insertions, 112 deletions
diff --git a/devel/autoconf257/Makefile b/devel/autoconf257/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf257/Makefile
+++ b/devel/autoconf257/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf257/pkg-comment b/devel/autoconf257/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf257/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf257/pkg-plist b/devel/autoconf257/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf257/pkg-plist
+++ b/devel/autoconf257/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf259/pkg-comment b/devel/autoconf259/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf259/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf259/pkg-plist b/devel/autoconf259/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf259/pkg-plist
+++ b/devel/autoconf259/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf26/Makefile b/devel/autoconf26/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf26/Makefile
+++ b/devel/autoconf26/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf26/pkg-comment b/devel/autoconf26/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf26/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf26/pkg-plist b/devel/autoconf26/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf26/pkg-plist
+++ b/devel/autoconf26/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf261/Makefile b/devel/autoconf261/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf261/Makefile
+++ b/devel/autoconf261/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf261/pkg-comment b/devel/autoconf261/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf261/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf261/pkg-plist b/devel/autoconf261/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf261/pkg-plist
+++ b/devel/autoconf261/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf262/pkg-comment b/devel/autoconf262/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf262/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf262/pkg-plist b/devel/autoconf262/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf262/pkg-plist
+++ b/devel/autoconf262/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf267/Makefile b/devel/autoconf267/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf267/Makefile
+++ b/devel/autoconf267/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf267/pkg-comment b/devel/autoconf267/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf267/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf267/pkg-plist b/devel/autoconf267/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf267/pkg-plist
+++ b/devel/autoconf267/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/autoconf268/Makefile b/devel/autoconf268/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/autoconf268/Makefile
+++ b/devel/autoconf268/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf268/pkg-comment b/devel/autoconf268/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/autoconf268/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/autoconf268/pkg-plist b/devel/autoconf268/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/autoconf268/pkg-plist
+++ b/devel/autoconf268/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info
diff --git a/devel/gnu-autoconf/Makefile b/devel/gnu-autoconf/Makefile
index b370e3faa3ad..637450dbe5c1 100644
--- a/devel/gnu-autoconf/Makefile
+++ b/devel/gnu-autoconf/Makefile
@@ -14,19 +14,20 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-BROKEN= This port is not finished yet
+BROKEN= Work is in progress right now.
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=257
@@ -48,16 +49,6 @@ GENERIC_TOOLS= config.guess \
missing \
mkinstalldirs
-MAN1= autoconf.1 \
- autoheader.1 \
- autom4te.1 \
- autoreconf.1 \
- autoscan.1 \
- autoupdate.1 \
- config.guess.1 \
- config.sub.1 \
- ifnames.1
-
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything:
@${ECHO} ===========================================================
@@ -69,8 +60,11 @@ pre-everything:
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/gnu-autoconf/pkg-comment b/devel/gnu-autoconf/pkg-comment
deleted file mode 100644
index 6922f03c2b32..000000000000
--- a/devel/gnu-autoconf/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Automatically configure source code on many Un*x platforms
diff --git a/devel/gnu-autoconf/pkg-plist b/devel/gnu-autoconf/pkg-plist
index e69de29bb2d1..cf839ff11440 100644
--- a/devel/gnu-autoconf/pkg-plist
+++ b/devel/gnu-autoconf/pkg-plist
@@ -0,0 +1,56 @@
+bin/autoconf257
+bin/autoheader257
+bin/autom4te257
+bin/autoreconf257
+bin/autoscan257
+bin/autoupdate257
+bin/ifnames257
+info/autoconf.info
+info/dir
+info/standards.info
+share/autoconf257/Autom4te/General.pm
+share/autoconf257/Autom4te/Struct.pm
+share/autoconf257/Autom4te/XFile.pm
+share/autoconf257/INSTALL
+share/autoconf257/autoconf/autoconf.m4
+share/autoconf257/autoconf/autoconf.m4f
+share/autoconf257/autoconf/autoheader.m4
+share/autoconf257/autoconf/autoscan.m4
+share/autoconf257/autoconf/autotest.m4
+share/autoconf257/autoconf/autoupdate.m4
+share/autoconf257/autoconf/c.m4
+share/autoconf257/autoconf/fortran.m4
+share/autoconf257/autoconf/functions.m4
+share/autoconf257/autoconf/general.m4
+share/autoconf257/autoconf/headers.m4
+share/autoconf257/autoconf/lang.m4
+share/autoconf257/autoconf/libs.m4
+share/autoconf257/autoconf/oldnames.m4
+share/autoconf257/autoconf/programs.m4
+share/autoconf257/autoconf/specific.m4
+share/autoconf257/autoconf/status.m4
+share/autoconf257/autoconf/types.m4
+share/autoconf257/autom4te.cfg
+share/autoconf257/autoscan/autoscan.list
+share/autoconf257/autotest/autotest.m4
+share/autoconf257/autotest/autotest.m4f
+share/autoconf257/autotest/general.m4
+share/autoconf257/config.guess
+share/autoconf257/config.sub
+share/autoconf257/elisp-comp
+share/autoconf257/install-sh
+share/autoconf257/m4sugar/m4sh.m4
+share/autoconf257/m4sugar/m4sh.m4f
+share/autoconf257/m4sugar/m4sugar.m4
+share/autoconf257/m4sugar/m4sugar.m4f
+share/autoconf257/m4sugar/version.m4
+share/autoconf257/mdate-sh
+share/autoconf257/missing
+share/autoconf257/mkinstalldirs
+@dirrm share/autoconf257/m4sugar
+@dirrm share/autoconf257/autotest
+@dirrm share/autoconf257/autoscan
+@dirrm share/autoconf257/autoconf
+@dirrm share/autoconf257/Autom4te
+@dirrm share/autoconf257
+@dirrm info