aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Jensen <erik@tenku.dk>2023-04-05 09:59:00 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-04-05 11:25:36 +0000
commit41a479ef801eb1f07456637e90afdecce951659b (patch)
tree3574000bef034e80bdfefa4aa628e7b426d00d64
parentbcb1cd7f7a0a522ccdfe1f2bd3422d0c42d3f8f6 (diff)
downloadports-41a479ef801eb1f07456637e90afdecce951659b.tar.gz
ports-41a479ef801eb1f07456637e90afdecce951659b.zip
devel/root: Remove 12.3 workaround and clean up
Remove build workaround for 12.3 re-added in last commit by mistake that was removed in 5693229 commit. Cleanup port and delete scripts dir used by workaround. PR: 270625 MFH: 2023Q2 (buildfixes)
-rw-r--r--devel/root/Makefile13
-rwxr-xr-xdevel/root/scripts/remove-modules-from-modulemap.awk9
-rwxr-xr-xdevel/root/scripts/remove-modules-from-modulemap.sh7
3 files changed, 1 insertions, 28 deletions
diff --git a/devel/root/Makefile b/devel/root/Makefile
index b9e7ccbef2e4..2f954fbc8a17 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -82,15 +82,4 @@ PLIST_SUB+= ONLY_INSTALLED_WITH_LLVM_CLANG_13=""
PLIST_SUB+= ONLY_INSTALLED_WITH_LLVM_CLANG_13="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-# In LLVM/Clang 10.0.1 (used on FreeBSD 12.3), the cstdalign header is missing from the std modulemap, but it is declared included in ROOT's std modulemap - this has to be removed.
-# See https://github.com/llvm/llvm-project/blob/main/libcxx/include/module.modulemap.in#L181
-# The same seems to be the case for the other headers defined in the variable "modules" below.
-.if ${OSVERSION} < 1204000
-modules= cstdalign cuchar experimental/string_view ext/functional ext/numeric ext/type_traits.h bits_alloc_traits_h bits/allocator.h bits/basic_ios.h bits/cpp_type_traits.h bits/exception_defines.h bits/ios_base.h bits/locale_facets.h bits_stl_algobase_h bits_stl_iterator_h bits/stl_iterator_base_types.h bits/stl_map.h bits/stl_pair.h bits_stl_tree_h bits/uniform_int_dist.h
-post-patch:
- SCRIPTDIR=${SCRIPTDIR} MODULEMAP=${WRKSRC}/interpreter/cling/include/cling/std.modulemap ${SH} ${SCRIPTDIR}/remove-modules-from-modulemap.sh "${modules}"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/root/scripts/remove-modules-from-modulemap.awk b/devel/root/scripts/remove-modules-from-modulemap.awk
deleted file mode 100755
index adabed818d2f..000000000000
--- a/devel/root/scripts/remove-modules-from-modulemap.awk
+++ /dev/null
@@ -1,9 +0,0 @@
-BEGIN {
- exclude = exclude; #trim left and right
- gsub(/[[:blank:]]/, "|", exclude);
- gsub(/\//, "\\/", exclude);
- ex_regx = "module[[:blank:]]+\"(" exclude ")\".*{[[:blank:]]*$";
-}
-
-$0 ~ ex_regx, $0 ~ /^[[:blank:]]*}[[:blank:]]*$/ { next ; }
-{print}
diff --git a/devel/root/scripts/remove-modules-from-modulemap.sh b/devel/root/scripts/remove-modules-from-modulemap.sh
deleted file mode 100755
index c118c7637bf0..000000000000
--- a/devel/root/scripts/remove-modules-from-modulemap.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-# Script removes module definition blocks in LLVM/Clang .modulemap
-# files "in-place" in the file path stored in the variable MODULEMAP
-
-modules=$1
-tmp=${MODULEMAP}.tmp && awk -f ${SCRIPTDIR}/remove-modules-from-modulemap.awk -v exclude="${modules}" ${MODULEMAP} > ${tmp} && mv ${tmp} ${MODULEMAP} || rm ${tmp}