aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-05-24 07:09:35 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-25 09:39:33 +0000
commit41cce74a9e4c1727c4120517724059f68f27404f (patch)
tree4b896801396e73d64fb4ba21ecfbb2297339e14b
parent55b63657a7c57ad5ee8fe0766dcb1604f2237e24 (diff)
downloadports-41cce74a9e4c1727c4120517724059f68f27404f.tar.gz
ports-41cce74a9e4c1727c4120517724059f68f27404f.zip
biology/py-pysam: unbundle biology/htslib
This fixes the build on armv7 by picking up our custom fixed libhts over the bundled unfixed version. The CFLAGS workaround is now no longer required either. Approved by: yuri (maintainer) Differential Revision: https://reviews.freebsd.org/D40251
-rw-r--r--biology/py-pysam/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/biology/py-pysam/Makefile b/biology/py-pysam/Makefile
index 5cd1b27a49a0..10e1d55b786e 100644
--- a/biology/py-pysam/Makefile
+++ b/biology/py-pysam/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pysam
DISTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= biology python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,15 @@ WWW= https://github.com/pysam-developers/pysam
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libhts.so:biology/htslib
+
USES= gmake python:3.6-3.9
USE_PYTHON= autoplist distutils cython cython_run pytest
-CFLAGS+= -fPIC # workaround for https://github.com/pysam-developers/pysam/issues/1146
-
BINARY_ALIAS= make=${GMAKE}
+MAKE_ENV= HTSLIB_MODE=external \
+ HTSLIB_LIBRARY_DIR=${LOCALBASE}/lib \
+ HTSLIB_INCLUDE_DIR=${LOCALBASE}/include
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pysam/lib*${PYTHON_EXT_SUFFIX}.so