aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2021-05-05 17:01:23 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2021-05-05 17:03:25 +0000
commit41f30e3a1f9c00af87bbb9124fe89b35d6fb89f4 (patch)
treeba4d31b548bf5f9d2aa25250a5a4a6c0fc019064
parented94bb1c1d03492bc55013a0637570a7bea5f3e1 (diff)
downloadports-41f30e3a1f9c00af87bbb9124fe89b35d6fb89f4.tar.gz
ports-41f30e3a1f9c00af87bbb9124fe89b35d6fb89f4.zip
net/haproxy: add lua flavor.
PR: 255052 Submitted by: Mark Deneen <mdeneen@gmail.com>
-rw-r--r--net/haproxy/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 7cca987cebb6..7c0d9d21467b 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -11,6 +11,13 @@ COMMENT= Reliable, high performance TCP/HTTP load balancer
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
+FLAVORS= default lua
+FLAVOR?= ${FLAVORS:[1]}
+
+default_CONFLICTS_INSTALL= haproxy-lua
+lua_CONFLICTS_INSTALL= haproxy
+lua_PKGNAMESUFFIX= -lua
+
CONFLICTS_INSTALL= haproxy-devel-[0-9]* haproxy17-[0-9]* haproxy18-[0-9]* haproxy19-[0-9]* haproxy20-[0-9]* haproxy21-[0-9]*
USES= compiler:c++11-lang cpe gmake
@@ -41,6 +48,10 @@ OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
LUA_USES= lua:53
LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
+.if ${FLAVOR:U} == lua
+OPTIONS_DEFAULT+= LUA
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386"