aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-27 14:44:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-27 15:05:16 +0000
commit421153eccef8f5443584cace7c336e1072773662 (patch)
treea0d4a2039297ffef3c392167a48c9bcb707162d3
parentedc1905c1243d4679895f6bfc2998ca9ab37e5be (diff)
downloadports-421153eccef8f5443584cace7c336e1072773662.tar.gz
ports-421153eccef8f5443584cace7c336e1072773662.zip
gnome.mk: fix usage of GLIB_SCHEMAS in five ports
Glib schema files should be registered using the GLIB_SCHEMAS variable provided by gnome.mk. This will add them and additionally the required glib-schemas keyword to the plist. The following ports were touched: * deskutils/foliate * deskutils/gnome-tweaks * deskutils/maliit-keyboard * games/swell-foop * textproc/ibus-m17n
-rw-r--r--deskutils/foliate/Makefile4
-rw-r--r--deskutils/foliate/pkg-plist1
-rw-r--r--deskutils/gnome-tweaks/Makefile2
-rw-r--r--deskutils/gnome-tweaks/pkg-plist1
-rw-r--r--deskutils/maliit-keyboard/Makefile2
-rw-r--r--deskutils/maliit-keyboard/pkg-plist1
-rw-r--r--games/swell-foop/Makefile2
-rw-r--r--games/swell-foop/pkg-plist1
-rw-r--r--textproc/ibus-m17n/Makefile2
-rw-r--r--textproc/ibus-m17n/pkg-plist1
10 files changed, 10 insertions, 7 deletions
diff --git a/deskutils/foliate/Makefile b/deskutils/foliate/Makefile
index d61862693484..9ac9d3834809 100644
--- a/deskutils/foliate/Makefile
+++ b/deskutils/foliate/Makefile
@@ -1,5 +1,6 @@
PORTNAME= foliate
PORTVERSION= 2.6.3
+PORTREVISION= 1
CATEGORIES= deskutils
MAINTAINER= fox@FreeBSD.org
@@ -15,6 +16,7 @@ RUN_DEPENDS= gjs-console:lang/gjs
USES= desktop-file-utils gnome localbase meson python:3.6+ shebangfix
USE_GNOME= cairo gtk30 introspection
+GLIB_SCHEMAS= com.github.johnfactotum.Foliate.gschema.xml
INSTALLS_ICONS= yes
@@ -29,8 +31,6 @@ NLS_USES= gettext
USE_GITHUB= yes
GH_ACCOUNT= johnfactotum
-GLIB_SCHEMAS= com.github.johnfactotum.Foliate.gschema.xml
-
post-patch:
@${REINPLACE_CMD} -e 's/@PYTHON_VERSION@/${PYTHON_VERSION}/g' \
${WRKSRC}/src/epubView.js
diff --git a/deskutils/foliate/pkg-plist b/deskutils/foliate/pkg-plist
index 5b41361e8104..1dbac0a01d79 100644
--- a/deskutils/foliate/pkg-plist
+++ b/deskutils/foliate/pkg-plist
@@ -45,7 +45,6 @@ share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src
share/com.github.johnfactotum.Foliate/assets/libarchivejs/main.js
share/com.github.johnfactotum.Foliate/com.github.johnfactotum.Foliate.data.gresource
share/com.github.johnfactotum.Foliate/com.github.johnfactotum.Foliate.src.gresource
-share/glib-2.0/schemas/com.github.johnfactotum.Foliate.gschema.xml
share/icons/hicolor/scalable/apps/com.github.johnfactotum.Foliate.svg
share/icons/hicolor/symbolic/apps/com.github.johnfactotum.Foliate-symbolic.svg
share/locale/cs/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
diff --git a/deskutils/gnome-tweaks/Makefile b/deskutils/gnome-tweaks/Makefile
index 72cf51641c10..157f8a30f9f6 100644
--- a/deskutils/gnome-tweaks/Makefile
+++ b/deskutils/gnome-tweaks/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gnome-tweaks
PORTVERSION= 40.0
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
@@ -21,6 +22,7 @@ RUN_DEPENDS= gnome-shell>=3.28:x11/gnome-shell \
USES= gettext gnome localbase meson pkgconfig python:3.4+ shebangfix \
tar:xz
USE_GNOME= gtk30 nautilus3 pygobject3
+GLIB_SCHEMAS= org.gnome.tweaks.gschema.xml
SHEBANG_FILES= gnome-tweak-tool-lid-inhibitor gnome-tweaks \
meson-postinstall.py
BINARY_ALIAS= python3=${PYTHON_VERSION}
diff --git a/deskutils/gnome-tweaks/pkg-plist b/deskutils/gnome-tweaks/pkg-plist
index ae6a06ba2e22..0900cebce6a2 100644
--- a/deskutils/gnome-tweaks/pkg-plist
+++ b/deskutils/gnome-tweaks/pkg-plist
@@ -73,7 +73,6 @@ bin/gnome-tweaks
%%PYTHON_SITELIBDIR%%/gtweak/widgets.py
libexec/gnome-tweak-tool-lid-inhibitor
share/applications/org.gnome.tweaks.desktop
-share/glib-2.0/schemas/org.gnome.tweaks.gschema.xml
%%DATADIR%%/shell.css
%%DATADIR%%/shell.ui
share/icons/hicolor/scalable/apps/org.gnome.tweaks.svg
diff --git a/deskutils/maliit-keyboard/Makefile b/deskutils/maliit-keyboard/Makefile
index 8c712cae7b7f..65424c4485bb 100644
--- a/deskutils/maliit-keyboard/Makefile
+++ b/deskutils/maliit-keyboard/Makefile
@@ -1,5 +1,6 @@
PORTNAME= keyboard
DISTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= deskutils kde
PKGNAMEPREFIX= maliit-
@@ -16,6 +17,7 @@ USES= cmake gettext-runtime gnome pkgconfig qt:5
USE_GITHUB= yes
GH_ACCOUNT= maliit
USE_GNOME= glib20
+GLIB_SCHEMAS= org.maliit.keyboard.maliit.gschema.xml
USE_QT= core dbus declarative gui multimedia network \
buildtools_build qmake_build
CMAKE_OFF= enable-tests
diff --git a/deskutils/maliit-keyboard/pkg-plist b/deskutils/maliit-keyboard/pkg-plist
index c86e0e3c922a..4d9721bd051e 100644
--- a/deskutils/maliit-keyboard/pkg-plist
+++ b/deskutils/maliit-keyboard/pkg-plist
@@ -271,7 +271,6 @@ share/doc/maliit-keyboard/COPYING
share/doc/maliit-keyboard/COPYING.BSD
share/doc/maliit-keyboard/COPYING.CC-BY
share/doc/maliit-keyboard/README.md
-share/glib-2.0/schemas/org.maliit.keyboard.maliit.gschema.xml
share/maliit/keyboard2/devices/default.json
share/maliit/keyboard2/devices/tablet.json
share/maliit/keyboard2/icons/erase.png
diff --git a/games/swell-foop/Makefile b/games/swell-foop/Makefile
index 08b47b845aab..6a2199bc009c 100644
--- a/games/swell-foop/Makefile
+++ b/games/swell-foop/Makefile
@@ -2,6 +2,7 @@
PORTNAME= swell-foop
PORTVERSION= 40.1
+PORTREVISION= 1
CATEGORIES= games gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome
@@ -23,6 +24,7 @@ PORTSCOUT= limitw:1,even
USES= gettext gnome localbase meson pkgconfig python:3.6+,build \
tar:xz
USE_GNOME= gtk30
+GLIB_SCHEMAS= org.gnome.SwellFoop.gschema.xml
INSTALLS_ICONS= yes
BINARY_ALIAS= python3=${PYTHON_VERSION}
diff --git a/games/swell-foop/pkg-plist b/games/swell-foop/pkg-plist
index 59b0aa08b6b8..82097519256d 100644
--- a/games/swell-foop/pkg-plist
+++ b/games/swell-foop/pkg-plist
@@ -1,7 +1,6 @@
bin/swell-foop
share/applications/org.gnome.SwellFoop.desktop
share/dbus-1/services/org.gnome.SwellFoop.service
-share/glib-2.0/schemas/org.gnome.SwellFoop.gschema.xml
share/help/C/swell-foop/figures/logo.png
share/help/C/swell-foop/figures/start-game.png
share/help/C/swell-foop/index.page
diff --git a/textproc/ibus-m17n/Makefile b/textproc/ibus-m17n/Makefile
index d13e2522cf40..6b785b8b9d6c 100644
--- a/textproc/ibus-m17n/Makefile
+++ b/textproc/ibus-m17n/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ibus-m17n
DISTVERSION= 1.4.7
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= yuri@FreeBSD.org
@@ -24,6 +25,7 @@ GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= ibus
USE_GNOME= glib20 gtk20 atk gdkpixbuf2 cairo pango intltool
+GLIB_SCHEMAS= org.freedesktop.ibus.engine.m17n.gschema.xml
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/textproc/ibus-m17n/pkg-plist b/textproc/ibus-m17n/pkg-plist
index 333bf4c596c6..81b092ad1578 100644
--- a/textproc/ibus-m17n/pkg-plist
+++ b/textproc/ibus-m17n/pkg-plist
@@ -1,7 +1,6 @@
libexec/ibus-engine-m17n
libexec/ibus-setup-m17n
share/applications/ibus-setup-m17n.desktop
-share/glib-2.0/schemas/org.freedesktop.ibus.engine.m17n.gschema.xml
%%DATADIR%%/default.xml
%%DATADIR%%/icons/ibus-m17n.svg
%%DATADIR%%/setup/ibus-m17n-preferences.ui