aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2022-11-05 23:16:40 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2022-11-05 23:17:19 +0000
commit423dc091d5bf4ac5ee47397959538fb84b301d7c (patch)
tree52683b7c554c44c42d7086b9d95d1c7ece25cc19
parentdd7da5bb7e126f25a8c29307a9cffa50c959d281 (diff)
downloadports-423dc091d5bf4ac5ee47397959538fb84b301d7c.tar.gz
ports-423dc091d5bf4ac5ee47397959538fb84b301d7c.zip
audio/grip: No longer cater to GCC 4.2
Remove code catering to GCC 4.2 (as system compiler) which is not necessary any longer sincer USES=compiler and USE_GCC never will pull that in any more. This reverts much of commit 2d32b6c73c040e43af60ab5c05912e333704cea from 3+ years ago. Approved by: maintainer
-rw-r--r--audio/grip/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 6f7fb3d4fa3e..c6b6ade0ee30 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -49,8 +49,6 @@ DEFAULT_CDROM_DEVICE= ${WITH_CDROM_DEVICE}
DEFAULT_CDROM_DEVICE= /dev/cd0
.endif
-.include <bsd.port.pre.mk>
-
pre-everything::
.if !defined(WITH_CDROM_DEVICE)
@${ECHO_MSG} "===> The default CDROM device is ${DEFAULT_CDROM_DEVICE}"
@@ -61,8 +59,5 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/src/grip.c
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
- ${REINPLACE_CMD} -e '/pragma/d' ${WRKSRC}/src/cdpar.c
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>